System does not respect power management rules

How do I prevent automatic suspend/sleep/shutdown/monitor off when I’m running a WM like qtile? I’ve had a look at the ArchWiki Power Management article, and tried to control it with Xfce’s Power Management, as well as the DE independent Powerkit tool, but neither work. I made sure to add Powerkit to autorun at startup, and turned off the screensaver with xscreensaver, but despite that the monitor still turns itself off after x minutes. It is not a hardware feature, as it has not been an issue with other DEs/WMs.

I do not need complex power management. It is a desktop computer, and I do not want it to auto suspend, shutdown, or turn off its monitor unless I tell it to. How can I achieve this when software rules do not seem to be respected?

There is probably some conflict, something is overriding your settings.

Check if you have any systemd services enabled related to suspend, sleep, etc.

  accounts-daemon.service                                                                   loaded active running Accounts Service
  alsa-restore.service                                                                      loaded active exited  Save/Restore Sound Card >
  avahi-daemon.service                                                                      loaded active running Avahi mDNS/DNS-SD Stack
  cups.service                                                                              loaded active running CUPS Scheduler
  dbus.service                                                                              loaded active running D-Bus System Message Bus
  kmod-static-nodes.service                                                                 loaded active exited  Create List of Static De>
  lightdm.service                                                                           loaded active running Light Display Manager
  lm_sensors.service                                                                        loaded active exited  Initialize hardware moni>
  lvm2-monitor.service                                                                      loaded active exited  Monitoring of LVM2 mirro>
  mullvad-daemon.service                                                                    loaded active running Mullvad VPN daemon
  NetworkManager-wait-online.service                                                        loaded active exited  Network Manager Wait Onl>
  NetworkManager.service                                                                    loaded active running Network Manager
  polkit.service                                                                            loaded active running Authorization Manager
  rtkit-daemon.service                                                                      loaded active running RealtimeKit Scheduling P>
  systemd-binfmt.service                                                                    loaded active exited  Set Up Additional Binary>
  systemd-fsck@dev-disk-by\x2duuid-7116b4fb\x2d5ed4\x2d4583\x2d8324\x2d0530ea2ef085.service loaded active exited  File System Check on /de>
  systemd-fsck@dev-disk-by\x2duuid-D8A5\x2dEAFE.service                                     loaded active exited  File System Check on /de>
  systemd-journal-flush.service                                                             loaded active exited  Flush Journal to Persist>
  systemd-journald.service                                                                  loaded active running Journal Service
  systemd-logind.service                                                                    loaded active running User Login Management
  systemd-modules-load.service                                                              loaded active exited  Load Kernel Modules
  systemd-random-seed.service                                                               loaded active exited  Load/Save Random Seed
  systemd-remount-fs.service                                                                loaded active exited  Remount Root and Kernel >
  systemd-sysctl.service                                                                    loaded active exited  Apply Kernel Variables
  systemd-timesyncd.service                                                                 loaded active running Network Time Synchroniza>
  systemd-tmpfiles-setup-dev.service                                                        loaded active exited  Create Static Device Nod>
  systemd-tmpfiles-setup.service                                                            loaded active exited  Create Volatile Files an>
  systemd-udev-trigger.service                                                              loaded active exited  Coldplug All udev Devices
  systemd-udevd.service                                                                     loaded active running Rule-based Manager for D>
  systemd-update-utmp.service                                                               loaded active exited  Record System Boot/Shutd>
  systemd-user-sessions.service                                                             loaded active exited  Permit User Sessions
  tlp.service                                                                               loaded active exited  TLP system startup/shutd>
  udisks2.service                                                                           loaded active running Disk Manager
  upower.service                                                                            loaded active running Daemon for power managem>
  user-runtime-dir@1000.service                                                             loaded active exited  User Runtime Directory />
  user@1000.service                                                                         loaded active running User Manager for UID 1000

Could it be TLP? Upower?

You don’t need tlp on a desktop, so feel free to disable it.

See if that helps.

1 Like

That’s questionable, sometimes you do actually need it on any system, but in reverse.:upside_down_face:
For example to disable some stuff like HDD stops…

But that’s a matter of configuration

1 Like

Disabled, I’ll let you know if it helps. Does it ship with EOS or has it snuck in with something else I’ve installed?

It ships with EndeavourOS.

@keybreak yeah, that’s a good point.

1 Like

Doesn’t seem to be tlp, monitor still turned off.

Any other ideas? I looked through /etc/systemd/logind.conf and IdleAction is set to Ignore so it shouldn’t interfere. I haven’t seen the system sleep, so it is possible that is now functioning fine, but it definitely still turns off the display after ~20 minutes. Couldn’t find an option for this in the systemd config. Where else could I look?

Hardware settings on the monitor? Maybe it has a built in sleep function.

1 Like

As I wrote in the initial post, it is not a hardware issue. It has worked fine with Gnome, Bspwm and KDE. Just to confirm, I checked the monitor settings now and it is not set to sleep/poweroff by itself.