System detects two "Built-in Audio", defaults to dummy one

As per the title, rebooting my system after a few days of uptime, I found myself with two “Built-in Audio” instead of the only one included in my laptop (integrated audio card)

lspci -knn|grep -iA2 audio
00:1f.3 Audio device [0403]: Intel Corporation Sunrise Point-LP HD Audio [8086:9d70] (rev 21)
	Subsystem: ASUSTeK Computer Inc. Device [1043:1280]
	Kernel driver in use: snd_hda_intel

Worst is, my system would default to the non-working sort-of-dummy one (top one in the picture)

By turning it off, I manage to get default audio redirected to the “real” output

This way I would be able to use normally my laptop, if it were not that the Volume Up and Volume Down keys and applet do not affect the audio output through the real sound card.
I took the chance to switch from pulseaudio to pipewire in the process, but the situation is exactly the same with both.

Is there a way to remove this dummy card, or to re-associate the MATE audio widget to the correct one?
Thank you in advance

UPDATE: As suggested by @ricklinux , installing sof-firmware partially did the trick. Now Volume up and down work like a charm, and so does the MATE audio applet.
The dummy card is still listed, but at this point it seems completely innocuous. As per the marked solution, hopefully a fix will be delivered (by chance or intention) for this in some future update

tried pavucontrol already?

1 Like

Unfortunately it seems to be the same, unless I missed any option

Here to I can turn off that secondary dummy card, but not get rid of it

Check if these are installed?

sudo pacman -Sy sof-firmware alsa-ucm-conf
1 Like

After check this command and post the link

sudo dmesg | grep sof | eos-sendlog

Edit: Not sure if i got this command correct but try and see?

Thank you so much, I was missing sof-firmware!
After installing it, now the Volume up and down work like a charm, and so does the MATE audio applet.
This is the output of the command

The dummy card is still listed, but at this point it seems completely innocuous.

Did you re-enable the output of the dummy card?

No, I left it disabled

Try enabling it for a minute and reboot.

If I re-enable the dummy built-in stereo, the Volume up and down gets again associated to it rather than to the real built-in stereo
(in the picture, I am playing some audio as shown in the upper volume visualiser)

You could try one thing. Not sure if this file exists.

cat /etc/modprobe.d/inteldsp.conf 

No, I do not have that file

ls /etc/modprobe.d/
droidcam.conf  list.conf

You could try and i don’t know if this will work

create the file

/etc/modprobe.d/inteldsp.conf 

add

options snd-intel-dspcfg dsp_driver=1

Need help with that?

I have created the file, should I run any additional command or proceed to reboot?

You probably need to reboot. Again i would enable the audio output on the dummy first.

Or not :man_shrugging:

No change unfortunately!
However, the main issue is solved at least, and I am very grateful to you for all
the help!!

Just remove that file then.

May i ask what the hardware is? Laptop?

Sure! It’s an ASUS ZenBook UX310UA-GL100T