System crashes in idle / low load

  • AMD Ryzen 3800X
  • Asus X370 Prime Pro (newest not Beta Bios)
  • 32GB DDR4-3200 HyperX
  • Samsung 970Pro 1TB Nvme
  • AMD RX6700 XT

Things I checked:

  • Memtest OK
  • SSD OK
  • Temperatures OK
  • Voltages OK
  • Kernel 6.3.9

Things I have done with no result:

  • changed BIOS from “low current idle” to “typical idle”
  • deactivate C-States in BIOS

The System only crashes when in idle or under low load.
When it crashes the gui hangs and sound repeate’s.
System is no more accessible over SSH from another System.

I looked at the logs (like in the wiki), but there are no entries releated to this issue.

Is there any possibility to activate extra logs?
Like crash dumps? Or crash messages?

1 Like

Try to exclude PSU by using other one temporary borrowed from a friend…

It can be a lot of things, but…

  • 32GB DDR4-3200 HyperX

Because KIngston is absolute garbage - try anything other than kingston in your system, one RAM at a time, to exclude it…But if i were you those would be in my trash-bin regardless :laughing:

yes, I tried this with another psu from my other system.
both are Seasonic Focus GX one with 750W and one with 650W.

Issue remains.

The ram is ok, I testet it 2 passes with Memtest. No issue there.

This tells not much unfortunately, even memtest devs saying that it’s not reliable to exclude all RAM problems, especially ones that is coming from idle / low states, so i suggest you try to borrow 1 non-Kingston RAM from a friend to be absolutely sure…

Usually RAM is tested by combination of memtest and prolonged ~24 hours stress-tests, but since you’re certain it’s idle / low - in my experience it’s most likely:

  1. CPU
  2. Motherboard / BIOS etc
  3. PSU
  4. RAM

Oh and how can i forget:

  1. SSD (easy to exclude, just unplug it from board and run only from live system to see if it will crash.)

I had similar issue with two of my ryzen machines.

  • Switching Power supply idle control in bios to “typical current idle” from “auto” fixed idle crash on one of them.

  • Another machine’s CPU was using an incorrect voltage at idle. The problem can be alleviated by setting the Vcore offset by 0.05V or higher. That machine is still working good to this day with 0.05v offset.

EDIT: Also, checkout this old link, sounds kind of similar:


the strange thing is, that I had this issue never unter Linux Mint 20.3 (and older versions).

When the system is under load, like gaming or compiling it never crashes.
I can run heavy loads all day without any issue.

I have only “low current idle” and “typical current idle” in the BIOS options.

I know there was a bug, a long time ago, that the kernel couldn’t wake up sleeping cores and locked up. That in mind, I deactivated the C States (in BIOS) to prevent the sleep of cpu cores.
But this doesn’t solved the issue also.

Could it be an issue with the current kernels or any other software on the system?
Is there a possibility to get more detailed logs then that described in the wiki?

Absolutely, install LTS and boot from it, to check.
Personally i’d use only LTS kernel, unless i really strongly actually need use latest for compatibility reasons (too new hardware)


I gonna try this and get back to you, if it resolved the issue

now I installed the lts kernel with this command

sudo pacman -S linux-lts linux-lts-headers

But I don’t get any selection on the grub boot menu.
Shouldn’t be this created automatically?

Re-Generate grub-mkconfig?

At the moment it looks like the system is stable.
But I don’t want to say the issue is solved.

I test the next ongoing days, and hopefully it keeps to be stable


Yes, with 6.1 LTS the system ist stable!
So ist is an issue with the 6.3.x Kernel Line.

Now I gonna Test the 6.4.x Kernel Line an See If it is stable too.

When not I can go back to 6.1 LTS

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.