Switching workspaces with mouse wheel stopped working

Seems to be a bug. When I assign workspace switching on the desktop to a different mouse action, it works. I e.G. can switch workspaces by clicking the middle button and have to select the workspace to switch to from a list.
Not as convenient as using the mouse wheel but at least a workaround.
Hope this gets fixed in the nearer future.
J.

@Jeannie Something has changed (or a bug as you suggested) in the way the scroll to switch workspaces works. If you place the cursor in the panel on any virtual desktop rectangle and scroll the mouse wheel it will change desktops/workspaces. My virtual destops are pictured in my panel at the left. (see image).
kde_desktop_scroll

I am not talking about switching workspaces with the mousewheel by placing the cursor over the desktop switcher applet, I am talking about switching workspaces with the mousewheel by placing the cursor somewhere on the desktop outside an application window, which is a different function
J.

Yes …it used to function that way on mine too and it does in Manjaro still!

Yes but which branch. If your install is on the stable branch Plasma is several versions behind EndeavourOS.

I realize that. I’m just posting another data point that the scroll wheel works within an app or widget’s territory/window. Even for switching desktops.

Any news on this?
J.

I don’t know what makes it work? It works on other plasma distro’s so something is changed? I’m surprised that some experienced Plasma user hasn’t the answer. I am using plasma but not that familiar with the inner workings at the best of times. I try my best! :smirk:

@Jeannie, I’ve found a workaround here:

https://forum.manjaro.org/t/plasma-5-18-bugs/123970/113

It seems to be a bug cause changing between desktops with the mouse wheel only works now having the desktop on “Desktop” mode but on “Folders view” mode. It would be great to get it working on both modes…let’s see if it’s fixed with the coming updates.

Yes, that works. But I can’t place anything on the desktop in “Desktop” mode, that’s a no-go for me.
J.

So, Plasma 5.19 came in today, the bug still exists.
I am really disappointed.
J

Guessing there must be a conflicting package somewhere. I just updated to 5.19 myself, and this still works without issue on my system.

Well, how to find out which package conflicts?
J.

Workspace/desktop switching via mouse wheel scroll has not worked for me in a while also. But today after reading this discussion I decided to give it another go. It works.

Here’s what I did;

  1. Right click on the desktop empty space.
  2. Choose Configure desktop
  3. Choose Mouse actions
  4. Add action
  5. Scroll wheel in little “Input here” box.
  6. Choose Vertical scroll - Switch window

I could have sworn this did not work before.

Edit: I recently switched from Breeze to Oxygen, but I don’t think that had any affect.

Tried that, but it did not work for me.
J.

Well maybe it is the theme. Like you I tried everything for months to get the switching to work and now it does. Other than updates these are the only changes I’ve made to my system in months.

I have tried it too and it’s not working for me also. I’m just using Breeze theme. Nothings changed. It only works if the cursor is on the desktop by application launcher.

It’s a little strange because it has not worked for me either and i have reinstalled fresh.

I’m beginning to think that the Arch build of 5.19 just has something horrendously wrong with it…every time I reboot there’s some NEW issue that wasn’t previously there right now. I have installed 5.19 on my work laptop (KDE Neon) and it has NONE of the issues ricklinux, Jeannie, or myself have had.

Rick, can you try the Oxygen theme? That’s all I have changed. Went from Breeze to Oxygen. Also you must have something in the workspace before it will more to the new one. I now have Chromium in Desktop 1 and Firefox in Desktop 2 and its making me seasick swapping back and forth with wheel scrolls. :rofl: