Switching workspaces with mouse wheel stopped working

For some unknown reason, the workspase switching with the mousewheel stopped working on my plasma5 desktop.
Until earlier today, I could hover with the mouse pointer over some empty space on my desktop and was able to switch workspaces with my mouse wheel.
This is not working anymore, I have to point the mouse on my workspace switcher in my panel to be able to switch workspaces now.
I would like to get the old behaviour back, but I seem not to be able to find the appropriate setting.
Could someone help me to find this setting?
Thx
J.

I had a hard time to remember it myself. :sweat_smile:
Right click on the desktop and then “configure desktop”.

Thanks for pointing me into the right direction, but that setting does not have any effect here.
J.

I have a silly thought, and so I ask “Does the scroll work properly any/everywhere else?” IF not, you cold disassemble the mouse and vacuum it out (usually the scroller is optical, and dust bunnies can block the ‘view’.

Always eliminate the easy/cheap stuff first - that’s my rule of computer troubleshooting…

Freebird54

Good advice.
It happens with three different mice, so it definitively is not a mouse problem. Scrolling works everywhere else by the way.
J.

Well - I did say it was a silly thought! That configuration screen doesn’t fix it - even after a logout/login afterwards? I am afraid I haven’t Plasma’d - I used to be a big Unity fan (for workflow reasons) and have now gone to XFCE because I can make it do most of what I’m used to, or near enough. Sorry not to be of more help…

Freebird54

Hi, @Jeannie. If you right click on the desktop, you can choose Configure Desktop. When the configuration window opens, select the Mouse Actions button on the left. Set Vertical Scroll to Switch Desktop. That should do it for you. You might also want to check your Workspace Behavior settings, under Virtual Desktop (you can also get there right clicking on the pager widget, if you have it installed) to be sure that you have a Show Animations selection enabled (mine’s the classic rotating cube, but you may have another preference).

Hope this works for you!

Barry

Checked all the settings you suggested. Everything seems to be set correctly, but the damned workspace switching on the desktop doesn’t work anymore.
J.

I wonder … is your compositor enabled? Settings > Display & Monitor > Compositor.

Yes, the compositor is enabled too.
J.

I had turned this feature off several releases ago and I just tried to activate it. No luck. My guess is it’s broken or there is a competing/conflicting setting that I can’t find.

At least you can reproduce the problem. Thanks for confirming.
J.

Maybe you can have a look at the plasma-org.kde.plasma.desktop-appletsrc under .config in your home-folder?
Right at the beginning I got the following:

[ActionPlugins][0]
MidButton;NoModifier=org.kde.paste
RightButton;NoModifier=org.kde.contextmenu
wheel:Vertical;NoModifier=org.kde.switchdesktop

I guess the line beginning with “wheel” is for the workspace-switch. If you didn’t have that line, make a backup of that file and insert it for testing.

Here are the relevant lines from my plasma-org.kde.plasma.desktop-appletsrc file

[ActionPlugins][0]
MidButton;NoModifier=org.kde.paste
RightButton;NoModifier=org.kde.contextmenu
wheel:Vertical;NoModifier=org.kde.switchdesktop

J.

I have Manajaro KDE installed and it is working with same settings. What about the Configure Window Manager…Window Actions Scroll?

A screenshot of the settings window you mentioned would be great, as my system is running in german and it’s not always easy to find a setting of which you only know the english name.
J.

Not sure if this has anything to do with it?

My settings are not different from yours.

Did you try moving the show desktop widget from the end of the task bar.

Just did that, that did not change anything.
J.