Switching to refind from grub but refind seems to just boot grub which then boots the os

After being victim of the grub issue I told myself I’d finally install refind since I’ve been meaning to for a while now.

And so I did. And it does start. I have quite a few boot options for all the OS I have installed on my computer, for endeavouros specifically I have three options, two straight up don’t work. The last does, but it boots a basic version of grub which then boots then os.

How do I just boot the os without going through grub?

With refind you can use the vmlinuz-linux image file to boot from. If you want the Icon in refind to match the desktop then just download the icon you want to use in .png and rename it to vmlinuz-linux.png. Then add it to the folder that has the vmlinuz-linux image. Then when you boot to rEFInd just hide the default icon of the penguin.


Edit: Example for Xfce


1 Like

Thanks ricklinux, that’s nice to know.

However, the issue I have is different.

I turn on my pc. Refind starts. I have it boot endeavouros. When I do that I get a black screen that says no memory. After that grub starts. Finally, edeavouros starts.

Here’s an example of what I’m describing, sorry if the quality of the video is awful:

After messing with it a little, namely removing the two hard drives that don’t have endeavouros, this is my situation:
When my computer starts refind shows two options, neither has an endeavouros logo, which I’d love to have but it’s not a big deal.
Here’s the part that ruffles my feathers: Both options try to start grub, which is not installed on my system as per picture here https://i.imgur.com/eBX9AWy.png
The first option has under the icon this line: Boot EFI\EndeavourOS\grub64.efi from NO_LABEL
Selecting that results in the following:
Starting grub64.efi
Using load options ’ ’
Error:Symbol ‘grub_debug_malloc’ not found
Entering rescue mode…
grub rescue>

The second options had below the following: Boot EFI\grub\grub64.efi from NO_LABEL

Selecting that results in the line “error out of memory” to appear something like 5 or 6 times, but the grub actually starts and I can get in my system.

This is kind of messy. Is refind SUPPOSED to start grub? If so, what’s the point of it?
Can I just get rid of it, get a properly functioning grub and use that instead?

If it’s not, how do I properly get rid of grub and have refind boot my system without passing through grub?

If you tell it to load grub - and you are doing that - yes.
Try to follow that guide:

You should have an entry in rEFInd that loads the vm_linuz of EndeavourOS - that one does not load grub. It should read vm_linuz* in the line under the icon where your used entry reads Boot EFI\grub\grub64.efi
I have hidden the grub-boot entry in rEFInd and now only have the EndeavourOS entry and the Windows entry, both do a direct boot.

Thank you BS86
And great profile picture, I used to read that webcomic ages ago.
And if 86 is your year of birth, we have the same age.

So, I went through that link, I think I’m misunderstanding something, but it doesn’t say how to add an entry that will use \boot\vmlinuz-linux which is absent at the moment on my refind.

I think the issue here is that I didn’t explain the problem I have clearly enough. Here’s a better video:

The section that shows hidden entries is empty, so it’s not hidden. It’s just not there.

Also I double checked, secure mode is, indeed, off.

Yeah, I’ve got much the same problem here. I installed refind in the hope it might fix things but it just leads to the same out of memory error.

Same here -

  • Installed refind
  • Ran sudo refind-install
  • Refind only picks up the grub entry.

BTRFS file system.

While I feel bad for you guys for having the same problem I am relieved that more are showing up with it so that people don’t think I’m insane.

1 Like

I think it’s do with the fact that refind is essentially just another type of boot manager, whereas the problem here seems to be more with grub itself.

Ok but refind should have an entry to boot with vm_linuz, which it doesn’t.
We’re missing a whole option in the boot manager here that should be there by default to the point that any person who told me what to do didn’t even consider for one moment that maybe the option was missing.

I have a sneaky feeling it may be because I have two disks and two efi partitions. I installed an NVME for Endeavour and still have Windows on the original.

I had three drives, I removed two. Now I have the endeavouros drive plus an external HD.

I’m not sure the multiple efi partitions can be blamed at this point.

BTRFS needs extra care.

Tip: make sure btrfs_x64.efi driver is installed, it can be installed manually by copying from /usr/share/refind/drivers_x64/btrfs_x64.efi to esp/EFI/refind/drivers_x64/btrfs_x64.efi, or you can install all drivers with the refind-install /dev/sdx --alldrivers option.

Also read Auto detection

What about ext4?

What is the question? EXT4 is a great file system!

When running refind-install, it uses the root file system type and its drivers

Heh, yeah sorry, my bad.
I’m using ext4, and I can’t seem to get refind to find vm_linuz either, hence the thread.

Have you read any wiki article?
What went wrong when you followed the instructions?
Any error messages?

First thing to edit is the refind.conf file. This is usually found (at least on EndeavourOS) in the /boot/efi/EFI/refind directory. You will need to locate the line containing extra_kernel_version_strings and uncomment it. Then edit it to match:

extra_kernel_version_strings linux-hardened,linux-zen,linux-lts,linux