rEFInd Booting Into GRUB Rather than OS

I had a very similar issue to this one, but it seems to have deviated off into a different tangent.

I installed rEFnd from this tutorial, & it seems to be working great.

Unfortunately, while Windows boots up just fine, I can’t directly boot to EndeavourOS.
I must first boot to GRUB, the my OS.

rEFInd looks like this:

Using the first photo, I simply boot into grub.
The second one lands me into a shell.

Similar to what I find in the grub.cfg file, do I have to boot to vmlinuz-linux & enter commands to get to my login screen?

The first Tux icon boots grubx64.efi. You can hide the next icon with the colors by pressing the delete key and yes. The next Tux icon boots from the vmlinuz-linux image file. You can change the tux icons to EndeavourOS icons or other if you like.

I see,
Though what I’m asking is how do I boot directly into EndeavousOS, bypassing the GRUB bootloader screen altogether?

Do I have to remove grub to be able to do so?

There is no direct boot into it. You either have to select the Tux icon that boot’s the lvmlinuz-linux image file or the Tux icon that boots the grubx64.efi file. You can hide the icon booting grub by highlighting it and press del key and answer yes.

Edit: You can also set a different icon for either depending on what you choose and or want.

Edit2: Even with systend-boot there is going to be an entry that comes up on the screen that you have to select.

I don’t know if you can bypass the grub screen or if you’d want to. But you can bypass what comes up after you select the entry in grub by setting quiet in the default grub command line and then update grub.

I got the hang of setting up a different icon,
Just to confirm, because I don’t think I’m explaining my point correctly.

By “directly boot”, I mean I don’t have an icon (whichever icon that may be) that will boot me into my Linux OS.
The Windows Icon, boots into Windows.
The grubx64.efi boots into grub, which I had previously to choose between Windows & Linux.
The vm-linuz-linux boots into a shell.

If I have to boot into grub, then what’s the point of having rEFInd because incase grub breaks, then I’m stranded anyways?

Your second post is quite helpful, that’s an option I could use to “directly” boot into EndeavousOS, but then my last question still bothers me.

Even with systemd-boot there is an entry and then when you select it you see all the text info load as it boots. Did you set an icon for booting from the vmlinuz-linux image file? You just download an icon.png and then rename it to vmlinuz-linx.png and copy it to the same folder that has the vmlinuz-linux file.

I don’t know if you can bypass the shell booting from the vmlinuz-linux file? I haven’t tried.

Edit: Found this on another site. I’m assuming it’s when using grub

Try adding rd.udev.log_priority=3 vt.global_cursor_default=0 to hush udev and hide the cursor.
Also uncomment ‘use_graphics_for osx, linux’ in refind.conf and see how it goes.

Edit: Hopefully this helps.

I think I’m starting to see that we’re talking about different things.
Before I dive down that rabbit hole, Is the vmlinuxz-linux file supposed to boot into the OS?



Yes it should boot from the image file. Not sure if you are selecting it? Or why these errors if it boots on grub?

Edit: When you install refind and this is dual boot Windows and Eos you should have an Icon for Windows, Icon for Eos that boots from grubx64.efi and also an icon that boots from the vmlinuz-linux file and an icon that is three colors for the fall back i think it is?

Edit2: You should be able to boot from either.

Ahhh, finally! I knew there’d be an option to boot into endeavousOS without using grub.
Though I have no idea why the vmlinuxz-linux errors out, it boots fine on grub, & hibernation works great.

About your second question, that’s the crux of it!
I never had an option (or icon) to boot into endeavour, just windows, grub, the three colors which is indeed fallback, & vmlinuxz.

When I first installed it, grub had the EOS icon, before I changed it.

I suspect it’s a problem with rEFInd and btrfs.
I have rEFInd booting a vmlinuz OK with an ext4 filesystem.
There is a rabbit hole here…

I see, I’ll take a look at this too :slight_smile:

Regardlesss, if using refind in dual-boot with Windows, MacOS, or any other system, I think it is important to point out the original refind manual here.

The title of that page is aptly named as boot-coups!

A great title for situations, where your favorite “other” system overwrites the refind configuration:

And those boot-coups will happen, regardless.
The only question is, when? Sooner or later, they will happen!

This is esp. posted for all those on this forum, hoping to be free from further issues by using refind instead of grub, as triggered by the late grub-issue.

Thinking, this will not happen when using refind, instead of grub will be a “Milchmädchenrechnung” in the end.


Refind works fine on btrfs. The post you are referring to is about booting into snapshots with refind. Normal booting on btrfs is working fine.

1 Like

You should be able to read the small print in the post I gave, before passing any judgement here, man. It is much broader than only referring to btrfs. Just saying…

Read it, and you can learn about refind, and how to recover from a boot-coup using refind.

No offence taken and none meant.

Not passing any judgement. Just saying refind works fine on a normal install but gets complicated when dealing with snapshots. I haven’t been able to get it to work yet trying to boot into snapshots. :slightly_smiling_face:

Sorry, can’t help you there. Refind is much older than snapshots are, so I’d try getting in touch w. the dev, if it be that important for me. (Not for me, as I’m using legacy hw & stuff.)

I’m not worried about it. I was just trying to get it to work since I use btrfs and snapper for snapshots. I don’t really care that much if I can’t boot into snapshots.

1 Like