Switching from AMDGPU to Nvidia

So, after a massive wait, I’ve finally managed to get an RTX 3080 ordered, which will be delivered tomorrow! :smiley:

So, my question is, I’m currently using an old Vega 56 GPU atm, which obviously uses the AMDGPU driver module in the kernel (currently using latest Zen kernel).

With this being the case, do I just need to install the Nvidia drivers once I have it installed, or is there anything else I need to do in order to be 100% good to go, or do I need to edit any configs etc?

Edit: Also, I’m using Plasma with X11 not Wayland :slight_smile:

  1. Unplug the old card.
  2. Plug in the new card.
  3. Boot up to TTY, install Nvidya drivers.
  4. Reboot and post here if it does not work :rofl:
  5. ???
  6. Profit!
1 Like

Is it that simple nowadays?

Last time I had an Nvidia card (about 6 years ago), it was a nightmare to sort drivers in Linux (Ubuntu back then IIRC), so I gave up on it :joy:

Thanks @Kresimir, I’ll report back on success or otherwise! :joy:

1 Like

I wouldn’t mark it as solved until it actually works :slight_smile:

It should be fairly easy, but there are always things that can go wrong. Good luck!

2 Likes

You might also need to edit the MODULES array in /etc/mkinitcpio.conf & re-run mkinitcpio -P if you’ve made use of early KMS for amdgpu.

You might want to uninstall any amd drivers you may have installed.
Also any Xorg configurations you have may need checking.

You probably don’t even need to boot to a TTY. As long as you don’t have a custom Xorg config or have made special settings changes your system will probably load the nouveau drivers and load a graphical session as normal.

Didn’t make any changes to any configs. Installing Endeavour was a simple straightforward process, and I’ve been using the defaults since :smiley:

Well, good luck! It will probably work just fine until you have a chance to install the proprietary drivers.

I have been looking for a 3080 for many months now.

I got mine from Scan. Cost the better part of £1k, but given they cost 2-3 times that 5-6 months ago, I’m happy enough. Ish. :joy:

Still a bit galled I had to pay that to get one, but it’s the first model I’ve seen actually available for purchase, so jumped while I had the chance :slight_smile:

Edit: Checked on the website, and predictably they’re sold out again. Looks like I happened upon it at the right time.

Also, idiot delivery company tried to deliver today, while I’m stuck at work and no-one else is in the house, when delivery was stipulated for tomorrow.

:man_facepalming:

2 Likes

Well, that was a journey :joy:

So I ended up re-installing Endeavour. Not a huge issue as I keep my install clean and save any data or downloads onto a separate partition on my Linux drive.

Clean install, and everything works as it should. Back up and running with the same setup, plasma themes etc that I had before.

One irk is that the animations in Plasma are a bit choppy, certainly moreso than they were with my AMD GPU. Small thing, but prime example being the cursor’s cog bouncing animation when opening say the settings panel. Instead of it smoothly bouncing, it’s choppy as hell (and this is on an NVME SSD too!):

Screenshot_2021-07-27_13-06-20

Like I say, small thing. XFCE works perfectly fine, and the Nvidia drivers appear to be installed and working ok!

1 Like

Did you try enabling “Full Composition Pipelining” in the nvidia settings?

Tried setting that in the Nvidia X-Server settings app, but the animation is still a bit choppy.

Even the same using different global themes, plasma themes, even cursor themes :joy:

Guess I’ll live with it, it’s only a minor thing and I can put up with it for the hugely better frame rates in games :slight_smile:

Installed FFXIV and performance was a bit lacking. Switched back to XFCE (from plasma) and all performance issues went away, both ingame and on the desktop!

Guess I’m back to XFCE :joy:

Have since found out that Plasma and Nvidia don’t really play well together, and is apparently a known issue :joy:

Certainly looking through the /r/kde subreddit there are plenty of threads with people complaining about Plasma performance on nvidia drivers, and it appears even an RTX 3080 isn’t capable of driving it smoothly :joy:

So yeah, back on XFCE for the time being, until at least the KDE team sort out their performance bugs with the nvidia drivers. Shame, because I’d just got my desktop looking really nice :joy: