Sway wont let me change keyboard layouts

No matter what i do within ~/.config/sway/config.d/input I can not add hungarian layout, and I don’t know how to switch layout with keyboard…

Something is not right with sway. Need help

wat is localectl status ?

you did reload the wm also ?

System Locale: LANG=en_US.UTF-8
VC Keymap: hu
X11 Layout: us

and yes I always run swaymsg reload after each change (without root privilege)

check in /etc/locale.gen that the us part has a # ?

and calamares wil normaly also set a line downunder ?

with localectl you can also set X11 Layout ithing , x11-keymap…

is set to us because the localectl is set to us ? just a rouggh guess;;

hu_HU.UTF-8 UTF-8 ( i uncommented this line)

And made a swaymsg reload

What else should I do?

you have to run locale-gen in sudo after it

I made a chekc in into ls /usr/share/kbd/keymaps/**/*.map.gz

And here is the post I got


Okay done. But still can not change the layout

localectl status looks ? different?

No. Still the same

localectl status
System Locale: LANG=en_US.UTF-8
VC Keymap: us
X11 Layout: us

But i had a successful locale-gen update

sudo locale-gen
Generating locales…
hu_HU.UTF-8… done
en_US.UTF-8… done

in locale-gen is somewhere stil us on # added

Uncommented in locale.gen the fallowing en_US.UTF-8 UTF-8
did an update with locale-gen
here is how it looks

Generating locales…
en_US.UTF-8… done
hu_HU.UTF-8… done
en_US.UTF-8… done

And this is the content of / .config/sway/config.d/input

Input configuration

Example configuration:

You can get the names of your inputs by running: swaymsg -t get_inputs

Put your touchpad’s ID to replace “Touchpad-ID” (keep the quotation marks)

input type:touchpad {
dwt enabled
tap enabled
natural_scroll enabled

Read man 5 sway-input for more information about this section.

input type:keyboard xkb_layout “us,hu”

exec_always {
'swaymsg input type:keyboard xkb_layout "$(localectl status | grep “X11 Layout” | sed -e>
'swaymsg input type:keyboard xkb_variant "$(localectl status | grep “X11 Variant” | sed >

Did that no use

but us,hu ? you have hu ?

I added that manually

the script probably uses also localectl status , i dont know i always get a mixed in that…

locale -a to see.

for keymaps is also locale-gen importand uncomment the hu part…

localectl -h its really straightforward…

localectl set-x11keymap hu , wil show localectl status a part to hu ,

it can change also system language too//

check also /etc/vconsole.conf it uses te proper keymap

i used sway from github the script setup also the keymap correctly here in input…

i think in the localesetting and other was not something correct.

locale -a post

localectl set-x11keymap hu
Unknown command verb set-x11keymap.

/etc/vconsole.conf (post)

ah wel mayby later someone with better input :slight_smile: im not so good i had a issue after a update seems localesetting was rubbish moved everything to us since i need be.