Sway Edition - General Conversation!

When I run the script I get
Error: target not found: ttf-nerd-fonts-symbols
?

1 Like

Ah yes. Good spot. The package name has changed to ttf-nerd-fonts-symbols-2048-em. I will change the list when I can.

For now swap in the new package in the file packages-repository.txt and re-run the script.

2 Likes

Welcome to the EndeavourOS forum. I hope you enjoy your time here.

Thank you for the feedback. Looks like @OdiousImp has you all set up.

Pudge

2 Likes

Thank you for making this script! It’s extremely encouraging for me; I am enjoying it.

1 Like

I’m not sure if this is the appropriate place to say, but EndeavourOS has been nothing short of a blessing to me. It’s given me the means to learn already an incredible extent in order to utilize my computer for efficiency, productivity, and enjoyment in just a few months.

5 Likes

^I’d also like to chime in and give my praises to EndeavourOS Sway. Coming from Fedora with Gnome, there’s definitely a learning curve and I’m not quite there yet in terms of being able to 100% customize things. Thankfully, Endeavour has very nice defaults out of the box in terms of included apps and waybar configuration, allowing me to tweak things to my liking and learn Sway as I go along. There’s still much to learn, but the documentation is good and the community has been helpful, so thank you guys for this great community edition! :grin:

3 Likes

thanks a lot :grinning: for the Sway edition
I’ve almost finished to configure it, really happy with it

1 Like

Having fun with sway, was happy to see that running the script worked really well despite already having a full Gnome install. Haven’t gone back to my Gnome session once :slight_smile:

One thing, I have found wofi pretty annoying and underpowered. I installed the wayland branch of rofi and copied my config from i3 and have been much happier with that, have not noticed any performance problems others have complained of.

1 Like

If you are still shopping around for wofi alternatives, be sure to check out the very excellent Fuzzel:

You won’t be able to copy and paste your rofi/i3 config, you’d have to set up a new one but it’s pretty nice if you’re looking for something new. Very fast, and customizable!

I did test this out, was nice I think I couldn’t get my clipboard history working the way I liked it. It looks like the way to do it is with clipman which I admittedly didn’'t try, may come back to it one of these days!

Tested and It’s good.
But I doesn’t manage to have the “more launched” apps at the top of the list like in Wofi. Which is a must have feature for me.

Missed something?

I use this. Dead simple and works as expected.

1 Like

It seems so; this feature is supported, and is the default behavior: https://codeberg.org/dnkl/fuzzel#features

  • Remembers frequently launched applications

After you launch an application it will be added to the cache in ~/.cache/fuzzel. Next time you open Fuzzel, that application will be at the top of the list (same as Wofi).

You have to run Fuzzel in application mode (not dmenu mode) for the history function to work. If you copied someone else’s Fuzzel config to get started, check that they haven’t configured it to run in dmenu mode.

Maybe I didn’t use it enough. I must try it more.
thx

Installed the new version of endeavouros and used the sway edition on a new laptop. Where is resolution controlled now. Cant see it referenced anywhere.

No need for GUI. Just get your outputs and resolution by typing swaymsg -t get_outputs in you terminal

Then add output and resolution in your sway config: ~/.config/sway/config

## Output configuration example
output DP-1 res 2560x1440@75Hz 
1 Like

Thanks for the reply. Yea I know how to set it but how is it set now, by default I mean.

The display you connect to announces what resolutions are available. I think Sway just defaults to whatever the suggested resolution is.

If you mean scaling, Sway defaults to 2.0 scaling if it detects the display is HiDPI. This is a bit much in my opinion. You can override the scaling the same way as any other display setting in the Sway config.

## Output configuration example
output DP-1 res 2560x1440@75Hz scale 1.2
1 Like

Starting using parts of this configuration in Niri now: https://github.com/YaLTeR/niri

:slight_smile:

Oh interesting…I always enjoy something new, hadn’t heard of Niri before your post.