Stuck on the welcome screen

Hi guys,

So today i downloaded the endeavouros Cassini Neo iso from the official website and used rufus to burn the iso into my pendrive so that I could install and dual boot eos with windows 11.

After sometime when the screen reaches to this point, it gets stuck and doesn’t go ahead to the installation display. Here is the image.

I have tried downloading the iso from the website a couple of times, to make sure that I don’t have a corrupted iso, but to no avail.

Any help will be much appreciated.

Do you have secure boot and tpm turned off?

Secure boot is turned off. TPM i have no idea if i turned it off. Mind saying where to do it

I’m BIOS settings as well. Every BIOS is different if, so not sure what it would be called for yours.

I am using hp laptop

Do you know what your CPU is? if it’s an Intel what generation it is? Also, does your machine have an NVIDIA graphics card?

I have 11th generation Intel. Plus i have nvidia GeForce mx350

This is a shot in the dark. Could you try the workaround in this thread?

1 Like

This May prove helpful for BIOs TPM? Without knowing what model and mobo your machine has, it’s hard to say. HP BIOS changes quite a bit every few years.

1 Like

You do boot on default option or the Nvidia boot entry?

need sto use ISO or DD mode to work properly… as all other options will change bootloader and let ISO fail to work.
Better is to take this:

read here:

And your system totally fit the issue for ibt=off needed 11th gen intel CPU plus latest nvidia … 30xx


Thank you so much… this worked out. I burnt the USB with USBWriter and add ibt=off as rightly said by @s4ndm4n and yourself. Now finally booted into the live environment.

Thank you so much guys

Thanks mate. I got through this issue by using USBWriter and changing the entry in the bootloader.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.