Stuck in installing EndeavourOS on a laptop

I tried installing EndeavourOS on my laptop, but kept seeing this screen

the picture is not sharp so hard to read it…

but USB seems to be defective or port used has issue…
But anyway welcome here at the forum … let’s hope we can bring the installer up on your device!

mb is this better?


Also i tried different ports but they all had the same message show up, and they arent damaged as far as i can tell since it works normally when using windows

i mean then usb stick itself could be defective… but not the only possible issue :wink:
It can be also you have secure boot enabled and it is not allowing to mount the USB device because of that.

SGX disabled by Bios should be okay :wink:

i have secureboot disabled in bios if that does anything to the installation
And i couldnt find anything in the bios to enable SGX if thats important

it is not supported on EndeavourOS to have secure boot enabled (same as on arch itself)
But it must be something in Bios settings that let you not access the USB device…
Or it is something with the USB device itself (corruption e.t.c.) or any tool that changed the image (iso file) in any way you have used to create the USB stick.

i used the iso mode in rufus when i created it, i tried using the DD mode after but i got a read error for some reason

best is dd mode on rufus… and where you got “read error” ? while creating stick or on try booting it?

when creating it, at the end

so looks more like the ISO file is corrupted or the USB stick is defective.
Have you checked the ISO file after downloading?

yea i downloaded the one from github
I get this btw

could be error reading ISO file or error reading from USB stick on verification…

is there anything i can try to do that would fix it? or

you could check the iso file with the sha512sum it ships with…
or redownload the ISO from one of the mirrors:

i tried a different mirror and its still the same ;-;
should i try a different software like balena etcher or something to create it?

Are you creating it from Windows? Use etcher in that case.

Hello and welcome @Aurniox
Why not try downloading a new ISO from another mirror to be sure?

I
and use dd with bs=1M status=progress parameters.

1 Like

i used this from windows on testing also:

and is usb boot in bios set to something like legacy boot or CSM: Compatibility Support Module ?