Stuck at login screen


Yesterday I updated the system and did a reboot, as recommended. After I entered my password, the screen went gray, then black and then back to the login screen. (I can get into tty.)

I had a similar issue a few years back, on a different laptop with Linux Mint. There, it was a result of the storage being full iirc. That can’t be the case now, I have over 200 GB of free storage.

When booting fallback initramfs it did tell me that the memory was exhausted, but that’s not really the case, there were always around 6.5 GB free. (I also didn’t get that message today, so idk if it’s important)

The laptop is an Asus vivobook flip 14
I do have a Kingston nvme, I read they can be kinda trash, don’t know if that’s important.

I really don’t know how this happened or how to solve it, any help is appreciated.

I hope this isn’t a repeat question, but I didn’t see any post describing my exact issue.


Welcome to the forum! :smile:

Having TTY as an option is great, because you can easily provide more information to us.
First useful information would be available via command

inxi -Fza | eos-sendlog

This tells info about your hardware (especially we likely need some graphics stuff).
The command displays an internet address, please share it here so community members can look at it to find possible solutions.

One idea (if the disk space is near full) is to remove unnecessary old packages from the package cache (which may keep growing if not managed). It is easy to do e.g. with commands

paccache -rk1    # removes all but the latest of each package in the cache
paccache -ruk0   # removes all packages that are not currently installed

The numbers in the commands tell how many will be kept, zero removes all from the cache.

1 Like

This is the link I got:

1 Like

Do you have many Gnome extensions?

Could you also share disk partition info?

lsblk -fm | eos-sendlog

I don’t. gnome-extensions list doesn’t list anything.

Partition Info:

/boot/efi is about 300MB. Are you using grub or systemd-boot?

With login screen you talk about GDM? and installed Desktop is GNOME?
Gnome just updated on Arch to next Version from 44 to 45.

If you are using some extensions one could cause your issue…

you can disable them to check if you can start Gnome without them:
mv ~/.local/share/gnome-shell/extensions ~/.local/share/gnome-shell/moved-extensions
and go back to GDM Ctrl+Alt+F7 and try again to login…

When you are able to login without the extensions…
put the extensions files back

mv ~/.local/share/gnome-shell/moved-extensions ~/.local/share/gnome-shell/extensions

And disable all over the extensions tool…
And go to add one after the other to see which one is causing your issue…

I fixed it.

To try something else, I decided to add another user, to test if it’s a user problem. With that new user, I could login just fine. With some trial and error I figured out the problem was something in the .config directory (not sure what exactly). With the maybe not very elegant solution mv .config config, I could login again.

I might try to figure out what file specifically was causing the problem tomorrow.

Thanks for the help, it was a nice first forum experience!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.