[Solved] User Login Fails, But Root Login Works

After doing an update before bed last night, I am now unable to log in to my user account. But I am able to log in to my root account.

I have i3, awesome, and cinnamon. Tried all three - but none worked.

It is similar to this Stuck at login screen but even when I create another user account, I still can’t log in.

Last night’s update included pretty much all the usual system-breaking culprits: grub, linux, pipewire, etc. In fact, not sure if this makes sense, but my root user cannot access any audio devices for some reason.

EDIT: I am using BTRFS, but even the snapshots don’t work. This is the first time that using a snapshot hasn’t worked so I’m kinda concerned by that. :confused:

Any help on this would be greatly appreciated. :pray:

Try creating a new account to see if that works. If it works, the problem may be in the configs of your current account.

That doesn’t work for me, unfortunately.

Turns out Linux now requires way more space to run properly than it needed the last time I checked.

  • I had 19.7 Gb of free space and based on this Stuck at login screen, that person’s Linux Mint didn’t want to log in without some arbitrary and unknown minimum amount of space.

Long story short, I moved some files from my /home directory to an external drive and I was able to log in, but only after restarting. Now, I have a bunch of errors from random apps and/or operations that say “you can’t do this because you don’t have enough space”.

I now have 47.4 Gb of space… :face_with_raised_eyebrow:

Now, let me go look up how to change file and directory ownership because I moved those files with the root account. :sweat_smile:

→ Achieved using sudo chown -R username:username /mnt/backup/ in case anyone is interested.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.