Stuck at boot after update

Hi guys, I’m new to Linux and recently I’ve updated my system, but now I am stuck at Boot.
The message is:

Starting version 250.3-1-arch
/dev/sda1 : recovering journal
/dev/sda1: clean, 276816/61054976 files, 13034248/244189752 blocks

I tried to refer to this link, but it doesn’t help much. my graphic card is GTX-1050, in case it is a graphic card problem.

any idea?
thanks.

are you able to access ttty if not fire up a live usb and share journal info and inxi -Fazy

https://clbin.com/gXvRm

https://clbin.com/7XyLu

here you are

@alkhwaritsmi if you do not know how to login via a tty session then do CNTL-ALT-F2 and login at the prompts. Your problem may be due to Nvidia drivers and your GTX1050 hardware. Search the forum for GTX1050 and see if any match your problem.

Driver shouldn’t be na. for your card you have to use proprietary drivers

Graphics:
  Device-1: NVIDIA GP107 [GeForce GTX 1050] vendor: Gigabyte driver: N/A
    bus-ID: 01:00.0 chip-ID: 10de:1c81

Welcome to the forum @alkhwaritsmi :enos: :enos_flag:

1 Like

Welcome to :enos: forums.

As pointed out it might be because you don’t have drivers installed for your graphics card.

Drop to tty by pressing Ctrl + Alt + F2F6

Log in at the login prompt. And then run the below command to do a test the driver install.

nvidia-installer-dkms -t

If you doesn’t see any errors then run the below command to install the drivers.

sudo nvidia-installer-dkms

Once the installer finishes (hopefully without errors) restart the computer using the below command/s.

sudo systemctl reboot

or

sudo shutdown -r now

Further reading: https://discovery.endeavouros.com/nvidia/nvidia-installer/2021/03/

1 Like

tried this but seems that I got an error retrieving packages(failed to retrieve some files). So, I tried this

sudo pacman -Syu elinks

as recommended in arch, but still no good.

But I apparently I encountered this glib2 package cannot be upgraded, might this be prior to my problem?

(post deleted by author)

Seems the files are missing from the mirror. Try a mirror list update then try a system update.

You can use reflector which is installed by default. You can use the command like below.

Without country

sudo reflector --age 12 --protocol https --sort rate --save /etc/pacman.d/mirrorlist

With country

sudo reflector --country <Put country names closer to you like Germany, United Kingdom> --age 12 --protocol https --sort rate --save /etc/pacman.d/mirrorlist

After doing that try an update then try to do the installs.

2 Likes

Thank you so much it works

1 Like

Happy to hear that it work and you’re most welcome. Another piece of advice enable reflector service which will automatically update your mirror list. So you won’t have to do it manually.

Refer this: https://discovery.endeavouros.com/pacman/automatically-ranking-the-mirror-list/2021/03/

1 Like

Wouldn’t that require to make sure to pass a double y to pacman for updating after the mirrors have been updated?

For myself, I just update the mirrorlist when/if there is an issue with it.

2 Likes

Yes -Syyu would have done the same.

It helps keep the mirror list updated for better speeds. Might not be an issue for most but for many others, it would help.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.