Steam not launching after upgrade to 5.7.12

I just did a system upgrade, after rebooting and trying to launch into steam nothing happens. Has anyone else experienced this? May anyone assist me with this issue?

Welcome!

Have you tried launching it in a terminal and looking for errors?

2 Likes

Where are you seeing version 5.7.12? The repos say the current version is 1.0.0.64-1, and that works fine for me.

(I presume it’s kernel 5.7.12 :wink:)

1 Like

Mine seems intact, follow @Elloquin 's advice, terminal should give some errors for debug most likely!

LOL…oops, brain-fart moment. In that case, mine works on 5.17.12 zen kernel on main PC, and the 5.7.12 vanilla kernel on my laptop, both after recent upgrade. :crazy_face:

4 Likes

All is well here as well.

Welcome @llp !

:maté: :slight_smile:

1 Like

running steam in the terminal shows no errors, i apologize for delayed response. Sorry is wasnt more clear in the tilte that i was referring to the kernel.

when i run steam in the terminal the output STEAM_RUNTIME is enabled, pins are up to date and steam clients requirements are satisfied, but the login screen does not launch

I was playing dragons dogma last night and very early this morning, i immediately tried steam after updating this morning.

I switched over to i3 from xmonad and steam is working fine. I am very sorry for wasting you guys time. It must be some issue with my xmonad. It was working fine last night. I will investigate further. thanks for the support

1 Like

you can try deleting everything in the .steam folder except the steamapps folder and reinstalling steam. Usually when steam starts having a fit that fixes it for me

thank you for your response if i encounter future issues i will def keep this in mind

Have you tried running the steam game windowed?

Right click on the game in your Steam library and choose properties
then click on launch options and enter:

-windowed

According to the Arch xmonad wiki this can help with games based on the source engine.
Don’t know if your particular game is using source engine, but could be worth a try.

Link to arch xmonad wiki:

[https://wiki.archlinux.org/index.php/Xmonad#Steam_games_(Half-Life,Left_4_Dead,%E2%80%A6)_and_xmonad]

Hope this is of some use.

If you are running firejail, you may need to disable it for steam games to run.

1 Like

Welcome aboard!

1 Like

@Elloquin
Thanks!

2 Likes

Welcome

1 Like

Welcome @llp and @Melways :beers: enjoy the community :smiley:

@antec1
Thanks! :wave:

@ramblinwreck
Thanks! :+1: