Steam crashes

When attempting to run steam I receive the following errors, I followed the instructions on both Arch Wiki and EndeavourOS Discover

[arun@arun-desktop ~]$ steam[67089]: Running Steam on endeavouros rolling 64-bit[67089]: STEAM_RUNTIME is enabled automatically[67162]: Steam runtime environment up-to-date!
/home/arun/.local/share/Steam/ubuntu12_32/steam-runtime/ line 85: steam-runtime-identify-library-abi: command not found[67174]: steam-runtime-identify-library-abi --ldconfig-paths failed, falling back to ldconfig[67089]: Can't find 'steam-runtime-check-requirements', continuing anyway
tid(67214) burning pthread_key_t == 0 so we never use it
[2024-05-02 19:57:55] Startup - updater built Jan 13 2024 00:51:43
[2024-05-02 19:57:55] Startup - Steam Client launched with: '/home/arun/.local/share/Steam/ubuntu12_32/steam'
ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
05/02 19:57:55 Init: Installing breakpad exception handler for appid(steam)/version(0)/tid(67214)
crash_20240502195755_2.dmp[67217]: Uploading dump (out-of-process)
/home/arun/.local/share/Steam/ line 798: 67214 Segmentation fault      (core dumped) "$STEAMROOT/$STEAMEXEPATH" "$@"
[arun@arun-desktop ~]$ crash_20240502195755_2.dmp[67217]: Finished uploading minidump (out-of-process): success = yes
crash_20240502195755_2.dmp[67217]: response: CrashID=bp-aec4b48e-4b6a-4fed-8889-f609b2240502
crash_20240502195755_2.dmp[67217]: file ''/tmp/dumps/crash_20240502195755_2.dmp'', upload yes: ''CrashID=bp-aec4b48e-4b6a-4fed-8889-f609b2240502''

Logs are attached
eos-log-tool.odt (12.4 KB)

1 Like

This is happening to me as well following updating today, tried the fix here and worked Steam not launching_

1 Like

Packages appear to be fixed now, just did pacman -Syu and fixed


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.