Steam Controller not being detected

Hi guys

I have been playing Batman Arkham Origins on Steam with my Steam controller and this morning noticed that the controller seems to no longer being recognised. It is now coming up with ‘Unknown Controller’ in the big picture config screen. I have installed a few updates recently and have only just noticed this issue. I even wiped my install and started fresh but have the same problem.

Does anyone know what is causing this? could it be a kernel update or something?

Thanks in advance

While i can’t help with steam-controller, coz i don’t have it, which seems to be broken with some update for you…

I’m also playing Batman Arkham origins too sometimes now!
It’s terribly optimized by default and there is bug which sets textures to low quality regardless of your video settings, which can be fixed through config file.

Few things i’d highly advise you to do, if you care about graphics / experience quality:

  1. If you’re on Nvidia, you can enable full GPU PhysX easily like that!

  2. Make sure your in-game settings are all set as you want, so you wouldn’t change them again

  3. Find config file path:

  1. Find and replace all matches of this keys to new values in file

If you doesn’t have powerful enough GPU, just do everything except shadows :wink:

  1. To skip intro videos on Steam, use:
%command% -nostartupmovies

This improves things a lot :partying_face:

1 Like

You can test that by booting up the LTS kernel.

1 Like

I’d assume it’s most likely steam or game-devices-udev update, still worth a shot with LTS :upside_down_face:

1 Like

Maybe you can help @mjl then? :slight_smile:

don’t know what to say, I just plugged the receiver in, and steam recognized it immediately

running on latest kernel 5.8.13-arch1-1 btw, no LTS


Hi guys

Thank you all very much for your help. It seems to be whenever my grub config is re-built - Kernel updates and upgrades of any kind as I use btrfs and timeshift-autosnap. Whenever this happens, a reboot fixes it

Thanks for the tip but I don’t seem to have any of those options in there