Startling error noises

Hi all, I need help turning off/ lowering the volume for these REALLY LOUD error beeps I get when typing. Example situations:

  • using ctrl+f function in Firefox and I type in a non-existent result
  • pressing/using the backspace in empty input areas in some apps

At first I thought it was related to my sound volume but it happens even when muted. Also thought it was DE/WM specific but it happens in every environment I have. KDE, Xfce, i3, etc.

Would really appreciate some help on this. Thanks!

Welcome to EndeavourOS! :partying_face: :rocket:

That’s beeper (super-scary stuff)

Should help, try it out:

sudo rmmod pcspkr
sudo echo "blacklist pcspkr" > /etc/modprobe.d/nobeep.conf

I think also requires reboot, not sure :upside_down_face:

2 Likes

Welcome to EndeavourOS :balloon: :tada:

Welcome aboard! If what @keybreak says does not work you will need to disable pcspeaker in bios.

Thank you so much for the welcome and the solution! It worked really well :smiley:
Loving this OS btw :heart:

2 Likes

Thank youuu :smiley: :partying_face: Looking forward to exploring EOS and the community!

@Elloquin, @keybreak’s solution worked but I’ll keep that in mind when installing on my next machine.

Just think - if you couldn’t disable the noise then you’d just have to stop making errors… :thinking::grin:

3 Likes