Starting with virt-manager

Hi
It’s up and running following the latest advice.
My wish is to test it in the most easy way before going further. I have a virtualbox vdi with W7 in own partition named /virtuel that I would like to use.

I create the new VM but gets the report that the NAT network is inactive and I do not know how to activate it.

You can activate it right at the end of the VM creation wizard. Just click on the “network inactive” button. You’ll get all active networks available.

Or, in the configuration window, just click on network in the left. You can select your network. Click “apply” to validate your choice.

or do use hostdevice bridge , it will say mostly this will not work, but here it works all the time…


Thank you both for your replies.

It seems I face a specific problem with RF-kill on my Lenovo laptop. I bought it three years ago and I had to wait 16 months before a Linux firmware update solves this and mades my wifi work…



écran3

yea it needs an ip… and wlp3s0 is this wireless device? and the only one in use?

what says:

rfkill list

It’s just slightly better if I try with the ensp network (Ethernet cable, which is connected). I start the VM W7 but only with the windows repair system - which of course repairs nothing.

certainement :wink:

[roger@lenovo ~]$ rfkill list
0: ideapad_wlan: Wireless LAN
	Soft blocked: yes
	Hard blocked: no
1: ideapad_bluetooth: Bluetooth
	Soft blocked: no
	Hard blocked: no
3: phy0: Wireless LAN
	Soft blocked: yes
	Hard blocked: no
7: hci0: Bluetooth
	Soft blocked: yes
	Hard blocked: no
[roger@lenovo ~]$ 

also if it is running before with a lan connection network… better to use the same on virt-qemu emulation :wink:

sudo rfkill unblock wifi

:artificial_satellite:

1 Like

For this try, I have better stick to the Ethernet connection (ensp) which does not suffer from RF-kill woes. So that my first problem is to know why Windows does not start normally.

I’ll have to learn a bit more about this and shall resume later. Sorry to make you waste your time.

I never try to boot on qemu from virtualbox drive… my it needs some extra stuff ?

Booting into the windows repair option sounds like it’s booting from the install media still perhaps. I’ve only used virtual box, but look for an option to “remove” a disk drive and unmount the .iso from there, or change the boot order to hdd before optical.

Have you been able to get virt-manager working? Since I can’t get VirtualBox to work on Arch based installs I have tried getting virt-manager running but seems to not boot the ISO. It’s strange as I have used it in the past but VirtualBox is the one I prefer. Not sure what I’m doing wrong with it? Tried different settings but so far it’s not cooperating. Going to try it again later.

If you feel adventurous, you could try my latest creation, the vm-gui. It wraps virt-manager and virt-viewer into an easy GUI.
Note that it is a very new tool, so there may be bugs lying around! So far I’ve used it myself without issues.

Here are some pictures. The first window is:

first

In order to use virtual machines, you need to create one first (so click Create). Then you’ll see this:

second

Usually giving the name and the ISO file location is what needs to be done. And here we go:

After installation, you can simply reboot and start using the VM. But if the VM is shut down, you can restart it by clicking the Start button on the main window, and you’ll come here:

third

Just run it!

The code is located under my personal packages at

If you don’t have that repo installed for pacman, there’s another (manual) way to install the package:

cd /tmp
wget https://github.com/manuel-192/m-m/releases/download/x86_64/vm-1.2-2-any.pkg.tar.zst
sudo pacman -U vm-1.2-2-any.pkg.tar.zst
4 Likes

This looks interesting. I kind of had my fill with virtual-box not working on EndeavourOS. :disappointed:

1 Like

@manuel
I don’t know what is going on with Github? I try to download EndeavourOS ISO and it’s coming up all the time over an hour.

Hello @manuel
I tried the vm-gui and it’s not launching anything> Does the virt-manager get installed with it? I’m confused on how this is working?

Edit: Seems all is installed including Qemu?
Edit2: Okay i got it working but is booting Bios not UEFI?

I am trying virt-manager but it won’t work for me. I don’t know why?

Edit: Finally

Is this an add on to virt-manager?