Starting version 249.3-1-arch

Hi All, noob here. I just installed Endeavour OS using the dvd to my 2009 HP Pavalion Desktop with NVIDIA graphics.

After the installation, I am stuck at “Starting version 249.3-1-arch”. I feel like it is likely due to nvidia graphics drivers.

Any help would be appreciate it. I just learnt to get into tty2 system and tested some commands. but my knowledge is 1 on a scale of 10.

Thank you.

Edit:
Since you can only get into a tty. Log in as root and add this to the default grub command line in /etc/default/grub under this line:
GRUB_CMDLINE_LINUX_DEFAULT="

You can use a text editor such as nano and save the changes after adding the following.
sudo nano /etc/default/grub

Add

nvidia-drm.modeset=1

To save the file
ctrl + o then enter

To exit
ctrl +x

Then update grub with

sudo grub-mkconfig -o /boot/grub/grub.cfg

If you need any help just ask. This is the minimum to try.

Here is a guide for additional enhancements for nvidia

Let me know if this works or if you need help.

Hi Ricklinux, thank you for your reply.

When I go to the directory using the livedvd and save the file with default text editor, I get an error saying “you do not have necessary permission to save”.

How do I edit while I am in liveuser mode using livedvd?

Also, the default line is "GRUB_CMDLINE_LINUX_DEFAULT=“loglevel=3 quiet nowwatchdog”

is that correct?

I thought you had it installed. I was thinking you were booting and then going to a tty . Then log in as root. Are you not installed anymore?

I do have the OS installed but I am stuck into the black screen when booting up.

Is it possible to edit the grub file in TTY?

How can I edit the config file? I would have to boot using the livedvd and use the file explorer to the /etc/default/grub to edit. correct?

No when you boot on the system and it stops can you do ctrl alt f2 and get into a tty?

yes, I am able to get into TTY while pressing ctrl alt f2.

So as i wrote use nano

sudo nano /etc/default/grub

Go to this line GRUB_CMDLINE_LINUX_DEFAULT="

After "quiet add

nvidia-drm.modeset=1

Then to save use

ctrl + o and then enter

To quit nano use

Ctrl + x

Then run the following command to update grub

sudo grub-mkconfig -o /boot/grub/grub.cfg

Then

systemctl reboot

2 Likes

Did you log in as root?

Edit: If you logged in as root you probably won’t need sudo

yes, so I added the following GRUB_CMDLINE_LINUX_DEFAULT=“nvidia-drm.modeset=1”

and saved and followed your instructions and rebooted.

Now after reboot, I am seeing the following error. Please see attached screenshot.

I didn’t get this far before. Thank you again.

You have to use the 340.xx driver version by the looks of it. I’m not sure how you installed the nvidia driver when you installed the system. After or?

I did not install any drivers. Its whatever the Endeavour OS installed as part of the installation using offline mode (XFCE DE).

Do you have any guidance or steps in installing the correct drivers?

Did you use the default grub menu entry or the non free?

default grub option … the second option was the nvidia non-free and that doesn’t load the system… so I just used the first option to load the distro and went ahead with the installation. When it first loaded the system, there is abit of screen tearing and then it rescaled automatically and I was presented with the welcome menu.

Okay try this

pacman -Qi nvidia

getting

error: package ‘nvidia’ was not found

Okay no nvidia drivers are installed by the looks of it.

yay -S nvidia-340xx-dkms

Edit: These are the drivers but i can’t guarantee it will boot & load the desktop but we’ll see.

Have you tried the above command to install the nvidia 340.xx drivers?

yes, its downloading. seems quite slow to me.

I don’t have ethernet but have the wifi adapter for the internet… may be that’s why it is super slow… dont think its going to work. let me see if I can connect to ethernet directly

Don’t interrupt it or you’ll end up with corrupted database!