Standard approach for fixing "Oh no! Something has gone wrong."?

Hey team - I somehow broke my eos install with an upgrade. It seems the “Oh no! Something has gone wrong.” screen is a catch-all for many kinds of errors. I would like to be able to provide as much relevant data about my system as possible, but I don’t know where to begin. I can’t find documentation to help me understand the reasonable steps to determine my problem - I’ve searched these forums and the wiki with no success.
So… is there a way to get to a console from the error screen? If so, what would be the normal first things to look at to determine the issue?



Gnome? Press Ctrl+Alt+Fn (where n is 3 or greater), log in:
Check you are upto date

sudo pacman -Syu

Try moving the extensions out of the way, temporarily:

mv ~/.local/share/gnome-shell/extensions ~/.local/share/gnome-shell/extensions-old


Rebuild initramfs:

sudo dracut-rebuild

While I appreciate the sentiment, I don’t think the implied criticism is entirely valid here (as far as I understand it :slight_smile: ) For one thing, a webapp breaking really does leave the user helpless, but generally I appreciate the goal of shielding the user from the feeling that something they did caused the breakage (even if it’s true). I’m investigating distros so I can install linux on machines for users who really really struggle with basic tasks. I think my target audience would be unnecessarily stressed if they just got straightup console log messages.

That said, it would be super helpful to provide some guidance so an intrepid user might start to debug and fix the issue. (e.g. maybe link to @xircon 's helpful post ?)

Could you specify what stage of booting/logging in is giving the error? If it’s during boot, you can follow @xircon 's instructions to access tty3 or whatever you pick. There you should be able to access journals.

Editing to add: I had no idea gdm3 even offered an error message like that. It’s incredibly unhelpful and vague, that doesn’t seem like your fault based on some of the search results I’m seeing.

Here’s an Arch bbs thread discussing something similar

Thanks for the guidance! Following your advice:

sudo pacman -Syu

... other stuff...
Error: failed to prepare transaction (could not satisfy dependencies) 
:: installing pacman (6.1.0-3) breaks dependency ‘’ required by libpamac-aur
:: installing pacman (6.1.0-3) breaks dependency ‘packman<6.1’ required by libpamac-aur 

I do not know how to fix the dependency resolution process. I took a look at /etc/pacman.conf but I’m pretty sure it’s still default (i.e. I haven’t touched it) and I didn’t notice anything obviously wrong.

Geesh. Tell me how you really feel.

Anything with errors I just set on fire and kick it into the woods.

I then go acquire new things without errors.


It looks like libpamac-aur is causing conflicts?

1 Like

looks like it… I’ve since
sudo pacman -Rc libpamac-aur
which worked, and am now running the update/upgrade again
sudo pacman -Syu

seems to be working now… will report back in a few minutes :+1:

1 Like

Anything with errors I just set on fire and kick it into the woods.

So does Gnome, apparently :upside_down_face:

replying to the thread (instead of editing my previous post)

my system is back online and running smoothly! Thank you @xircon and @rinwolf1312 - your time and help is very much appreciated!

Funny enough, I didn’t know what the library I removed (libpamac-aur) did, but when I searched for ‘add/remove programs’ from the desktop launcher (my typical tool for managing packages) it no longer exists. I’m happy enough to stick with pacman from the console going forward, especially since I’ve become more familiar with it.


Glad to hear it! I haven’t tried pamac before, but pacman’s commands are very intuitive

1 Like

Great that you got it working again!

And yes, pacman is the package manager of choice on Arch based systems. It is the most reliable of all that I’ve used, and the only one supported by the Arch team.

We have also yay (and paru) that are helpful with AUR software. Their usage is quite similar to pacman. Note that they can manage also native packages in addition to the AUR stuff.

1 Like

I would look inside the journal entries from the get-go.