Stable release won't boot unless usb stick is in

Hi congrats on new release. However, I installed the stable release on elitebook 8440p. Went smoothly but after the grub menu on reboot it hangs and won’t boot unless any usb drive is plugged in. When usb drive is in it boots fine.

I have ubuntu on a second partition and that boots ok. I have also reinstalled several times and also reinstalled grub on /dev/sda but does not help.

I had the beta release installed with no problems

Any ideas

Hi,
first of all welcome to the forum.
Since you have an Elitebook I’m assuming you have EFI. Could you share your partition scheme, because I think something went wrong with the boot partition.

Thanks Bryan I am not using EFI as far as I know. Here is partition scheme

sudo fdisk -l
Disk /dev/sda: 232.91 GiB, 250059350016 bytes, 488397168 sectors
Disk model: Samsung SSD 850
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x0f375531

Device Boot Start End Sectors Size Id Type
/dev/sda2 524288 257045772 256521485 122.3G 83 Linux
/dev/sda3 257046526 488397167 231350642 110.3G f W95 Ext’d (LBA)
/dev/sda5 476477440 488397167 11919728 5.7G 82 Linux swap / Solaris
/dev/sda6 * 257046528 476477439 219430912 104.6G 83 Linux

Partition table entries are not in disk order.

Disk /dev/sdb: 28.92 GiB, 31029460992 bytes, 60604416 sectors

I fixed that warning but does not do anything for my problem. On boot grub menu comes up but need any usb drive attached in order to boot.

sudo blkid
/dev/sda2: UUID=“09f9c939-376f-4d3a-b43b-33ae0262c857” TYPE=“ext4” PARTUUID=“0f375531-02”
/dev/sda5: UUID=“30ffb09f-f904-4a55-88e5-ec1ed81a70b3” TYPE=“ext4” PARTUUID=“0f375531-05”
/dev/sda6: UUID=“6e536d6d-664d-4d72-b887-9da7fa9a7a25” TYPE=“swap” PARTUUID=“0f375531-06”
/dev/sdc1: LABEL_FATBOOT=“KINGSTON” LABEL=“KINGSTON” UUID=“A8C0-ADF8” TYPE=“vfat” PARTUUID=“a8c0adf8-01”

This is relevant section in grub.cfg:
menuentry ‘EndeavourOS Linux, with Linux linux’ --class endeavouros --class gnu-linux --class gnu --class os $menuentry_id_option ‘gnulinux-linux-advanced-30ffb09f-f904-4a55-88e5-ec1ed81a70b3’ {
load_video
set gfxpayload=keep
insmod gzio
insmod part_msdos
insmod ext2
set root=‘hd0,msdos5’
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-ieee1275=‘ieee1275//disk@0,msdos5’ --hint-bios=hd0,msdos5 --hint-efi=hd0,msdos5 --hint-baremetal=ahci0,msdos5 30ffb09f-f904-4a55-88e5-ec1ed81a70b3
else
search --no-floppy --fs-uuid --set=root 30ffb09f-f904-4a55-88e5-ec1ed81a70b3
fi
echo ‘Loading Linux linux …’
linux /boot/vmlinuz-linux root=UUID=30ffb09f-f904-4a55-88e5-ec1ed81a70b3 rw quiet resume=UUID=6e536d6d-664d-4d72-b887-9da7fa9a7a25 audit=0 loglevel=3
echo ‘Loading initial ramdisk …’
initrd /boot/initramfs-linux.img
}

I didn’t register some very important info on your first post, When the Grub menu boots, does the machine boot the “Ubuntu menu” or the “Arch menu”? Also did you install the bootloader on install of EndeavourOS? If so, it wasn’t necessary.

can you show:

cat /etc/fstab

/dev/sdc1: LABEL_FATBOOT=“KINGSTON” LABEL=“KINGSTON” UUID=“A8C0-ADF8” TYPE=“vfat” PARTUUID=“a8c0adf8-01”

is this the media you were using to install? or do you install from DVD ? or another usb drive ?

Bryanpwo
It is the EndeavourOS menu I believe. As for bootloader I don’t know. I had ubuntu installed first and then created a partition for EndeavourOS.

Joekamprad Thanks for interest. Here is my fstab:

UUID=30ffb09f-f904-4a55-88e5-ec1ed81a70b3 / ext4 defaults,noatime,discard 0 1
UUID=6e536d6d-664d-4d72-b887-9da7fa9a7a25 swap swap defaults,noatime,discard 0 2
tmpfs /tmp tmpfs defaults,noatime,mode=1777 0 0

i can’t see anything related to this issue… if possible you can get bootlog from chrooting into installed system on booting from live-ISO:


and inside the terminal you do the chroot:

lspci > log.txt && lsusb >> log.txt && journalctl -b -0 >> log.txt && cat log.txt | curl -F 'f:1=<-' ix.io
this will put out a short url at the end you can post here.

looks like this:

 ~  lspci > log.txt && lsusb >> log.txt && journalctl -b -0 >> log.txt && cat log.txt | curl -F 'f:1=<-' ix.io
http://ix.io/1OEy

I can boot as long as I have a usb stick in. Here is result of your command.

http://ix.io/1OEC

nothing in there links to an issue on your issue… needs some investigation.

1 Like

@joekamprad – wanted to send heartfelt thanks for your patience in your handling of the many issues unique to particular computer models and not an EndeavourOS fault.

1 Like

you are welcome, every issue can point to something we can make better next time!

Just did a clean install and used the 3rd option of using entire disk. Afraid I got the same result - just blank screen after grub menu unless I have a usb drive in. I believe this model has NVIDIA NVS 3100M graphics controller. Boot ok with usb in.

Have you installed the Nouveau drivers?

sudo pacman -Q xf86-video-nouveau
xf86-video-nouveau 1.0.16-1

Did you also change the mkinitcpio file? you can read what to do over here https://endeavouros.com/docs/hardware-and-network/nouveau/

Tried that the file was /etc/mkinitcpio.con and I changed MODULES="" TO MODULES=(nouveau) as suggested but it was no good. Same would stall after grub menu unless I inserted a usb drive.

Okay, I’m not giving up, try to install nouveau-fw
It’s in the AUR so you can use yay to install it.

Sorry Bryanpwo I forgot to sudo mkinitcpio -p linux and it looks like that did it. I will reboot again to see.