SSD slowed down after installs

So I bricked my fresh Endeavour system, no biggie, just reinstall it… well somewhere during the install my entire computer slowed down, this means Windows, Endeavour, everything!! The whole machine is INCREDIBLY slow.
Booting into Endeavour takes 10 minutes and then 8 to even get the welcome message. I never got the full desktop enviroment to load up (I lost hope in the thing)

For more information:
My computer was already somewhat slow compared to others, but now I feel like even a Raspberry Pi would be faster
I’m dual-booting Windows and Endeavour
I bricked it by trying to rename the root user (despite the warning signs)

Update: after further investigation, it’s just the SSD. Using the SSD on another computer yields the same issue

Any idea what might solve this crisis?

Looks like it’s time for an upgrade. Either replace the SSD or buy a new computer.

Can we start with the output of inxi -Fxxxz?

Haha… my SSD is 2 months old…, but I agree, maybe I’ve somehow messed up the SSD???

Have you changed any settings in BIOS?

  Kernel: 6.0.12-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    Desktop: Xfce v: 4.18.0 tk: Gtk v: 3.24.35 info: xfce4-panel wm: xfwm
    v: 4.18.0 vt: 1 dm: LightDM v: 1.32.0 Distro: EndeavourOS base: Arch Linux
  Type: Desktop System: HP product: 20-c020 v: N/A
    serial: <superuser required> Chassis: type: 13 serial: <superuser required>
  Mobo: HP model: 8245 v: 001 serial: <superuser required> UEFI: AMI v: F.05
    date: 06/03/2016
  Info: quad core model: AMD E2-7110 APU with AMD Radeon R2 Graphics bits: 64
    type: MCP smt: <unsupported> arch: Puma rev: 1 cache: L1: 256 KiB L2: 2 MiB
  Speed (MHz): avg: 1400 high: 1497 min/max: 1000/1800 boost: disabled
    cores: 1: 1172 2: 1451 3: 1483 4: 1497 bogomips: 14378
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: AMD Mullins [Radeon R3 Graphics] vendor: Hewlett-Packard
    driver: radeon v: kernel arch: GCN-2 ports: active: eDP-1 empty: HDMI-A-1
    bus-ID: 00:01.0 chip-ID: 1002:9850 class-ID: 0300
  Display: server: X.Org v: 21.1.5 compositor: xfwm v: 4.18.0 driver: X:
    loaded: radeon unloaded: modesetting alternate: fbdev,vesa dri: radeonsi
    gpu: radeon display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1600x900 s-dpi: 96 s-size: 423x238mm (16.65x9.37")
    s-diag: 485mm (19.11")
  Monitor-1: eDP-1 mapped: eDP model: HP ALL-in-One serial: <filter>
    res: 1600x900 hz: 60 dpi: 94 size: 432x240mm (17.01x9.45")
    diag: 494mm (19.5") modes: max: 1600x900 min: 640x480
  API: OpenGL v: 4.5 Mesa 22.3.1 renderer: KABINI ( LLVM 14.0.6 DRM 2.50
    6.0.12-arch1-1) direct render: Yes
  Device-1: AMD Kabini HDMI/DP Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel bus-ID: 00:01.1 chip-ID: 1002:9840
    class-ID: 0403
  Device-2: AMD FCH Azalia vendor: Hewlett-Packard driver: snd_hda_intel
    v: kernel bus-ID: 00:14.2 chip-ID: 1022:780d class-ID: 0403
  Sound API: ALSA v: k6.0.12-arch1-1 running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.63 running: yes
  Device-1: Realtek RTL8723BE PCIe Wireless Network Adapter
    vendor: Hewlett-Packard driver: rtl8723be v: kernel pcie: speed: 2.5 GT/s
    lanes: 1 port: e000 bus-ID: 01:00.0 chip-ID: 10ec:b723 class-ID: 0280
  IF: wlan0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Hewlett-Packard driver: r8169 v: kernel pcie: speed: 2.5 GT/s
    lanes: 1 port: d000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp2s0 state: down mac: <filter>
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 1-1.3:4 chip-ID: 0bda:b008 class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 946.42 GiB used: 1.8 GiB (0.2%)
  ID-1: /dev/sda vendor: Western Digital model: WD Blue SA510 2.5 1000GB
    size: 931.51 GiB speed: 6.0 Gb/s type: SSD serial: <filter> rev: 5100
    scheme: GPT
  ID-2: /dev/sdb type: USB vendor: SanDisk model: Cruzer Glide
    size: 14.91 GiB type: N/A serial: <filter> rev: 1.27 scheme: MBR
  ID-1: / size: 10 GiB used: 24.8 MiB (0.2%) fs: overlay source: ERR-102
  Alert: No swap data was found.
  System Temperatures: cpu: 78.5 C mobo: N/A gpu: radeon temp: 78.0 C
  Fan Speeds (RPM): N/A
  Processes: 194 Uptime: 2m wakeups: 0 Memory: 3.52 GiB used: 1.37 GiB (39.0%)
  Init: systemd v: 252 default: multi-user Compilers: gcc: 12.2.0 Packages:
  pm: pacman pkgs: 890 Shell: Bash v: 5.1.16 running-in: xfce4-terminal
  inxi: 3.3.24

Keep in mind I’m using the USB installer thing to send this

Well of course yes, but not recently at all. The most that’s changed recently is just the boot order

Have you tried switching to the LTS kernel to see if it was caused by a recent kernel change?

Also, how full is your SSD and have you been running trim on it?

Keep in mind the issue persists even to Windows (again, dual-booting), so I don’t think it’d be a kernel issue… but no, I have not tried switching kernels.

The SSD isn’t even half-way full (I can’t find an exact number…) but it is a complete clone of my old harddrive. I also don’t think I’ve been running ‘trim’ on it? Considering how I don’t actually know what that is

Not saying that this is or might be the cause of the issue you are experiencing but it might be worth to look into if there is a BIOS update for your system.

This is only a suggestion. As always, do your own research and make up your mind for the course of the action. Whatever you choose to do to your system is at your own risk :wink:

Well, I’ve used HP’s “support assistant” to look for updates before, but it says there’s none (even after looking online or whatnot). Pretty sure my computer (an all-in-one) is at its end of life for HP as well

1 Like

If the computer suffers performance in both OSes equally but not when you boot off the ISO, that seems to point to some issue with the hard drive.


Yeah… I agree… any solutions apart from replacing the whole hard drive? Keep in mind the poor thing is only a month or so old.

Regardless, I’ll try the SSD on a different computer to see if the issue persists.

This could be the ssd needing a trim

sudo fstrim -a

Do I run this while running off the hard-drive? (May not be possible)
In other words: can I run this command on an internal drive from an external one


Is it the same command, or do I need to specify which drive it is? (like sda or sdb or whatnot)

You need to mount the drive.

So if you mount the drive at /mnt that should be sufficient.

Then you can either do:

sudo fstrim -a


sudo fstrim /mnt

-a does all mounted filesystems.

1 Like

Based on what is said here, the trim operation on the whole disk could be dangerous. It could affect Windows as well the next time the user boots into it. The SSD might be a lemon.

Why would a trim be dangerous?

If it did, why would that be a problem?