Squiggly lines when scrolling in librewolf in i3

After trying out KDE Plasma, I tried to use i3 because of my curiosity to learn new stuff. One thing I noticed is that whenever I try to scroll my screen in librewolf, there would be squiggly lines, or some parts of the screen would be delayed from syncing when it hits a specific horizontal line. I tried to take a screen record of this using OBS, but when I played the video, it showed me that my screen wasn’t flickering at all! I switched to KDE Plasma X11 to see if it also has the same bug, but it didn’t, so it seems like this is a i3 specific problem. I tried to disable “smooth scrolling” in the settings. It did somehow fix the problem, but I’m not comfortable with it and want smooth scrolling back. Any way to fix this?

Librewolf version: 98.01

inxi - Fazy

~ » inxi -Fazy                                                                                                                                                                                                                  mika@Luna
System:
  Kernel: 5.16.16-arch1-1 x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-linux
    root=UUID=611866a2-d11d-4442-b786-7263350a926f rw quiet
    cryptdevice=UUID=b9e892a4-f9f8-403f-b606-27b363a97077:luks-b9e892a4-f9f8-403f-b606-27b363a97077
    root=/dev/mapper/luks-b9e892a4-f9f8-403f-b606-27b363a97077
    resume=UUID=665bc4e0-0faa-4bac-9fe7-ecfb2dfef3a7 loglevel=3 nowatchdog
    nvme_load=YES
  Desktop: i3 4.20.1 info: i3bar, docker vt: 7 dm: LightDM 1.30.0
    Distro: EndeavourOS base: Arch Linux
Machine:
  Type: Laptop System: Acer product: Aspire A514-53 v: V1.16
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: IL model: Sneezy_IL v: V1.16 serial: <superuser required>
    UEFI: Insyde v: 1.16 date: 01/18/2021
Battery:
  ID-1: BAT0 charge: 28.2 Wh (100.0%) condition: 28.2/53.0 Wh (53.2%)
    volts: 16.4 min: 15.4 model: PANASONIC KT004 AP19B5L type: Li-ion
    serial: <filter> status: Full cycles: 386
  Device-1: hid-f4:73:35:09:1d:b5-battery model: Keyboard K380 serial: N/A
    charge: N/A status: Discharging
CPU:
  Info: model: Intel Core i3-1005G1 bits: 64 type: MT MCP arch: Ice Lake
    family: 6 model-id: 0x7E (126) stepping: 5 microcode: 0xA8
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 160 KiB desc: d-2x48 KiB; i-2x32 KiB L2: 1024 KiB desc: 2x512 KiB
    L3: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 2793 high: 3075 min/max: 400/3400 scaling:
    driver: intel_pstate governor: performance cores: 1: 2584 2: 3075 3: 2797
    4: 2718 bogomips: 9524
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel Iris Plus Graphics G1 vendor: Acer Incorporated ALI
    driver: i915 v: kernel ports: active: HDMI-A-1 off: eDP-1 empty: none
    bus-ID: 00:02.0 chip-ID: 8086:8a56 class-ID: 0300
  Device-2: Chicony HD User Facing type: USB driver: uvcvideo bus-ID: 1-6:4
    chip-ID: 04f2:b64f class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 1.21.1.3 driver: X: loaded: modesetting
    alternate: fbdev,intel,vesa gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 506x285mm (19.9x11.2")
    s-diag: 581mm (22.9")
  Monitor-1: HDMI-1 mapped: HDMI-A-1 model: LG (GoldStar) FULL HD
    built: 2016 res: 1920x1080 hz: 60 dpi: 102 gamma: 1.2
    size: 480x270mm (18.9x10.6") diag: 551mm (21.7") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  OpenGL: renderer: Mesa Intel UHD Graphics (ICL GT1) v: 4.6 Mesa 21.3.7
    direct render: Yes
Audio:
  Device-1: Intel Ice Lake-LP Smart Sound Audio vendor: Acer Incorporated ALI
    driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_icl
    bus-ID: 00:1f.3 chip-ID: 8086:34c8 class-ID: 0401
  Device-2: C-Media USB PnP Sound Device type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-1:2 chip-ID: 0d8c:013a
    class-ID: 0300
  Sound Server-1: ALSA v: k5.16.16-arch1-1 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: yes
  Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
  Device-1: Intel Ice Lake-LP PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:34f0 class-ID: 0280
  IF: wlan0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Acer Incorporated ALI driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 01:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp1s0 state: down mac: <filter>
  IF-ID-1: br-6fe731a68570 state: up speed: 10000 Mbps duplex: unknown
    mac: <filter>
  IF-ID-2: docker0 state: down mac: <filter>
  IF-ID-3: veth7dc610f state: up speed: 10000 Mbps duplex: full
    mac: <filter>
Bluetooth:
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-10:5 chip-ID: 8087:0026 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
RAID:
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
    v: 3.0 port: 4060 bus-ID: 00:17.0 chip-ID: 8086:282a rev: N/A class-ID: 0104
Drives:
  Local Storage: total: 1.4 TiB used: 432.15 GiB (30.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: HBRPEKNX0202A
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 15.8 Gb/s
    lanes: 2 type: SSD serial: <filter> rev: G002 temp: 33.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:8 vendor: Intel model: HBRPEKNX0202AO
    size: 27.25 GiB block-size: physical: 512 B logical: 512 B speed: 15.8 Gb/s
    lanes: 2 type: SSD serial: <filter> rev: K5110440 temp: 46.9 C scheme: GPT
  ID-3: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM048-2E7172
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 5400 serial: <filter> rev: 0001 scheme: GPT
Partition:
  ID-1: / raw-size: 69.85 GiB size: 68.2 GiB (97.64%) used: 30.61 GiB (44.9%)
    fs: ext4 dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-b9e892a4-f9f8-403f-b606-27b363a97077
  ID-2: /boot/efi raw-size: 489 MiB size: 488 MiB (99.80%)
    used: 28 MiB (5.7%) fs: vfat dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-3: /home raw-size: 162.98 GiB size: 159.36 GiB (97.78%)
    used: 78.47 GiB (49.2%) fs: ext4 dev: /dev/dm-1 maj-min: 254:1
    mapped: luks-05a5ae76-4f16-418d-b6dd-70173c6d5b5e
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 10.25 GiB used: 8.5 MiB (0.1%)
    priority: -2 dev: /dev/nvme0n1p1 maj-min: 259:1
Sensors:
  System Temperatures: cpu: 60.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 280 Uptime: 50m wakeups: 3 Memory: 7.45 GiB
  used: 3.88 GiB (52.2%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 Packages: 1487 pacman: 1461 lib: 353 flatpak: 26 Shell: Zsh
  v: 5.8.1 running-in: xfce4-terminal inxi: 3.3.13

You mean screen tearing?

Try to go to KDE Settings → Display and Monitor → Compositor → Tearing prevention (vsync)
Choose: Re-use screen content

(oh sorry, you’re on i3 now…@joekamprad probably could give some advice)

1 Like

is tearfree enabled?

i3 itself does not have any settings for managing gpu/driver options… it uses xorg settings…
It could be also related to picom (compositor) if it is in use?