Spectacle is stuck in one window

Spectacle is stuck in one window, the first one it was open. And, it doesn’t want to change, so can’t take a screenshot. Is there a way to clear it? This happens on and off.

I uninstalled Spectacle and installed Flameshot, but the problem is still there. This means, it is something to with Endeavour OS KDE Plasma.

I have made bug report here, before I installed Flameshot. But, after I installed Flameshot, it looks like it is an Endeavour/Arch matter with KDE Plasma.

I have checked with OPenSuse Tumbleweed KDE Plasma, spectacle works quite well.

Not Endeavour or Arch specific, I’ve encountered it on Chakra a few times. Solved itself at some point, no idea how. Chakra lags behind everyone else ridiculously much though, 5.2 kernel should tell you all you need to know, so its Spectacle version likely is a year and half older than Arch’s…
Haven’t encountered this problem on Endeavour so far though.

I know, not very helpful, sorry…

What about Flameshot? It has the same problem. Only app that works well taking a screenshot is GIMP at the moment.

Can’t comment on that, as I had never heard of Flameshot until I read this thread.

I was looking for a screenshot app to replace Spectacle, but it too got the same problem. So, I thought this is not a screenshot app’s problem, but the OS or the DE’s problem. Then, I went and checked OpenSuse Tumbleweed KDE. Spectacle works quite well there. So, it might be a OS problem. The app, or the OS cannot clear the cache somehow. Don’t know how to do that.

Well, at least I have GIMP :slight_smile:

I am not sure exactly what is causing your issue but I can’t replicate it on any of my machines.

I have used spectacle for almost 2 years now and never had this issue on EndeavourOS in KDE.

1 Like

Like I mentioned above, this happens with other screenshot applications too, so it looks like the EndeavourOS is not clearing the cache somehow.

As you see, Spectacle is holding on to a screen before.

And if you click take a new screenshot? Spectacle always displays the last screenshot until you take a new one.

1 Like

No, that was not the last screenshot. (I never took the screenshot.) It just displays any other random screen. When trying to take a rectangular region, it goes to some other screen, even one that’s long time closed. This happens with any other screenshot app too.

I’ve dropped Spectacle for now. Useless fighting with it atm. Maybe, it’d correct itself or EOS. For what I need, I use GIMP.

It’s not necessarily a KDE problem as you assume. It might be a problem with the compositor. Are you using wayland?
What’s the output of hwinfo --gfxcard?
Maybe you will have to install hwinfo.

$ echo $XDG_SESSION_TYPE
x11

$ hwinfo --gfxcard
25: PCI 02.0: 0300 VGA compatible controller (VGA)              
  [Created at pci.386]
  Unique ID: _Znp.EE5nvNhuk33
  SysFS ID: /devices/pci0000:00/0000:00:02.0
  SysFS BusID: 0000:00:02.0
  Hardware Class: graphics card
  Model: "Intel Iris Plus Graphics G1 (Ice Lake)"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x8a56 "Iris Plus Graphics G1 (Ice Lake)"
  SubVendor: pci 0x17aa "Lenovo"
  SubDevice: pci 0x3f1a 
  Revision: 0x07
  Driver: "i915"
  Driver Modules: "i915"
  Memory Range: 0x6000000000-0x6000ffffff (rw,non-prefetchable)
  Memory Range: 0x4000000000-0x400fffffff (ro,non-prefetchable)
  I/O Ports: 0x3000-0x303f (rw)
  Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
  IRQ: 140 (380907 events)
  Module Alias: "pci:v00008086d00008A56sv000017AAsd00003F1Abc03sc00i00"
  Driver Info #0:
    Driver Status: i915 is active
    Driver Activation Cmd: "modprobe i915"
  Config Status: cfg=new, avail=yes, need=no, active=unknown

Primary display adapter: #25

Did you check if the problem persists with a new user? Maybe some of your session settings are screwed.


Taken from GIMP

I guess there is some misunderstanding. What I meant by saying session settings was kind of misconfiguration in your hidden Plasma configuration folder. Sorry for not being clear enough.

Edith says : Starting with an empty session might eventually solve the issue. After changing the setting, don’t forget to log out and log in again.

Where to find it? How to clear it?

I edited my previous post. Maybe it would be a good idea to try that first.

How do I do that? Starting with an empty session?

Just take a look at the screenshot you posted. The setting is available in section On Login.