'soundconverter' does not work

Dear EOS Friends:

For a very long time I use ‘soundconverter’ to change my ogg/flac files to mp3. But now it is not working. The GUI link ‘Application – Sound and Video – Sound Converter’ does not work – the cursor goes on going round and round.

And this is the command line output:

$: soundconverter
Traceback (most recent call last):
File “/usr/bin/soundconverter”, line 33, in
import pkg_resources
ModuleNotFoundError: No module named ‘pkg_resources’
$:

I installed it with ‘yay -Syu soundconverter’ and it showed no problem.

Any help anyone?

Try yay -S soundconverter . Syu is used for updating.

Nothing changed. Thanks for trying to help anyway.

This might be of some interest.

Also, in AUR, package is named as soundconverter-git.

Try using yay -S soundconverter-git.

I did but the same results once again:

<<
soundconverter
Traceback (most recent call last):
File “/usr/bin/soundconverter”, line 33, in
import pkg_resources
ModuleNotFoundError: No module named ‘pkg_resources’

Should I do ‘yay -Rnc soundconverter’ before ‘yay -S soundconverter-git’?

So many thanks for lingering with me.

Using yay -Rsn soundconverter should be enough. Then use yay -S soundconverter-git.

No, exactly the same thing again.

Wait up, I will try to find up the solution.

Thank you so much. You really sound like your name – PhoenixAwakened. :slight_smile:

1 Like

It seems like there is error with python on your system. If you look at the topic I shared, the error there had shown output of python instances when executed from terminal. But they are not in your case.

How to correct the error with python? Reinstall?

To check soundconverter, I installed it on my system now :

~ ❯❯❯ yay soundconverter
2 aur/soundconverter-git 4.0.3+12+gf1611d6-1 (+8 0.00) 
    A simple sound converter application for GNOME
1 community/soundconverter 4.0.3-1 (239.3 KiB 839.3 KiB) 
    A simple sound converter application for GNOME
==> Packages to install (eg: 1 2 3, 1-3 or ^4)
==> 1
[sudo] password for deweshk: 
resolving dependencies...
looking for conflicting packages...

Package (7)               New Version  Net Change  Download Size

extra/aalib               1.4rc5-14      0.28 MiB       0.13 MiB
extra/gst-plugins-good    1.20.3-1       6.50 MiB       1.96 MiB
extra/gst-python          1.20.3-1       0.13 MiB       0.03 MiB
extra/libshout            1:2.4.6-1      0.19 MiB       0.07 MiB
community/twolame         0.4.0-2        0.24 MiB       0.08 MiB
extra/wavpack             5.5.0-1        0.85 MiB       0.49 MiB
community/soundconverter  4.0.3-1        0.82 MiB       0.23 MiB

Total Download Size:   3.00 MiB
Total Installed Size:  9.01 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 aalib-1.4rc5-14-x86_64                           136.3 KiB  27.2 KiB/s 00:05 [--------------------------------------------] 100%
 twolame-0.4.0-2-x86_64                            78.2 KiB  15.6 KiB/s 00:05 [--------------------------------------------] 100%
 soundconverter-4.0.3-1-any                       239.3 KiB  47.8 KiB/s 00:05 [--------------------------------------------] 100%
 wavpack-5.5.0-1-x86_64                           506.9 KiB  97.7 KiB/s 00:05 [--------------------------------------------] 100%
 gst-python-1.20.3-1-x86_64                        33.8 KiB  60.3 KiB/s 00:01 [--------------------------------------------] 100%
 libshout-1:2.4.6-1-x86_64                         69.8 KiB  93.4 KiB/s 00:01 [--------------------------------------------] 100%
 gst-plugins-good-1.20.3-1-x86_64                2007.8 KiB   166 KiB/s 00:12 [--------------------------------------------] 100%
 Total (7/7)                                        3.0 MiB   243 KiB/s 00:13 [--------------------------------------------] 100%
(7/7) checking keys in keyring                                                [--------------------------------------------] 100%
(7/7) checking package integrity                                              [--------------------------------------------] 100%
(7/7) loading package files                                                   [--------------------------------------------] 100%
(7/7) checking for file conflicts                                             [--------------------------------------------] 100%
:: Processing package changes...
(1/7) installing wavpack                                                      [--------------------------------------------] 100%
(2/7) installing aalib                                                        [--------------------------------------------] 100%
(3/7) installing libshout                                                     [--------------------------------------------] 100%
(4/7) installing twolame                                                      [--------------------------------------------] 100%
(5/7) installing gst-plugins-good                                             [--------------------------------------------] 100%
(6/7) installing gst-python                                                   [--------------------------------------------] 100%
(7/7) installing soundconverter                                               [--------------------------------------------] 100%
:: Running post-transaction hooks...
(1/5) Arming ConditionNeedsUpdate...
(2/5) Compiling GSettings XML schema files...
(3/5) Updating icon theme caches...
(4/5) Updating the info directory file...
(5/5) Updating the desktop file MIME type cache...

And after that, I executed it from terminal without any error.

After your suggestion I reinstalled python and reinstalled soundconverter-git once again, without producing any change.

My desktop is Mate – can that be the source of this problem?

And I am not at all technical like you people, I am just a teacher in economics and I love floss.

Look at this :


~ ❯❯❯ soundconverter 
soundconverter 4.0.3
analysing file integrity
adding: 1 files
Discovered 1 audiofiles in 0.2 s

Everything is going normal.

try executing :

yay -S python-setuptools .

1 Like

I am also not a technical person.

I don’t think so. I am using KDE. And this utility is built for GNOME.

Thank you. This time it worked. And I did ‘yay -Rns’ with soundconverter-git and did ‘yay -S soundconverter’ and it worked. So many thanks for recovering my ashes dear PhoenixAwakened. :smile:

1 Like

Thanks sir. Mark the reply as solution which helped you, so that it can be helpful for others with similar issue.

You can update and install new packages at the same time. In fact, when installing from the AUR, it’s a good idea to do so with an updated system.

2 Likes