[SOLVED] Soundconverter no longer launches

Greetings lovely community,

I don’t use soundconverter v4.0.1-2 ( Github ) often so I’m not exactly sure when this issue cropped up (last time I used it was about a month ago), but when I try to launch it, nothing happens. Any advice would be much appreciated. When I try to launch it from a terminal I get the following error:

[scott@endeavourOS ~]$ soundconverter
Traceback (most recent call last):
  File "/usr/bin/soundconverter", line 33, in <module>
    import pkg_resources
  File "/usr/lib/python3.10/site-packages/pkg_resources/__init__.py", line 3243, in <module>
    def _initialize_master_working_set():
  File "/usr/lib/python3.10/site-packages/pkg_resources/__init__.py", line 3226, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.10/site-packages/pkg_resources/__init__.py", line 3255, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.10/site-packages/pkg_resources/__init__.py", line 559, in _build_master
    ws = cls()
  File "/usr/lib/python3.10/site-packages/pkg_resources/__init__.py", line 552, in __init__
  File "/usr/lib/python3.10/site-packages/pkg_resources/__init__.py", line 608, in add_entry
    for dist in find_distributions(entry, True):
  File "/usr/lib/python3.10/site-packages/pkg_resources/__init__.py", line 2063, in find_on_path
    for dist in factory(fullpath):
  File "/usr/lib/python3.10/site-packages/pkg_resources/__init__.py", line 2128, in distributions_from_metadata
    yield Distribution.from_location(
  File "/usr/lib/python3.10/site-packages/pkg_resources/__init__.py", line 2591, in from_location
  File "/usr/lib/python3.10/site-packages/pkg_resources/__init__.py", line 2989, in _reload_version
    md_version = self._get_version()
  File "/usr/lib/python3.10/site-packages/pkg_resources/__init__.py", line 2770, in _get_version
    version = _version_from_file(lines)
  File "/usr/lib/python3.10/site-packages/pkg_resources/__init__.py", line 2554, in _version_from_file
    line = next(iter(version_lines), '')
  File "/usr/lib/python3.10/site-packages/pkg_resources/__init__.py", line 2765, in _get_metadata
    for line in self.get_metadata_lines(name):
  File "/usr/lib/python3.10/site-packages/pkg_resources/__init__.py", line 1417, in get_metadata_lines
    return yield_lines(self.get_metadata(name))
  File "/usr/lib/python3.10/site-packages/pkg_resources/__init__.py", line 1407, in get_metadata
    value = self._get(path)
  File "/usr/lib/python3.10/site-packages/pkg_resources/__init__.py", line 1611, in _get
    with open(path, 'rb') as stream:
PermissionError: [Errno 13] Permission denied: '/usr/lib/python3.10/site-packages/google_api_core-2.3.2-py3.10.egg-info/PKG-INFO'
[scott@endeavourOS ~]$ 

Edit: I also get the same error with Tauon Music Box as well, but that’s an AUR package based on python, so I’ll keep support to just soundconverter but interesting to know it’s not the only thing affected right now.

Edit2: If anyone comes here with the same issue/error, just update your system to pull in the new python-google-api-core and you should be good to go then.

Both are based on python. Might have to rebuild them. Didn’t you’re the one who reported the update from 3.9 to 3.10 :smiley: .

yay -S $(pacman -Qoq /usr/lib/python3.9) --answerclean All
1 Like

That is an interesting error. What are the permissions on that file?

soundconverter is a repo package.

1 Like

So doesn’t it need to be rebuilt?

@s4ndm4n as mentioned above soundconverter is a repo pacakge, so the Arch devs have already rebuilt so it shouldn’t require any intervention from us, and yes I’ve rebuilt all my AUR packages before, but that isn’t the issue at hand unfortunately this time around. Just to be doubly sure, I ran it again, but there’s nothing to rebuild since it’s all been rebuilt already:

[scott@endeavourOS ~]$ yay -S $(pacman -Qoq /usr/lib/python3.9) --answerclean All
error: No package owns /usr/lib/python3.9
[scott@endeavourOS ~]$ 

@dalto need me to post a pacman -Qi I take it?

1 Like

The packages in the repo are already built.

To start, this:

ls -l /usr/lib/python3.10/site-packages/google_api_core-2.3.2-py3.10.egg-info/PKG-INFO
[scott@endeavourOS ~]$ ls -l /usr/lib/python3.10/site-packages/google_api_core-2.3.2-py3.10.egg-info/PKG-INFO
-rw-r----- 1 root root 1820 Dec 17 14:13 /usr/lib/python3.10/site-packages/google_api_core-2.3.2-py3.10.egg-info/PKG-INFO
[scott@endeavourOS ~]$ 

Ahh…yeah, it isn’t readable alright. How about:

pacman -Qo /usr/lib/python3.10/site-packages/google_api_core-2.3.2-py3.10.egg-info/PKG-INFO
[scott@endeavourOS ~]$ pacman -Qo /usr/lib/python3.10/site-packages/google_api_core-2.3.2-py3.10.egg-info/PKG-INFO
/usr/lib/python3.10/site-packages/google_api_core-2.3.2-py3.10.egg-info/PKG-INFO is owned by python-google-api-core 2.3.2-1
[scott@endeavourOS ~]$ 

Edit: If this is helpful:

[scott@endeavourOS ~]$ pacman -Qi python-google-api-core
Name            : python-google-api-core
Version         : 2.3.2-1
Description     : Google API client core library
Architecture    : any
URL             : https://github.com/googleapis/googleapis
Licenses        : Apache
Groups          : None
Provides        : None
Depends On      : python-setuptools  python-pytz  python-requests
                  python-googleapis-common-protos  python-google-auth
Optional Deps   : python-grpcio: for grpc support
Required By     : python-google-api-python-client
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 885.29 KiB
Packager        : Morten Linderud <foxboron@archlinux.org>
Build Date      : Fri 17 Dec 2021 02:13:58 PM EST
Install Date    : Fri 17 Dec 2021 08:30:37 PM EST
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : Signature

[scott@endeavourOS ~]$ 

Okay maybe this was an issue that just happened. I update daily. This update literally just came out now, so I’ll install it and see it if fixes it; might’ve just been perfect timing:

[scott@endeavourOS ~]$ yay
[sudo] password for scott: 
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community               5.9 MiB  1361 KiB/s 00:04 [-----------------------] 100%
 multilib is up to date
 endeavouros is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

warning: insufficient columns available for table display
Packages (1) python-google-api-core-2.3.2-2

Total Download Size:   0.11 MiB
Total Installed Size:  0.86 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 python-google-ap...   115.1 KiB   421 KiB/s 00:00 [-----------------------] 100%
(1/1) checking keys in keyring                     [-----------------------] 100%
(1/1) checking package integrity                   [-----------------------] 100%
(1/1) loading package files                        [-----------------------] 100%
(1/1) checking for file conflicts                  [-----------------------] 100%
(1/1) checking available disk space                [-----------------------] 100%
:: Processing package changes...
(1/1) upgrading python-google-api-core             [-----------------------] 100%
:: Running post-transaction hooks...
(1/2) Arming ConditionNeedsUpdate...
(2/2) Checking which packages need to be rebuilt
:: Searching databases for updates...
:: Searching AUR for updates...
 -> Flagged Out Of Date AUR Packages:  minecraft-launcher
 there is nothing to do
[scott@endeavourOS ~]$

That looks like a bug in the python-google-api-core package

A bug report should probably be filed with Arch if one hasn’t been filed already.

In the meantime, you can workaround it with:

sudo chmod o+r /usr/lib/python3.10/site-packages/google_api_core-2.3.2-py3.10.egg-info/PKG-INFO

I had similar, removed google-api-core and installed from pip (with sudo). Which fixed the problem.

This is an absolutely terrible idea. Nobody should ever do that.


So I just ran yay since there was an update to python-google-api-core that was just released now and this latest version fixes it. I can successfully launch soundconverter and Tauon Music Box again, so looks like all we had to do today was be a little patient this time around :wink:

So the bug is fixed, nothing else to report, what a relief! Thanks for coming to my rescue though guys I appreciate this awesome community very much and I’m glad the bug was caught and fixed quickly enough by the Arch devs:slight_smile:

1 Like

Ahh…it looks like a fixed package was pushed already. I literally got the update 2 minutes ago.

1 Like

Just for information :
tauon-music-box working without any problems on my machines

1 Like

You are always quick to fix things, but the Arch devs were just a bit quicker this time :stuck_out_tongue:

Edit: @Trekkie00 yup, it’s working fine now for me too thanks to this update. I let the Tauon dev know in their discord, but they are in New Zealand, so it’s still a bit early for them right now. But I also let them know that this update fixes it, so they shouldn’t have to do anything in case other users report it.

Why? it is only a python package and needs to be under /usr/libs, pacman requires sudo to do this.

Because when you install things with sudo pip you write to the same locations that pacman wants to write. Further, by removing that package, other packages no longer know it is installed and will try to pull it in again. However, this will fail, because pacman will see that those files already exist.

You should never use sudo pip on a Arch-based distro.