Sound Card Not Detected

Hello all,
Sorry to bother you guys but I have been trying to fis my sound for the longest time. I have an HP Probook 450 G7 and I cannot get any sound playing on the computer. I was able to play sound before but after I took the computer to a repair store to be fixed because my bios updated and the power went out, I have not been able to activate any sound. I have tried aplay -l and it says no sound cards detected. However when I ran a system diagnostics in the bios the audio passed. Can anyone help please?

Welcome! :partying_face:

Give us some more info on your system:

inxi -Fxxxz

Here’s what i found meanwhile, without more specific details:

Fix sound
Note: With PulseAudio 14, all that is needed is sof-firmware

Install sof-firmware
Add snd_hda_intel.dmic_detect=0 to the kernel parameters.

(c) https://wiki.archlinux.org/index.php/HP_ProBook_450_G7


So if it’s the case try this:

  1. Install firmware

    sudo pacman -S sof-firmware
    
  2. Open your /etc/default/grub

  3. Add that parameter snd_hda_intel.dmic_detect=0 to that line:

    GRUB_CMDLINE_LINUX_DEFAULT="some other options snd_hda_intel.dmic_detect=0"
    
  4. Rebuild your grub

    sudo grub-mkconfig -o /boot/grub/grub.cfg
    
  5. Reboot

P.S. Also check instructions for microphone fix in same article, in case it doesn’t work as well :upside_down_face:

3 Likes

Thanks.
Here is the output from inxi -Fxxxz

System:    Kernel: 5.11.12-arch1-1 x86_64 bits: 64 compiler: gcc v: 10.2.1 Desktop: Cinnamon 4.8.6 tk: GTK 3.24.28 
           dm: LightDM 1.30.0 Distro: EndeavourOS base: Arch Linux 
Machine:   Type: Laptop System: HP product: HP ProBook 450 G7 v: N/A serial: <filter> Chassis: type: 10 
           serial: <filter> 
           Mobo: HP model: 86A0 v: KBC Version 02.2F.00 serial: <filter> UEFI: HP v: S71 Ver. 01.07.02 
           date: 10/29/2020 
Battery:   ID-1: BAT0 charge: 34.1 Wh condition: 42.9/45.0 Wh (95%) volts: 12.3/11.4 
           model: Hewlett-Packard Primary type: Li-ion serial: <filter> status: Unknown cycles: 80 
CPU:       Info: Quad Core model: Intel Core i7-10510U bits: 64 type: MT MCP arch: Kaby Lake note: check rev: C 
           L2 cache: 8 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 36812 
           Speed: 1100 MHz min/max: 400/4900 MHz Core speeds (MHz): 1: 1100 2: 1100 3: 1100 4: 1100 5: 1100 
           6: 1100 7: 1100 8: 1100 
Graphics:  Device-1: Intel UHD Graphics vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:9b41 class ID: 0300 
           Device-2: NVIDIA GP108M [GeForce MX250] vendor: Hewlett-Packard driver: nouveau v: kernel 
           bus ID: 01:00.0 chip ID: 10de:1d13 class ID: 0302 
           Device-3: Quanta HP HD Camera type: USB driver: uvcvideo bus ID: 1-2:2 chip ID: 0408:5373 
           class ID: 0e02 serial: <filter> 
           Display: x11 server: X.org 1.20.10 driver: loaded: intel,modesetting unloaded: fbdev,vesa 
           alternate: nouveau,nv resolution: <missing: xdpyinfo> 
           Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:     Device-1: Intel Comet Lake PCH-LP cAVS vendor: Hewlett-Packard driver: sof-audio-pci bus ID: 00:1f.3 
           chip ID: 8086:02c8 class ID: 0401 
           Sound Server: ALSA v: k5.11.12-arch1-1 
Network:   Device-1: Intel Comet Lake PCH-LP CNVi WiFi driver: iwlwifi v: kernel port: 5000 bus ID: 00:14.3 
           chip ID: 8086:02f0 class ID: 0280 
           IF: wlan0 state: down mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Hewlett-Packard driver: r8169 
           v: kernel port: 3000 bus ID: 02:00.0 chip ID: 10ec:8168 class ID: 0200 
           IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Bluetooth: Device-1: Intel type: USB driver: btusb v: 0.8 bus ID: 1-10:5 chip ID: 8087:0026 class ID: e001 
           Message: Required tool hciconfig not installed. Check --recommends 
Drives:    Local Storage: total: 1.16 TiB used: 5.89 GiB (0.5%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLQ256HAJD-000H1 size: 238.47 GiB speed: 31.6 Gb/s lanes: 4 
           rotation: SSD serial: <filter> rev: HPS4NFXV temp: 44.9 C scheme: GPT 
           ID-2: /dev/sda vendor: Toshiba model: MQ04ABF100 size: 931.51 GiB speed: 6.0 Gb/s rotation: 5400 rpm 
           serial: <filter> rev: 7C scheme: GPT 
           ID-3: /dev/sdb type: USB vendor: SanDisk model: Cruzer Blade size: 14.53 GiB serial: <filter> rev: 1.00 
           scheme: MBR 
Partition: ID-1: / size: 224.71 GiB used: 5.89 GiB (2.6%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-2: /boot/efi size: 299.4 MiB used: 280 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 
Swap:      ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p3 
Sensors:   System Temperatures: cpu: 49.0 C mobo: 41.0 C gpu: nouveau temp: 41.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 257 Uptime: 1m wakeups: 1 Memory: 7.61 GiB used: 1.47 GiB (19.4%) Init: systemd v: 248 
           Compilers: gcc: 10.2.0 Packages: pacman: 802 Shell: Bash v: 5.1.4 running in: gnome-terminal 
           inxi: 3.3.01 

I have tried reading the arch wiki. and have already installed sof-firmware but to no avail. Sorry I am a real newbie at this. Thanks.

P.S. Microphone doesn’t work as well. Thanks!

1 Like

Please read the rest of @keybreak`s post.

2 Likes

Well, if you haven’t missed steps 2-5 in my post…Then i’m not sure yet :thinking:

No worries, we’ve all been there :upside_down_face:

btw, when sharing code, please wrap markdown’s codeblock tag around it, like this:

```
code goes here
```
It will be easier to read then, you can edit your post with pencil icon on the right bottom :wink:

2 Likes

Okay, will do. I am currently trying to edit the /etc/default/grub file like you told me to. then I will try and rebuild my grub. Thanks for the help BTW!

1 Like

wow…your solution totally worked! I have been trying to fix this audio for like 3 days! Thank you so much. If you are not busy, what exactly did I do? How did that fix it?

BTW thanks so much for the help!

2 Likes

yeah I should have read his reply right the first time. Fixed it like a charm!

1 Like

Hi, first of all, welcome to the community.

Could you be so kind to mark @keybreak’s answer as a solution, for future users who encounter the same issue?

2 Likes

Sure thing. Marked. Thanks!

1 Like

No problem! :slight_smile:
Don’t hesitate to ask, you’ll learn.


Well…

GRUB is a bootloader which we use by default on EndeavourOS / Arch.

You’ve edited it’s config to tell Linux Kernel via GRUB_CMDLINE_LINUX_DEFAULT line, that you want to bypass the default Intel driver for your sound card (snd_hda_intel.dmic_detect=0)

Which means that it will be forced to use sof-firmware you’ve installed first, and your specific laptop needs to work properly.

And this line you always need to run for any changes you’ve made in GRUB configuration to work:

sudo grub-mkconfig -o /boot/grub/grub.cfg

btw, how’s mic already working?

If not - try to do that, from same arch wiki:

  1. Open file
    etc/pulse/default.pa
    
  2. Add this line to file:
    load-module module-alsa-source device=hw:0,6 channels=40
    
2 Likes

man @keybreak you really know your stuff…the microphone was not working before but I was thinking I should just leave well enough alone after you helped fix the audio output. I tried your solution and again it fixed it! I also ran the line for sudo grub-mkconfig -o /boot/grub/grub.cfg after I added the line to the pulse file.

Also thanks for the explanation. Basically the line you gave me made my computer force the use of sof-firmware. Thanks again!

2 Likes

I wish… :rofl:

Just learned to search some patterns fast enough and then read in “Linux”, it’s like a language - comes with time :upside_down_face:

2 Likes

I really appreciate the help! I am trying to learn this language but it’s harder than Ancient Greek to me! What would have took me over 3 days you got fixed in less than an hour! Thanks!

2 Likes

Welcome to the forum. Thanks for giving EndeavourOS a try. I hope you enjoy your time here.

It’s great that the audio and microphone are working, but now comes yet another important step. Write up a little procedure of what you did, which commands and in what order. Then store it as a text file and put it somewhere it wiil be safe in case of your computer crashing as it did this time.

Pudge

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.