Some doubt regarding eos install

so i have two hds here, i decided to keep one with my main eos install and the other one with w10 format and install eos on it, but when i try to boot it i get an error like “Default boot device Missing or boot failed”, one question, i had chose GPT, should i use MBR instead of gpt for legacy bios like mine ?

Where you choose that? In case the machine is like 10y old Bios only and not able to boot in UEFI mode at all you can use gpt too but with this you can not use automatic partition options in the installer it needs to use manual partition and create a 8MB empty partition flagged as bios-grub… and it is reported to not work in cases…
Most easy will be to use MBR.

here’s a photo of the error, the installations seems to have went well, it asked me to reboot at the end etc, i can see the partition from dolphin
2024-05-15_10-46


if i remember well i installed eos on an older pc here 2 days ago with legacy bios and chose gpt and it worked well, but then i used a dvd to install and not flash drive, maybe something wrong with the flash drive not sure

How did you burn the USB? Did you use Unetbootin?

no i used mint stick, i’d prefer to use a dvd to format but my new pc case cant have it, so i’ve been looking to buy an external dvd burner from lenovo because i tend to prefer dvd over flash drives

Of course it is up to you, but I’d recommend against DVD.
USB sticks are simply more convenient in my view.

Mixing UEFI boot and MBR boot is known to cause problems in some cases. May depend on the motherboard if it supports booting both.

Post some terminal output:

sudo parted -l

efibootmgr

This may help people who may be able to help to maybe have something to go by.

1 Like

which file system do you recommend for a bootable usb flash drive ? i may read and maybe used NTFS

For what purpose?
Sharing files between Linux and Windows?
Burning the ISO installer environment to it?

just for burning linux iso

If you burn the EndeavourOS ISO installer to the USB drive with dd, you don’t need to format the drive.

i suspect it might be something bad with my usb, it’s from kingston and like 10yo or so, when i tried to do backup on it, when i copied the files from my hd it corrupted like 20% of the files, and i feel and read that’s not a good brand, maybe i just try another usb flash drive or buy a different brand maybe a patriot usb stick, on the older pc here with legacy bios i formated it using gpt, used manual partition, i normally just create / and /home

I also have bad experience with Kingston USB sticks. Better buy one from another maker. For example, here Sandisk sticks have been without issues so far.

yes i tried backup on 3 from kingston, copying files to it seems to have ran well, but when i tried to copy the files from it all the 3 corrupeted like 20-30% of my files, i am staying away from kingston from now on

Also if you say “new PC” why a new PC is still running on Bios? new in case would be at least like not older as 5 years… Bios is not in that devices mainly… they run modern EFI UEFI firmware.
If that it could be simply you set to use legacy Bios CSM mode in the system firmware interface.

What @pebcak mention would be good to see. simply from booting the Live ISO. And It will not matter if device is a DVD or USB stick DVD is only much slower on read files and bootup like 100 times slower.

And yea… the EndeavourOS ISO files is a hybrid ISO, it must be written as it is… if you change the bootloader it will fail in the one way or the other.
Read here for recommendations on creating install media:
https://discovery.endeavouros.com/installation/create-install-media-usb-key/2021/03/

1 Like

so i need to run both commands after loading the Live iso ? i was unsure where to run those commands

efibootmgr will show if you are booted in uefi or Bios(legacy) mode.

sudo parted -l will show information about your partitions/drive

you can post a photo made with smartphone too in case… or use our log pastebin tool withnthe commands to send the output to online pastebin and you can post the url it gives out:

efibootmgr | eos-sendlog
sudo parted -l | eos-sendlog

i found this comment regarding mintstick, so it seems to be ok for isos ?