[Solved] Slow transfer speeds with static IP's, maybe? [Solved] Operator error lol

Long story short as possably, I thought I had a bad network cable, Samba or a router issue, hours of trying to find why I had such a low transfer speed to my server finnally eliminate samba, routers and cables as to why I was getting 11.2 MB/s max if I was lucky copying large files over.

I eliminated it being samba by copying a file through ssh and it told me the same speed as the plasma copy file information did, between 10 & 11 MB/s.

Apparently it’s been this way I just never noticed until I had to copy large video directories back and forth.

All my machines have giganics in them
On 2 of my machines, I have static Ip’s set and during the hours spent looking for an answer I happened to use

inxi -Fxz

On the two machines with static ip’s set the give this

        *Machine 1*
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
           vendor: Acer Incorporated ALI driver: r8169 v: kernel port: d800 bus ID: 03:00.0 
           IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>

        *Machine 2*
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell driver: r8168 v: 8.048.03-NAPI 
           port: e000 bus ID: 02:00.0 
           IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>

Why are giganics only running at 100Mbps?

I set up the static ip’s manually in the netctl directory so I didn’t know if not doing it in plasma network setup
was making it all wonky or not…

The static configs look like this are the same other than Ip addys & interface

Description='Wired'
Interface=enp3s0
Connection=ethernet
IP=static
Address=('192.168.1.144/24')
Gateway=('192.168.1.1')
DNS=('192.168.1.1', '8.8.8.8', '8.8.4.4')

#gives ip if cable unplugged
 ForceConnect=yes
 SkipNoCarrier=yes

But I am stuck and do not know how or what to try next to get those machines to say 1000Mbps instead of 100Mbps

It won’t be anything to do with setting a static IP address.

More likely due to bypassing carrier detect

so possibly you’re not giving it time to detect a 1Gbps carrier.

Those options are now turned off,
restarted with
$ netctl restart enp3s0
no change

rebooted,
nochange I might have tried that, but I did it again anyway, thankyou for the suggestion
I didn’t really think it would be because of static ip’s,
but it’s whats common between the two that I noticed.

Have you tried using ethtool?

sudo ethtool -s enp3s0  speed 1000 duplex full autoneg on

ethtool -s enp3s0 speed 1000
netlink error: No such file or directory
Cannot set new settings: Success
not setting speed

@MrEd
Did you look at the hardware first using the lshw tool.

Here is mine:

[ricklinux@eos-xfce ~]$ sudo lshw -C Network
[sudo] password for ricklinux: 
 *-network
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:27:00.0
       logical name: enp39s0
       version: 15
       serial: xx:xx:xx:xx:xx:xx
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=5.8.7-arch1-1 duplex=full firmware=rtl8168h-2_0.0.2 02/26/15 ip=xxx.xxx.x.xx latency=0 link=yes multicast=yes port=MII speed=1Gbit/s
       resources: irq:38 ioport:d000(size=256) memory:fc804000-fc804fff memory:fc800000-fc803fff
[ricklinux@eos-xfce ~]$ 

Also look at

ethtool enp39s0

$ sudo lshw -C Network
  *-network                 
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: enp3s0
       version: 06
       serial: 44:87:fc:cb:4d:03
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 duplex=full firmware=rtl_nic/rtl8168e-1.fw ip=192.168.1.144 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:18 ioport:d800(size=256) memory:defff000-deffffff memory:deff8000-deffbfff memory:fbee0000-fbefffff

ethtool won’t let me change anything though
says
ethtool -s enp3s0 speed 1000
netlink error: No such file or directory
Cannot set new settings: Success
not setting speed

Are you using plasma?

Edit:
If so check the GUI network manager for auto-negotiation check box.

yup

Is the source file encrypted AND is it re-encrypted at the receiving end?

Pudge

I’m not sure the ethtool will work with the network up?

Ive tried all sorts of things.
I can’t find any relevant info on
netlink error: No such file or directory
This whole things has me baffled for 2 days now

What is the netlink error and stuff?

$ sudo ethtool -s enp3s0 speed 1000 duplex full
[sudo] password for major:
netlink error: No such file or directory
Cannot set new settings: Success
not setting speed
not setting duplex

Did you try it disconnected?

It doesn’t change anything so it doesn’t disconnect, just gives that error

No i meant did you try setting it with the ethernet disconnected. Or link down?

I don’t want to lead you down a bad path or anything but here is some info maybe it’s helpful?

I was using krdc so long, it didn’t occure to me to go to the machine and turn off nic, then run ethtool, but it still didn’t work. (had to hook up monitor keyboard and mouse)

I’m going to go through the page you posted (its a little more detailed than the one I was looking at) until my brain frys for the night.
If the commands arnt working for me, I might still be stuck, so if you think of something else let me know.