[SOLVED]Need help setting up microphone

I need to use Zoom client for my online classes. I want to connect my collar mic to my PC.
But there is no audio coming in computer, as in, softwares on my PC don’t get any audio input from the mic.
Zoom can’t get audio. I installed gnome-sound-recorder. I tried recording some audio, but all it record is a blank audio file. (though it doesn’t warn about any errors).

This is how my mic looks like:


Its got a 3.5mm jack. There is a compressor, but i never switched it on, because my phone(android) is able to record audio without the compressor, and I don’t think the pc requires a compressor (or does it?). I can guarantee that the mic itself is working. It is regularly used to record videos on phone.

The audio related ports behind my CPU look like this (yes, its old)


The leftmost port is captioned 'MIC", second one is “LINE OUT” and third one is “LINE IN”. I plug my speaker in the second port. (removed it temporarily to take the picture). I tried plugging mic in the first and third port, but no luck.

I have no experience with audio set ups, so I don’t know what related logs I should attach. I’ll provide whatever is needed.
Any help is appreciated!
Thank You :slightly_smiling_face:

Can you see your input device with pacmd list-sources ?

What is the output of hwinfo --sound? Alternatively post the output of inxi -A. Maybe you have to install inxi. So we can see, if that mic connector is showing in your system.
Install pavucontol if not already installed. Depending on your DE install the gtk2 or the qt version. It’s an easy way to configure input and output devices. In addition to that it gives you the opportunity to select which input our output device is used by a program. You can also unmute muted devices, if there are any.

What do you normally plug the 4 pin jack of the collar mic into?

A mic would normally only be 2 or maybe 3 pins

I suspect the 4th pin would be for power to the compressor and the mic is not compatible with a standard PC mic input.

if you open pavucontrol in menu or terminal , you have a setup tab with two lines of profiles. for the hardware profile you have to set to analog stereo duplex. duplex is importand for use to microphone as example

Open up PulseAudio Volume Control, and check under the configuration tab:


(set to duplex)

Also check the input devices tab and choose your microphone there:

output of pacmd list-sources
Doesn’t look like its detecting a microphone, but at the end, there is the active port
active port: <analog-input-rear-mic>

Analog stereo duplex was selected by default. The input device tab looks like this:

audiocontrol

that meter just above “advanced” keeps going up and down, probably indicating that pulseaudio is sensing the audio input.

When i record audio using gnome sound recorder, ‘Recording’ tab looks like this:

recording

But whats finally recorded is some whitenoise. No audio which i’m speaking

could this be a bug with gnome sound recorder? is there some other recording application you’d reccommend me to use while i’m testing this.

FIRST I would try plugging and unplugging your 3.5 mm input several times into both of those sockets which you have not been using just to make sure that they are not corroded.

If that corrects the problem, fine.

If not, I would try using the Gnome ALSA Mixer control found in the Multimedia section of the menu.

If you do not already have this program installed, install it by using the command:

yay -S gnome-alsamixer

(This program is contained within the Arch User Repository (AUR).)

When you open it, you will see many choices and the one(s) you need to set or adjust should be obvious.

I hope that this helps you and I wish you the best of luck.

Lawrence

1 Like

This reminds me, should i be plugging my mic into the ‘MIC’ labelled port or the port labelled ‘LINE IN’ ?
I currently have it plugged into the ‘MIC’ port.

output of hwinfo --sound

output of inxi -A

Mic port…

1 Like

You’ve probably already tried it, but maybe something from PulseAudio Troubleshooting would work? :confused:

1 Like

Can you tell us what the markings on that small switch on that large cylinder say? Maybe take a pic?

Thats the compressor. You put a button cell in there and switch it on(camera mode). I use the mic for recording on my smartphone, which doesn’t need the compressor, because smartphones deliver power through the aux input. (Don’t know if ‘deliver’ is the right word)
Usb microphones probably dont suffer from this tiny drawback because usb can for sure supply power.
For devices that don’t supply power though the audio port, external power is supplied through the compressor.

Is it that PC don’t supply power thru the input port? If that is the case then it would be necessary to use the compressor

Yes, I did read that page. The closest thing I found was the static noise issue, but I didn’t try out the fix because my pc wasn’t recording audio in the first place. Though there was still some while noise in the recordings.

Probably the switch has to be on and use battery power to work plugged into the mic jack on computer as port doesn’t supply power. Is the battery good?

Edit: It say’s right here on the website!

Using the microphone

• For Smartphone

Switch off the microphone. Slide the ON/OFF up to OFF/Smartphone

The power is shut down.

• For DSLR, Camcorders, Audio recorders, PC ect

Switch on the microphone. Slide the ON/OFF up to ON

http://www.boya-mic.com/lavaliermicrophones/BY-M1.html

2 Likes

If that is the case, then the mic won’t work for me as of now. The compressor needs a button cell, and I don’t have one right now. Plus the shops are closed due to current lockdown, so I can’t even purchase.

This may be of relevance:

Do you plug in two pins into two ports? Are both also mic/input ports?

1 Like

I also have the same mic…And it could very well be a problem relating to ports on my CPU.

Do you plug in two pins into two ports? Are both also mic/input ports?

Could you please elaborate. The mic has only one pin. Line out output goes to my speaker via an aux cable.

And thanks for sharing a very related link :smile: