[SOLVED] Need help mounting ufs drive

I’m setting up an Endeavour KDE machine to take the place of my old Nas4Free server.
I have now reach the point I need to mount the drives and copy the files from ufs drives to ext4 drives.

From what I’ve read, which there is little info I can find, stated that arch can read the information.
Any drive I plug I’ve plugged in auto mounts. I would have thought a ufs drive would have done the same, but it does not.

So I’m looking for an up to date/ easy to understand way to mount the drives.

Are there any gui tools or a package I can install to do this?

Here is some info.


Do you know what type it is? ufs2? Or something else?

In gparted it says
/dev/sdh1 ufs InfinityGem 931 GiB

I saw that link, but idk the type
but with age of post I’m sort of uncomfortable trying unless someone can confirm steps to take
so I don’t destroy anything lol

Can you simply use the file manager and click the drive?

That was the first thing I tried.

Gives error
blah blah wrong fs type blah blah blah missing codepage or helper programs or other error.

man mount

sudo mount -t ufs /dev/sdh1 /mnt

Does that work? Not sure about the ‘ufs’ type…
Do you see the data in /mnt ?

What about create a mount point first? Then:

mount -t ufs -o ro,ufstype=ufs2 “device” “mount point”


mount: /mnt: wrong fs type then rest of error as above

Being unsure of type is one of the reason I’m seeking help
…doing stuff


Works Thankyou!
sudo mount -t ufs -o ro,ufstype=ufs2 /dev/sdh1 /mnt

kinda scary when never trying that before lol

So are you able to mount and then browse using file manager?

Yes Sir!

Now it will be a LONG time to copy all these drives lol
It would be kind nice if that function was built in in Endeavour.
I know it’s something that probly not used much, but nice to have it.

What was it from BSD? or something else?

Yeah from my Nas4Free server that uses FreeBSD
I liked it as a server, it does all sorts of stuff and can boot from a usb drive if you want.
It has a web interface for all the configure stuff.

Is why I’ve mentioned in Antergos forums at one point I wish there was a server type installation that can do everything NAS4Free does.
I think it would be a nice option In the Endeavour installer as well down the road to have something like that.
I’m mostly switching because using other than ufs filesystem in Nas4Free is not recomended, which leaves out using external drives and being able to take them someplace and use on another system.

1 Like

Just curious. What are the NAS4Free functions that you are interested in EndeavourOS providing?


Yes…and it will be Endeavour4 free! Server install with ease.

Looks like now it does a few more things than when I looked at it last, but I used it for ten years or so.
It went down about a year ago and been sitting there, but I really need my media server running again lol
The main functions I had set up were

  • UPS (NUT)

  • SMB/CIFS (Samba)

  • FTP (ProFTPD)

  • MiniDLNA (Fully compliant with DLNA/UPnP-AV clients) or option to use Fuppes (for DLNA/UPnP-AV clients)

  • iTunes/DAAP server (Firefly)

  • SCP (SSH)

  • Webserver (Lighttpd)
    When mine went down, I was in the process of learning how to setup these functions

  • Software RAID 0,1,5 and mix (1+0,1+1, etc.)

  • RSYNC (Client/Server)

  • VirtualBox with WebSocket VNC server

It also sent me email of logs and stuff
It does a great many things in a reletivley small package.
Once installed, you just connect to the web-interface to mount shares or do whatever

Oh yeah forgot, they changed it to XigmaNAS I forget why.

Here is a list of key features it does

If you get a chance to tinker with it you’ll see what I mean.
I just prefer all my stuff in Arch now, but using that is what got me into switching to linux as my everyday machine.

I’m setting up a EndeavourOS KDE server that will do pretty much everything that nas did, it just takes longer to get all the setup and learning the equivalents that did those services.

There is also FreeNas? Is this an offshute? I see they are on distrowatch.

The original project I started with was FreeNAS.
They split into FreeNAS and NAS4Free
and now NAS4Free is XigmaNAS

I think the difference between the two is the size of the OS…I THINK!
One uses a chopped up stripped down version of FreeBSD, the other uses the whole OS…I THINK!

Here is an Antergos Wiki article I wrote. It covers some of the equivalent services you mentioned. I intend to revamp this for EndeavourOS after the online installer is released. So I could use the online installer as a means to install a base install of EndeavourOS.

It is a simple LAN server, no GUI or DE, strictly Command Line Instructions. Remote administration is also CLI.
Services provided as is
Rsync for data backups

This uses SSH with SSHFS for data transfers. Auto Mounts server at client boot up. Then the client Thinks the server mount point is a local directory.

Webserver (Lighttpd) I would recommend two totally separate devices for a Web server and a Lan Server for security reasons. I also have a tutorial on that if desired.

The article may contain some helpful hints on what you are doing. Then you can concentrate on the other services you want. I think it is worth a read for what you are doing.


Ooops, I had the wrong URL for the link, fixed.

1 Like

Thankyou for that, I read page 1 so far and you mentioned low power.
I was just looking into hdparm to save power, and wear and tear on the drives.

While I’m not totally committed to just command line, I’m definitely going to finish reading that.
I was also looking at Webmin in case it’s a possibility to adjust settings on a NAS type system.

It is definitely going to help me in some way, and sounds like a nice base of instructions I wish I had a couple weeks ago lol

Yes interested
Webserver (Lighttpd)

1 Like

Once the install and setup is done, the only administration I do is Updates using pacman, and backup the data using rsync. Almost forgot, once every 80 days, I have to renew my https certificate from Let’s Encrypt with CLI. I run the server headless, and do the admin remotely. This project will definitely help get one comfortable with CLI if that is one of your goals.

I use nginx as my web server engine. This is a simple static file web server, no SQL database, no PHP scripts, just serves static files. IMHO nginx is best for my purposes. If it’s good enough for the NASA Jet Propulsion Laboratory, it’s good enough for me. The tutorial files you are downloading are hosted on my web server. Along with almost all the images, etc in my posts here are also being served from my web server. Now I have total control over the images in my posts.

Look at the link when you are downloading the PDF files from my webserver. Notice the .ddns part of the URL. Keep this in mind when reading the first page.

Here is the link for the Web Server tutorial

This is actually a tutorial for installing on Fedora, so skip the installation section, and the rest should be fairly applicable except for setting up the firewall. I could redo this for EndeavourOS after the online installer is available.

Here is a pic of my Web and Lan servers.

Any questions, let me know

For some reason, the URL for the pdf did not get included in the post. fixed