[SOLVED] MicroSD card not detected

I have a brand new 32gb micro sd card.
Originally, when I first put it in the reader, it was not detected.
I used my wifi cam to format it, then I could see it in the pc.

That was/is problem 1 - Why couldn’t endeavour/arch/plasma see the card when inserted to format it?

Anyway, this card is for another device, a minicam recorder with a small lcd for my pellet gun nightvision setup.

Here is problem 2 - the device allows format of the card to record video and stills, but the only way to get the images and video off is to put the card in a PC.
Endeavour/arch/plasma cannot read the whatever filesystem it was formatted to to get the images off…I’m guessing that’s the issue.

I’ve tried a basic live boots of windows 10 (Hirens boot PE) even though it didn’t help,
I then realized I shouldn’t even have to try that at all since it defeats the purpose of switching over in the first place.

I tried opensc and a few other packages, but nothing seems to do the trick.

So, anyone been down this road with sd cards and figure out what endeavour needs to be able to read whatever filesystem the sd card was formatted to? if that is the issue.

when you plugged in the sd card did you reboot so the modules can load. These cards might show up as mmc.

dmesg | grep mmc

I thank you for making sure I didn’t skip that “just in case option”

but all it shows is my dvd drive

$ dmesg | grep mmc
[    1.263466] sr 2:0:0:0: [sr0] scsi3-mmc drive: 40x/40x writer dvd-ram cd/rw xa/form2 cdda tray

Although, if I leave the card plugged in at boot the system halts as it thinks there is a boot device there, so the system knows there is something there, just not the os it would seem.

It sounds to me like it knows the hardware is there but can’t mount the file system to read it.
What does lsblk show?

I don’t know plasma, that said I found this recent thread:

I’m tending to think you may need to add exfat-utils?

> $ lsblk
> loop0    7:0    0   216M  1 loop /var/lib/snapd/snap/natron/120
> loop1    7:1    0  55.4M  1 loop /var/lib/snapd/snap/core18/1944
> loop2    7:2    0  31.1M  1 loop /var/lib/snapd/snap/snapd/10707
> sda      8:0    0 931.5G  0 disk 
> ├─sda1   8:1    0   500M  0 part /boot/efi
> ├─sda2   8:2    0  97.7G  0 part /
> ├─sda3   8:3    0     2G  0 part [SWAP]
> └─sda4   8:4    0 831.4G  0 part /home
> sdb      8:16   0   1.8T  0 disk 
> └─sdb1   8:17   0   1.8T  0 part 
> sr0     11:0    1  1024M  0 rom

no 32gb device

exfat-utils is installed

Thanks but thats set as well. Readable drives prompt when plugged in.

I don’t think it can mount it because it’s not reading the file system? :thinking:

Edit: Of course i could be wrong!

Thats what I was thinking.
Is there any other tools to try that may be able to mount it you can think of?

Not off hand. There is a lot of info on the internet about this issue. The problem is i don’t want to see you use some commands or something that might cause havoc on your installed system. Maybe some more experienced have some idea.

Does it not also see the sd card with sudo fdisk -l

It does not,
however I do have a little more info.
I forgot I had a windows 7 machine on my back porch for music and stuff.

That machine will see the mmc card.
The card is formatted fat32, so I don’t understand why my linux machine cannot see it…

I suppose you have the ntfs-3g package installed?


What about?

ls /dev/sd*

Weather the card is in or out this remains the same

$ ls /dev/sd*
/dev/sda  /dev/sda1  /dev/sda2  /dev/sda3  /dev/sda4  /dev/sdb  /dev/sdb1  /dev/sdc  /dev/sdd  /dev/sde  /dev/sdf

Those are other drives i assume?

Edit: Have you looked at journalctl after inserting the card?

the sda’s are boot root home swap
the sdb is extra drive

I’m guessing the other ones are card reader but idk

I’m not so sure about that? This is the reason why you need to be careful or you do some havoc on your system.