[SOLVED] Microphone is detected but no sound is recorded

Hello kind folks,
I have recently installed EOS on my ASUS TUF FX505DV laptop, and I have been having issues with the internal microphone and with analog headphone mics being detected but not recording any sound except for some light static.

Just to be clear, I have the most recent versions of all packages and I’m running KDE Plasma. Here are some system data that might be useful:

inxi -Axxx
Audio:
  Device-1: NVIDIA TU106 High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: speed: 5 GT/s lanes: 8
    bus-ID: 01:00.1 chip-ID: 10de:10f9 class-ID: 0403
  Device-2: AMD Family 17h/19h HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: speed: 8 GT/s lanes: 16
    bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound Server-1: ALSA v: k5.19.6-arch1-1 running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: PulseAudio v: 16.1 running: no
  Sound Server-4: PipeWire v: 0.3.57 running: yes
arecord -l
**** List of CAPTURE Hardware Devices ****
card 1: Generic [HD-Audio Generic], device 0: ALC233 Analog [ALC233 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
~ arecord -vv -f dat /dev/null 
Recording WAVE '/dev/null' : Signed 16 bit Little Endian, Rate 48000 Hz, Stereo
ALSA <-> PipeWire PCM I/O Plugin
Its setup is:
  stream       : CAPTURE
  access       : RW_INTERLEAVED
  format       : S16_LE
  subformat    : STD
  channels     : 2
  rate         : 48000
  exact rate   : 48000 (48000/1)
  msbits       : 16
  buffer_size  : 24000
  period_size  : 6000
  period_time  : 125000
  tstamp_mode  : NONE
  tstamp_type  : MONOTONIC
  period_step  : 1
  avail_min    : 6000
  period_event : 0
  start_threshold  : 1
  stop_threshold   : 24000
  silence_threshold: 0
  silence_size : 0
  boundary     : 6755399441055744000
#+                                                 | 00%
lsmod |grep hda
snd_hda_codec_realtek   167936  1
snd_hda_codec_generic    98304  1 snd_hda_codec_realtek
ledtrig_audio          16384  1 snd_hda_codec_generic
snd_hda_codec_hdmi     86016  1
snd_hda_intel          61440  2
snd_intel_dspcfg       36864  1 snd_hda_intel
snd_hda_codec         188416  4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek
snd_hda_core          118784  5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek
snd_hwdep              16384  1 snd_hda_codec
snd_pcm               172032  4 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_core
snd                   126976  16 snd_hda_codec_generic,snd_seq,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_pcm

Alsamixer displaying all devices
image

Pavucontrol
image
(both the internal and the headphone mics are detected and unmuted, but no sound is detected from them).

I have tried several possible fixes to this problem:

  • booting from an LTS kernel does nothing;

  • no result was obtained by tweaking power settings;

  • no result was obtained by applying the required tweaks for my specific chipset in /etc/modprobe.d/modprobe.conf (Realtek ALC233).

Moreover,

arecord --duration=5 --format=dat --device=hw:1,0 test-mic.wav

works, but the only output is static.

Any help would be greatly appreciated.

…is a problematic machine, when it comes to any chipset- and related driver-issues on linux.

Do a web-search for
ASUS TUF snd_hda_intel micophone issue

Turns out, the solution was the right search string away…
From the first result for that search: https://forums.linuxmint.com/viewtopic.php?t=316400
I solved the issue by adding the following line to /etc/modprobe.d/snd-hda-intel-headset.conf and rebooting.
options snd-hda-intel model=dell-headset-multi

GG my man @ivanhoe, sometimes you just gotta teach a noob how to google.

1 Like

Please mark the post that solved the issue as the solution. This option will be available in the … options menu at the bottom of that post.
This will tell the forum software that its the solution and help future users when they are searching for the issue. There is no need to change the title in this forum.

2 Likes

Done!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.