[SOLVED] Machine won't power down. --> Intel ME Jumper

To be honest, idk if this is a kde problem or not.

I set up a new machine to upgrade from my old one.
I did a fresh endeavour/kde install, and copied my home directory from old machine to new one.

At that time, I basically had 2 identical machines, except my video card was yet in the old one.
I noticed that that machine would not shut down without actually pushing the power button.
I was sort of attributing this to a setting I may have copied over.

At present I am on the new machine and still having the problem.

When clicking shutdown in the menu, kde closes and goes to a terminal screen.
shutting down on old machine this screen only showed on one monitor,
this screen shows on 2 and just sits there.

In the begining I thought it may be the way kde might have been using the shutdown cmd so I tried these 2 cmds with the same result

qdbus org.kde.Shutdown /Shutdown logoutAndShutdown
shutdown -h now

I didn’t mean to leave my think out load notes in the post, it was getting late.

I thought I’d update though.
It seems it is shutting down from what log says

Nov 10 22:09:15 _hostname_ systemd[1]: Shutting down.
Nov 10 22:09:15 _hostname_ audit: BPF prog-id=16 op=UNLOAD
Nov 10 22:09:15 _hostname_ audit: BPF prog-id=15 op=UNLOAD
Nov 10 22:09:15 _hostname_ audit: BPF prog-id=14 op=UNLOAD
Nov 10 22:09:15 _hostname_ audit: BPF prog-id=13 op=UNLOAD
Nov 10 22:09:15 _hostname_ audit: BPF prog-id=12 op=UNLOAD
Nov 10 22:09:15 _hostname_ audit: BPF prog-id=11 op=UNLOAD
Nov 10 22:09:15 _hostname_ kernel: audit: type=1131 audit(1636600155.852:129): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=lvm2-monitor comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Nov 10 22:09:15 _hostname_ kernel: audit: type=1130 audit(1636600155.852:130): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-reboot comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Nov 10 22:09:15 _hostname_ kernel: audit: type=1131 audit(1636600155.852:131): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-reboot comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Nov 10 22:09:15 _hostname_ kernel: audit: type=1334 audit(1636600155.852:132): prog-id=16 op=UNLOAD
Nov 10 22:09:15 _hostname_ kernel: audit: type=1334 audit(1636600155.852:133): prog-id=15 op=UNLOAD
Nov 10 22:09:15 _hostname_ kernel: audit: type=1334 audit(1636600155.852:134): prog-id=14 op=UNLOAD
Nov 10 22:09:15 _hostname_ systemd[1]: Using hardware watchdog 'iamt_wdt', version 1, device /dev/watchdog
Nov 10 22:09:16 _hostname_ systemd[1]: Set hardware watchdog to 10min.
Nov 10 22:09:16 _hostname_ systemd-shutdown[1]: Syncing filesystems and block devices.
Nov 10 22:09:17 _hostname_ systemd-shutdown[1]: Sending SIGTERM to remaining processes...
Nov 10 22:09:17 _hostname_ systemd-journald[207]: Journal stopped

So… ok to hit power button I’m guessing?
It’s a long press of power button, reset button does not work

The box itself does not turn off from motherboard maybe?
Asus P8B75-M/CSM

I can’t find anything in the bios for that, and the bios is up to date

Just an update I guess
but what does
Set hardware watchdog to 10min. mean?

the hardware watchdog usually is there to monitor your system, after a certain period is up it should automatically hardware reset your pc.

I have found in a very rare case that something in kde did make shutdown a little borked, maybe try disabling plasma before rebooting to see if that helps?

I always just enter poweroff in a terminal. No need to use sudo. If you are using Yakuake that should make things very convenient. I recall the shutdown button in the Plasma menu being borked a long time ago. I just stopped using it. A drop down terminal is just as easy, especially if you are using a shell with autocompletions enabled.

Thankyou both for the replies.

I disabled KDE with
systemctl disable sddm.service

booted to terminal and still get same result.

However I have some new info that may help someone to help me track down the problem.

I got to thinking about what you said about disable KDE, but wondered what would happen if I booted to installer on usb drive and shutdown.

after loading the usb installer I get this at shutdown
these are rough notes I jotted down

Reached target poweroff
/dev/mapper/control: open failed no such device
check that mapper is available in kernal
incompatible libdevmapper 1.02.170 and kernal unknown
can't unmount /dev/loop0
can't unmount /oldrun/archiso/cowspace
reboot: power down
noveau drm:lockup-switching to software fbcon

I realize its from a usb stick but it does the same behavior as desktop does

Most info I find on those errors, search results show asus, grub messed up somehow or uefi problems.

I checked journal like this, and don’t know why I have this error

$ journalctl -p 3 -xb
-- Journal begins at Thu 2021-10-28 20:23:47 EDT, ends at Thu 2021-11-11 21:17:32 EST. --
Nov 11 20:56:07 Beholder kernel: 
Nov 11 20:56:26 Beholder kwin_x11[979]: kwin_core: Compositing is not possible

Compositing should work…idk “pulls hair”

So I’m not sure where to go from here
I hope the added information helps.

kwinrc has a setting called GLPlatformInterface=egl, some report removing this helped them, perhaps try that?

you might also try uninstalling these:

lib32-libva-mesa-driver lib32-mesa lib32-mesa-vdpau opencl-mesa libva-mesa-driver mesa mesa-demos mesa-vdpau

and than reinstall these:
mesa and lib32-mesa

I will into that, but before I do,
Tonight, I reinstalled on different drive.
Fresh install, only video drivers.
The machine will still not power off.

If you or Anyone know anything about Asus P8b75-M motherboard,
I’m wordering if the non shutdown of the motherboard is a security feature or something…maybe with Intel ME function or maybe TPM (Trusted Platform Modual)

I’m reading up on them, but I’m not sure what I’m looking for.
I’ve never had live usb of anything that does not power off the computer.

Not even sure if this is in appropriate section bc this doesn’t act like a kde problem.

wow i actually have this same problem, came here to post about it :laughing:
i noticed this happened after installing the latest kernel and the latest version of systemd. my machine doesn’t seem to shutdown either. after long-pressing the power button it shuts down, but upon rebooting the boot screen doesn’t show the “recovering journal” message that usually appears after a hard power off, so i’m inclined to think it actually halts it? or at least it doesn’t do any damage? (making a guess here).

i’m using KDE as well, if that helps. :confused:

does reset work on the box after you goto shutdown and halts…so to speak?
was only curiouse

my machine doesn’t have a reset button if that’s what you’re asking, this is a laptop I’m dealing with.
also, I’m pretty sure that this isn’t a KDE problem, maybe forum mods can move this so more people can see it? I’m almost certain it’s a kernel or a systemd issue, since i got those 2 big updates before this problem started appearing.
also @wordler , typing poweroff in the terminal didn’t solve the issues for me, but I’m curious about this: what’s the difference between typing poweroff and shutdown?

Hopefully these links will explain a few things:
I have found that in my machines I do not need to use sudo or systemctl before poweroff or reboot. On an old Arch install I think I had to use systemctl, and on a Debian-based distro I also had to use sudo.

Try this

The shutdown fix did not work.

–However I did solve this!–
I made a live usb with Knoppix on it and on exit the machine still did not power down thus somewhat confirming it was something with the mother board.

Here is why I was thinking it was something with Intel ME

A fundamental feature of the Intel® Management Engine is that its power states are independent of the host OS power states.

So, looked up Asus PB875-M mobo jumpers and sure enough, there was a disable jumper on the board.

Then after booting up, Pamac says there was an update for audit package.

Now it shuts down!

Maybe this is something could be added to the installer to detect this setting letting people know?
idk, Just thinking out loud.

Someone feel free to move this to more appropriate forum section.

hey this audit update didn’t fix things for me. :confused:

i’m using AMD btw, so the previous answer doesn’t apply to my machine. i’m not entirely sure what could have caused this, since we had some major package updates as of late. maybe i should make another thread for my issue?

According to the manual the jumper is there to disable it in order to update the IME. Enabled is default.



What the hell…?!

You have a motherboard with jumper switch for currently the most malicious technology in all hardware world? :astonished:

Fsck KDE power down, turn it off!!! :sunglasses:

1 Like

It’s right out of the 80’s!
Edit: Okay… I’m exaggerating!