[SOLVED] Is Anyone Else Having Trouble Upgrading balena-etcher?

That would be the case if the GUI one would be a wrapper for the CLI utility.

It depends how privacy conscious you are. They aren’t stealing data or anything but definitely over the line for me from a privacy perspective.

It was first reported in 2018:

Here is another:

Here are the reported sites they were connecting to:

https://www.googletagmanager.com
https://www.google-analytics.com
https://d1l6p2sc9645hc.cloudfront.net
https://api.mixpanel.com
https://data.gosquared.com
https://data2.gosquared.com
https://google-analytics.com
https://googletagmanager.com
https://connect.facebook.com
https://www.facebook.com

The final straw for me was where they acknowledged that their opt-out settings were broken but basically said they had other priorities to work on first.

Things didn’t get all that much better over a year later:

Since then, I have been unwilling to trust them from a privacy perspective. There are too many other alternative flashing tools out there.

1 Like

Test for yourself, try a big ISO etcher vs dd. I am not talking about a 5% speedup. More like 2x performance. I have never looked into why that is so it may be possible to optimize dd in a similar manner.

Well, I will. Even if that means installing that spyware :confused:

Hmm you are right, I’ve noticed they are showing adds, but I didn’t think they need to call google and others like them to show those ads.
Popsicle looks great: simple, minimal… great. Instant switch! :slight_smile:

One more thing:

$ sudo pacman -Rsnc etcher
checking dependencies...

Packages (1) etcher-1.5.94-1

Total Removed Size:  223,54 MiB

:: Do you want to remove these packages? [Y/n] 
:: Processing package changes...
(1/1) removing etcher                                                                                   [##############################################################] 100%
:: Running post-transaction hooks...
(1/3) Arming ConditionNeedsUpdate...
(2/3) Updating icon theme caches...
(3/3) Updating the desktop file MIME type cache...

223MB for a simple utility like that. Now that’s bloat. I hate Atom.

2 Likes

My balena-etcher build fails…

Installing dependencies
npx: installed 435 in 7.216s
npm ERR! cb() never called!

npm ERR! This is an error with npm itself. Please report this error at:
npm ERR!     <https://npm.community>

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/ana/.npm/_logs/2020-06-01T16_03_59_642Z-debug.log
make: *** [Makefile:97: electron-develop] Error 1
==> ERROR: A failure occurred in build().
    Aborting...
checking dependencies...
:: nodejs optionally requires npm: nodejs package manager
Have you tried the `status=progress` flag?

That’s what refuses to work well. I t usually start OK, then after a while it appears to freeze, although it does continue to the end. I end up going for a smoke break, and then reading a book, and then seeing if it finished! At least adding the beep helped a bit (sometimes I could hear it while reading).

Yes, it does that. It never was taking too long though, but maybe I just had nothing to compare it to. It is a simple core utility and works for my simple expectations.

With this balena not building I am going to be stuck forever with dd it seems :sweat_smile:

Well - I find mintstick OK, and I’m going to have a look at popsicle (now that I’ve heard of it). I was slow to change from burning a DVD, so I’m not up-to-date :grin:

Come to think of it, that applies to more than getting ISO’s ready to use!

1 Like

It is working for me. Are you using the standard version of npm and is your system otherwise up to date?

I don’t know.

ana % yay balena-etcher                                                          I
1 aur/balena-etcher 2:1.5.95-1 (+196 8.08%) 
    Flash OS images to SD cards & USB drives, safely and easily
==> Packages to install (eg: 1 2 3, 1-3 or ^4)
==> 1
:: Checking for conflicts...
:: Checking for inner conflicts...
[Repo Make: 5]  semver-7.3.2-1  node-gyp-6.1.0-1  npm-6.14.5-1  oniguruma-6.9.5_rev1-1  jq-1.6-2
[Aur: 1]  balena-etcher-2:1.5.95-1

==> Remove make dependencies after install? [y/N] y
  1 balena-etcher                    (Build Files Exist)
==> Packages to cleanBuild?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> n
:: PKGBUILD up to date, Skipping (1/1): balena-etcher
  1 balena-etcher                    (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==> n
:: Parsing SRCINFO (1/1): balena-etcher
[sudo] password for ana: 
resolving dependencies...
looking for conflicting packages...

Package (5)          New Version   Net Change

community/jq         1.6-2           0.65 MiB
community/node-gyp   6.1.0-1         6.35 MiB
community/npm        6.14.5-1       20.48 MiB
community/oniguruma  6.9.5_rev1-1    0.83 MiB
community/semver     7.3.2-1         0.08 MiB

Total Installed Size:  28.39 MiB

:: Proceed with installation? [Y/n]

Just updated it (2 packages) and will try again.

It is successfully installed :slight_smile:

1 Like

As a Gnome head, I have been using “disks” for years with no problems what so ever.

Highlight the target USB drive, click on Options, then Restore Disk Image, then navigate to the source ISO. I don’t know about speed, but it is very reliable.

Pudge

2 Likes

Try the package in the official repository:


Edit: nevermind this, it’s not going to show like that in EOS. I was sure it’s in the Arch repos, but it’s actually in the Manjaro repos.

I didn’t know that there’s another one. I already installed from AUR…

Trying to measure it’s speed, but not sure how to do that with a gui app to be honest. I set a timer for 10 mins (given that dd needs ~5 mins), but it didn’t even get to 40%…

Now it’s super-precise and scientific seconds=0;while true; do ((++seconds)); sleep 1;done :laughing: Going to stop it manually when it finishes.

Flashing it on an oldest USB stick with the whole 8GB (this thing is ancient) I could find, so it can be seen better.

Thank you for the recommendation, I didnt know Popsicle existed! Works well for me too

Hah! I’m using Disks a lot, I explicitly install it in any DE if it’s not there already.
I had no clue about that feature :slight_smile:

1 Like

I also use Etcher. Never had an issue with it.

How are you getting this to come up? I only get AUR packages.

Didn’t know about the install version. I use the app stand alone version.

cough wrong distro cough

2 Likes