[SOLVED] Is Anyone Else Having Trouble Upgrading balena-etcher?

We have several computers running EndeavourOS. This morning, on three (3) of them, so far, when we try to do our updating, everything goes fine except for balena-etcher.

Here is a screenshot of the results using yay:

Is there anyone here who is experiencing a similar problem?

Is there anyone here who knows how to fix this?

Thanks for any help.

Lawrence

1 Like

It is an issue with AUR package. They updated the shell script to use electron9 but not the sha256sum.

https://aur.archlinux.org/cgit/aur.git/commit/?h=balena-etcher&id=e5891ab101adbff42dfacf7d6574ae834f2522fe

I will report it.

You can either wait for the maintainer to fix it or tell yay to ignore the checksum

2 Likes

Dear dalto,

I will wait for the fix to be implemented. The current version which I have still works so there is no rush for me to upgrade it. Thank you very much for the quick reply.

Lawrence

1 Like

i do use etcher-bin as it is faster to update :wink:

1 Like

Ever since balena had all those privacy issues with etcher I have been bouncing around between tools.

Lately, I am using popsicle which is simple, elegant and seems to work really well.

Never heard of popsicle, it isn’t in the AUR, is it?

Edit, sorry, Yay, found it, but Pamac didn’t.

No lo he usado nunca, pero el que nunca me defraudó, a pesar de ser muy feo es imagewriter.

That is odd, do you have AUR support enabled? Alternatively, if your like me, did you spell popsicle correctly? I type it wrong almost every time. :nerd_face:

I have used imagewriter and mintstick without issue as well. But they are ugly. :grin:

They are very, very ugly :laughing:

1 Like
$ yay popsic
1 aur/popsicle-git 0.1.5.r180.g4bbdffc-2 (+3 0.00%) 
    Linux utility for flashing multiple USB devices in parallel, written in Rust

@lhb1142, the AUR maintainer just responded and said it should be fixed now.

2 Likes

Funny, I fired up pamac again and now popsicle was found… :upside_down_face:

I am pretty sure that I am using mintstick, but I never thought of it as ugly… minimal, but not ugly. Maybe it’s a matter of your theme? :grin:

Compared to dd’s minimal progress report anyway - now THAT’S ugly!

why not just using dd then? :slight_smile: It is not ugly

Or you mean it doesn’t report the progress very well? I never used anything else on Linux to be honest :sweat_smile:

The way I use, it is! I’ve got it set up to go, but it never keeps reporting progress, so I have to add and ‘’; beep" to it - now that’s ugly!

Have you tried the status=progress flag?

For me, dd tends to be quite a bit slower than some of the graphical tools. Also, I am lazy.

1 Like

What issues are we talking about? I’m using etcher. Should I worry?

Then you haven’t seen my neighbor yet, she is slow, lazy and ugly…

That seems highly improbable that a cli utility written in C is slower than gui apps…