[Solved] Grub not working after every restart

Some times ago I always set my partitions with MBR / Legacy Bios and did not having issues.

When I switch to GPT / UEFI I simply noticed the GRUB OS choosing between Endeavour / Windows 10 not appear when I restart from Endeavour: I have to turn off the pc, wait some seconds and then i can choose the os.

Endeavour is the primary os and when I restart, it starts automatically without choosing and motherboard logo it not appears.

My setup:
ASRock AB350 Gaming K4
AMD Ryzen 5 1600X
NVIDIA GeForce GTX 1070 Ti
2x GSkill F4-3200C14-8GFX

Drives (GPT):
Disk 1
120gb - Windows 10 - NTFS

Disk 2
500 MB - /boot/efi - FAT32
1 GB - swap
230 GB - Endeavour - ext4

Other 2 another data disks
Secure boot is off

Thanks! :slight_smile:

Sounds very strange.
So your motherboard supports both UEFI boot and Legacy MBR boot.
Is there a setting in the BIOS where you can change how to boot?
How do you restart the machine?
Do you have fastboot and is it disabled?

1 Like

Yes, and it’s already set on uefi mode.
I restart my machine from “Restart” button of DE (i tried KDE, Gnome, Cinnamon…same reaction) or via terminal with command “reboot”
I have fastboot and it’s disabled

If i restart from Windows, Grub works like a charm.

It can not related to distro: i tried Endeavour, Fedora and openSuse with same result (i tried those just to exclude EOS)

Have you used any special tools for grub? Like grub-customizer (which I don’t recommend…)?

Here are some general info pages:
https://discovery.endeavouros.com/system-rescue/repair-a-non-booting-grub
https://discovery.endeavouros.com/installation/how-to-install-refind

The former is useful to see through, and try to regenerate grub (if you didn’t use grub-customizer or other external tools).
The latter might be worth trying is grub problems continue.

1 Like

check all option in your UEFI

SecureBoot off
Fast Boot off
No CSM
No Legacy
all disks on AHCI
No Optane/RST

you can check in terminal

inxi -Fxza
test -d /sys/firmware/efi && echo efi || echo bios
sudo parted -l
1 Like

No, anyone :frowning:
The weird that if my pc is turned off, i turn on and boot working.

I turn off after loading every os and turn on, boot working.

If i choose EOS or another distro and want restart, boot not show mb’s logo and os choosing, switching automatically to Linux

Sure.

SecureBoot off -> OK
Fast Boot off -> OK
No CSM -> OK
No Legacy -> OK
all disks on AHCI -> OK
No Optane/RST -> OK
$ inxi -Fxza

https://pastebin.com/5bG0FLSu pwd: MgtHm3k7sM

$ test -d /sys/firmware/efi && echo efi || echo bios
efi

$ sudo parted -l
Modello: ATA DREVO D1 SSD (scsi)
Disco /dev/sda: 120GB
Dimensione del settore (logica/fisica): 512B/512B
Tabella delle partizioni: gpt
Flag del disco: 

Numero  Inizio  Fine   Dimensione  File system  Nome                          Flag
 1      1049kB  106MB  105MB       fat32        EFI system partition          avvio, esp
 2      106MB   123MB  16,8MB                   Microsoft reserved partition  msftres
 3      123MB   119GB  119GB       ntfs         Basic data partition          msftdata
 4      119GB   120GB  534MB       ntfs                                       nascosta, diag


Modello: ATA ST2000DM006-2DM1 (scsi)
Disco /dev/sdb: 2000GB
Dimensione del settore (logica/fisica): 512B/4096B
Tabella delle partizioni: gpt
Flag del disco: 

Numero  Inizio  Fine    Dimensione  File system  Nome  Flag
 1      1049kB  2000GB  2000GB      ntfs               msftdata


Modello: ATA CT250MX500SSD1 (scsi)
Disco /dev/sdc: 250GB
Dimensione del settore (logica/fisica): 512B/512B
Tabella delle partizioni: gpt
Flag del disco: 

Numero  Inizio  Fine    Dimensione  File system     Nome                  Flag
 1      1049kB  537MB   536MB       fat32           EFI system partition  avvio, esp
 3      538MB   1612MB  1074MB      linux-swap(v1)  Linux swap            swap
 2      1612MB  250GB   248GB       ext4            Linux filesystem


Modello: ATA Crucial_CT750MX3 (scsi)
Disco /dev/sdd: 750GB
Dimensione del settore (logica/fisica): 512B/512B
Tabella delle partizioni: msdos
Flag del disco: 

Numero  Inizio  Fine   Dimensione  Tipo     File system  Flag
 1      1049kB  750GB  750GB       primary  ext4

can you provide

cat /etc/fstab
pacman -Qs Grub
1 Like
$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=14F8-7ABD                            /boot/efi      vfat    umask=0077 0 2
UUID=525acade-ead7-44b3-bf75-3968237acb13 /              ext4    defaults,noatime 0 1
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
UUID=67751666-9656-406a-abce-01fa61764157  /run/media/otto/Dati      ext4  defaults                     0  2

$ pacman -Qs Grub
local/grub 2:2.04-10
    GNU GRand Unified Bootloader (2)
local/grub-tools 1.6.5-1
    Fixes, additions and enhancements to grub and os-prober.
local/grub2-theme-endeavouros 20210131-1
    EndeavourOS grub2 theme
local/python-markdown 3.3.4-1
    Python implementation of John Gruber's Markdown.

Strange issue.

I noticed a couple of somewhat interesting things in the inxi output:

  • you are using nouveau driver instead of nvidia (this likely is not the culprit)
  • your larger Crucial disk is MBR, others are GPT

What system do you have on /dev/sdd (the larger Crucial SSD)?
If that drive is possible to temporarily disconnect, does that help anything with the booting problem?

Alternatively, the booting issue might be caused by one of the disks that is giving signs of starting to fail? If that would be the case, then I suggest you make a backup (to an external disk) of all of your personal data, to be on the safe side.

1 Like

/dev/sdb is used to install data games
/dev/sdd is used as data partition (mp3, movies, documents, pictures, etc etc)

I temporaly disconnect those drives and install nvidia driver but no news :frowning:
Then i formatted my drive as gpt.

My new inxi output: https://pastebin.com/UfhdyZp5
pwd: Vt7igqMb89

Fortunately i save my date to external disk + nas :smiley: :smiley:

1 Like

Did you already answer this?
Maybe you did.

Anyway, I’m starting to have no new ideas anymore… Hopefully someone here has a better idea what to look for. My current guess is a hardware issue, but that is simply a guess, nothing more.

1 Like

Yes, I already answer that and i don’t use any special tool :frowning:

Don’t worry, I hope too but I really appreciated your help and availability! Thank to you I touched some critical points and taking courage for format my drive as GPT :smiley:

1 Like

It could be useful?

$ sudo efibootmgr
BootCurrent: 0002
Timeout: 1 seconds
BootOrder: 0002,0004,0001,0000
Boot0000* boot
Boot0001  EndeavourOS
Boot0002* UEFI OS
Boot0004  Windows Boot Manager

You want to switch the boot to 0001

sudo efibootmgr -o 0001,0004,0000,0002

1 Like

It worked first reboot but then, the second time has changed automatically :s

BootCurrent: 0001
Timeout: 1 seconds
BootOrder: 0001,0002,0004,0000
Boot0000* boot
Boot0001* EndeavourOS
Boot0002  UEFI OS
Boot0004  Windows Boot Manager

EndeavourOS should control the boot and gives you the grub menu for EndeavourOS and Windows.

How about if i deactivate 0002 and 0000?

You can by using efibootmgr also to remove them.

sudo efibootmgr -b bootnum -B

Edit: bootnum is the number you want to remove

1 Like

It works!

At the first time, I deleted:

Boot0000* boot
Boot0002  UEFI OS

with the command sudo efibootmgr -b bootnum -B

Then at the first reboot, system recreated UEFI OS and forced to activated it.

For resolving that problem, I disabled UEFI OS
(sudo efibootmgr -b 0005 -A)

Now the (working) situation is:

$ sudo efibootmgr
BootCurrent: 0001
Timeout: 1 seconds
BootOrder: 0001,0004,0005
Boot0001* EndeavourOS
Boot0004  Windows Boot Manager
Boot0005  UEFI OS

(boot order by bios is only with EndeavourOS, I disabled other options)

Problem solved!

Thank you very much! :smiling_face_with_three_hearts:

2 Likes