[SOLVED] Grub not working after every restart cause UEFI OS

I want follow my last issue with a new related one: [Solved] Grub not working after every restart

Turning my pc on, GRUB is loading with any issue, but when I restart my pc, I can’t see motherboard logo and GRUB to choose my os between Windows 10 or Endeavour OS.

My actual situation:

$ sudo efibootmgr
BootCurrent: 0001
Timeout: 1 seconds
BootOrder: 0001,0004,0005
Boot0001* EndeavourOS
Boot0004  Windows Boot Manager
Boot0005  UEFI OS

At that point I delete 0005:
sudo efibootmgr -b 0005 -B
and I can restart properly, but that entry recreated automatically and next restart has broken again…

How can I delete UEFI OS entry definitely? I really starting to hate UEFI :rofl:

Don’t hate UEFI it’s better in many ways!

sudo efibootmgr -b 0005 -B

Edit: The entry may come back anyway and i wouldn’t worry too much about that as long as the boot order is correct. You want EndeavouOS to handle the boot with grub entries for Endeavour and Windows. UEFI does keep those entries when you boot on different devices or drive.

Edit2: If you delete the entry and get booted up into EndeavourOS you could also run the command.
sudo grub-mkconfig -o /boot/grub/grub.cfg

1 Like

Excuse me, I wrote bad but I already tried to delete it with -B (i edited my first post: sorry).

You are right about that entry but If i delete it every time, the problem is solved. Now I set a cron that delete UEFI OS every time I want restart ahaha (kidding)

Let me to try grub-mkconfig

Thanks in advance, choom!

Situation after delete entry and grub-mkconfig:

$ sudo efibootmgr
BootCurrent: 0005
Timeout: 1 seconds
BootOrder: 0005,0001,0004
Boot0001* EndeavourOS
Boot0004  Windows Boot Manager
Boot0005* UEFI OS

UEFI is a mutant! :smiley:

Check in your UEFI Bios and make sure the order of boot is also set to the proper drive that EndeavourOS is installed on. You can set the boot order there and it depends on the manufacturer of the board and Bios how it’s set up.

There was:

  • EndeavourOS

I edited:

Then I disabled the second one but after OS loading, entry was recreated again…
I’m just start thinking I have weird option on the bios

Or if Win10 is trying to load something wrong?

any boot by UEFI start like this
UEFI: on any motherboard

save a profile for windows
another one for linux

recheck all option in your UEFI in case profile Linux

SecureBoot off
Fast Boot off
No Legacy
all disks on AHCI
No Optane/RST

you can check in terminal

inxi -Fxza
test -d /sys/firmware/efi && echo efi || echo bios
sudo parted -l
sudo efibootmgr -v
1 Like

My UEFI Bios has two area’s to set the boot. The first one is boot options and the second one shows boot order below it? So i have to make sure the last one is the one that sets the boot order. The first one is boot options and second is the priority.




Edit2: Sorry for the crappy images. As you see i am booting from rEFInd.

Edit3: Also i can disable any of them that i don’t want.

1 Like

I checked all points and there are okay.

Here is the output :wink: (password: ILoveEndeavour)

Thank you!!!

Thank you man. I really appreciated you restarted or turn on your pc for me! <3

Mine is working at the same way, so I activated EndeavourOS as first choice and then Windows Boot Manager :slight_smile:

How is rEFInd? Is it a replace of Grub?

Solved, guys!

In a really weird way…

Surfing on the net, I found this post:
speaking about a bug.

I done those steps:

$ sudo vi /etc/default/grub
uncommented GRUB_TERMINAL_OUTPUT=console
$ sudo grub-mkconfig -o /boot/grub/grub.cfg
$ sudo reboot

Problem still persist, so I recovered situation:

$ sudo vi /etc/default/grub
commented GRUB_TERMINAL_OUTPUT=console
$ sudo grub-mkconfig -o /boot/grub/grub.cfg
$ sudo reboot

“Ok, la la la, I’m working on my pc… oh no, I need to download some binaries on Windows, i need to restart”

I restarted with any issue.
I restarted again, no issue…
Again… no issue…

I really don’t know what’s happened, just believing my Uefi is a monster :smiley:

Thanks you guys, really. I appreciate your help <3

It works well the way i have it set up as a triple boot all on different drives.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.