(SOLVED) External command finished with errors (Installation Failed)

I am trying to install endevour on my old laptop. (2nd try)
But about 50% in, it gives this error and stops the installation: i.imgur.com/LsS8Srs.png
What is this? I am running in BIOS mode.

Thank you in advance.

Hello @groovy08
Welcome. When you say old laptop are you able to provide the hardware info. You can post the output of inxi -FGz

Also here is some info on how to include and or post logs.

Hardware Information:
http://ix.io/2psl

The error code listed in the OP has mkinitcpio referring to linux-lts not found. I didn’t know that you could specify the LTS kernel. How is that happening?

Pudge

1 Like

I haven’t touched anything relating to the linux kernel. Strange.
I only removed gtop, screenfetch and neofetch.

The hardware info doesn’t seem to give the memory. How much memory does it have just curious? Also how did you go about the install? Is there anything else on the laptop? Did you create the partitions manually? Please give a little detail.

Edit: Also are you using wifi to install?

1 Like

Htop says that my memory is 3.65G
I am using wifi.
I used the online installer.
I created the partitions manually because I needed swap space.
I used korean keyboard layout but with english as language.

Are you using the whole drive to install on? Or not? Just wondering what partitions you created as the laptop is Bios and not UEFI?

I used all of /dev/sda.

Okay then if you are going to use all of the drive it would be better to use gparted and use device create partition table gpt. Then you can either close gparted and start the installer and do manual partitions or use erase disc with swap and it will automatically create the needed partitions. But if you want a home partition you’ll have to do the manual partition way.

Edit: I’m asking you to try it this way as sometimes the Calmares installer has issues with creating the file system.

1 Like

Why GPT?
Why not DOS?

You can use DOS.

I never knew I can use erase disk option with swap :sweat_smile:
I will try re-installing. Thanks.

It still may be better to open gparted first and created a new partition dos and then close it and run the installer and with erase disc with swap. Otherwise you might get another fail and have to do it anyway. Just a suggestion. It may be okay…i can’t say.

Thanks a lot! The installation was successful.

1 Like

Excellent! Glad it worked for you. Welcome to the EndeavourOS forum!

I have one question as i noticed the WiFi chip you have is a Ralink. Do you have wifi on the install because it isn’t well supported so sometimes they don’t want to work depending on the vendor of the chip.

So are you asking why am I using wifi in install?
Sorry. My native language is not english.

I was asking you if the wifi is working after the install worked.

Yes. The wifi was working fine with my kubuntu install.