[SOLVED] Cups server error

(translated from the original post)

Trying to install the printer I get this error:

I tried reinstalling the cups packages and the epson drivers, the strange thing is that with other arch versions and with other linux distributions I can install it and print. I noticed that with other versions when starting system-config-printer it is initially locked and to add the printer you have to enter the administrator password.

I understand that the problem is
RuntimeError: ppdOpenFile failed

but I can’t find any ppd file and I can’t even fix the connections with the printer.

Also at http://localhost:631 I can see the printer but then I can’t print.

I also searched in the wiki to see if there was any info that could solve it but I didn’t find anything.

If anyone has any ideas they are welcome.

Here is the output from system-config-printer debugging
system-config-printer --debug 2>&1 | tee log.txt

password: XXtEY8wdMd

Then I ran the command: driverless
ipps://EPSON%20ET-2720%20Series._ipps._tcp.local/

I tried running:
lpadmin -p Epson-ET-2720_Series-epson-escpr-en -E -v ipps://EPSON%20ET-2720%20Series._ipps._tcp.local/ -m everywhere

And I got this result:
lpadmin: Unable to connect to “EPSONB148FC.local:631”: Unknown name or service

I tried this command as well:
ipptool -tv ipps://EPSON%20ET-2720%20Series._ipps._tcp.local/ get-printer-attributes.test > ipp-attrs.txt

with this output:
ipptool: Unable to connect to “EPSONB148FC.local” on port 631 - Unknown name or service

nmap localhost -p 631

Starting Nmap 7.91 ( https://nmap.org ) at 2021-06-15 10:39 CEST
Nmap scan report for localhost (127.0.0.1)
Host is up (0.00013s latency).
Other addresses for localhost (not scanned): ::1

PORT STATE SERVICE
631/tcp open ipp

the printer is connected via network, for this reason I did the test with nmap on the printer port, when ipptool and lpadmin gave me the error on the connection; anyway the drivers via aur are these epson-inkjet-printer-escpr-1.7. 10-1 and I installed them via yay

I also checked on the epson site to see if there was the updated version around but they are not there yet for arch, you would have to convert the deb or rpm to get the 1.7.11 version.

I even reset all the cups files with the .conf extension with the default ones, just to make sure the settings are clean.

at the end i tried the solution offered by this topic but it doesn’t work because the service is called by other name:

$ sudo systemctl enable org.cups.cupsd.service
Failed to enable unit: Unit file org.cups.cupsd.service does not exist.

The name of the service is cups.

sudo systemctl enable cups

Nothing to do, error still persists :frowning:

Solved!

Editing this file /etc/nsswitch.conf and add the bold part:
hosts: … mdns_minimal [NOTFOUND=return] resolve [!UNAVAIL=return] dns …

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.

has the hint to enable local hostname resolution also :wink:

1 Like

Thank you! user told already checked that :S no words

1 Like