Errore del server cups

Provando a installare la stampante ho questo errore:

Ho provato a reinstallare i pacchetti cups e i driver epson, la cosa strana è che con altre versioni arch e con altre distribuzioni linux riesco ad installarla e stampare. Ho notato che con le altre versioni quando si avvia system-config-printer è inizialmente bloccato e per aggiungere la stampante bisogna inserire la password da amministratore.

Capisco che il problema sia su RuntimeError: ppdOpenFile failed ma non trovo nessun file ppd e non posso neanche sistemare i collegamenti con la stampante.

Anche su http://localhost:631 riesco a vedere la stampante ma poi non riesco a stampare.

Ho cercato anche nella wiki per vedere se c’era qualche info che poteva risolvere ma non ho trovato nulla.

Se qualcuno a qualche idea e ben accetta.

Quali driver hai installato?
Hai già provato con questi https://aur.archlinux.org/packages/epson-inkjet-printer-escpr/ ?

Sì, sono quelli i driver che avevo installato alla versione 1.7.10-1.

Aggiorno il post:
ho usato il comando: system-config-printer --debug 2>&1 | tee log.txt

Poi ho eseguito il comando: driverless
che ha dato questo risultato:
ipps://EPSON%20ET-2720%20Series._ipps._tcp.local/

Ho provato pure ad eseguire il comando:
lpadmin -p Epson-ET-2720_Series-epson-escpr-en -E -v ipps://EPSON%20ET-2720%20Series._ipps._tcp.local/ -m everywhere

ma ho avuto questo risultato:

lpadmin: Unable to connect to “EPSONB148FC.local:631”: Nome o servizio sconosciuto

Ho provato pure questo comando:
ipptool -tv ipps://EPSON%20ET-2720%20Series._ipps._tcp.local/ get-printer-attributes.test > ipp-attrs.txt
avendo come risposta nel terminale questa:
ipptool: Unable to connect to “EPSONB148FC.local” on port 631 - Nome o servizio sconosciuto

ho controllato col comando:
nmap localhost -p 631

Starting Nmap 7.91 ( https://nmap.org ) at 2021-06-15 10:39 CEST
Nmap scan report for localhost (127.0.0.1)
Host is up (0.00013s latency).
Other addresses for localhost (not scanned): ::1

PORT STATE SERVICE
631/tcp open ipp

La stampante è collegata tramite USB o via rete?

Nel primo caso prova a dare:

sudo pacman -S cups cups-filters cups-pdf ghostscript gsfonts foomatic-db-engine foomatic-db foomatic-db-ppds foomatic-db-nonfree foomatic-db-nonfree-ppds gutenprint foomatic-db-gutenprint-ppds system-config-printer

e a riavviare la macchina.

Come hai installato i driver da AUR?

la stampante è connessa via rete, per questo motivo avevo fatto il test con nmap sulla porta della stampante, quando ipptool e lpadmin mi hanno dato l’errore sulla connessione; comunque i driver via aur sono questi epson-inkjet-printer-escpr-1.7.10-1 e li ho installati tramite yay, ho anche controllato sul sito epson per vedere se a giro c’era la versione aggiornata ma ancora non ci sono per arch, andrebbero convertiti i deb o gli rpm per avere la versione 1.7.11. Ho persino resettato tutti i file cups con l’estensione .conf con quelli di default, solo per essere sicuro che le impostazioni siano pulite.

Il problema è questo: che non riesce a copiare i file ppd, e il system-config-printer ho provato ad eseguirlo anche col “sudo” davanti per capire se poteva essere una questioni di permessi, ma nulla da fare.

Non abbiamo lo stesso modello ma ricordo di aver avuto anche io dei problemi.

Uso gli stessi driver: per fare una prova ho installato da zero Endeavour per una situazione pulita (avevo pasticciato un po’ all’epoca e non volevo compromettere il risultato) e ha funzionato in questo modo.

Installati i driver:

yay -S epson-inkjet-printer-escpr

Dal menu principale delle applicazioni (se non ho visto male usi KDE):

  1. voce Stampanti
  2. Rimuovi tutte le stampanti configurate
  3. voce Fai clic qui per aggiungere una nuova stampante
  4. Stampanti di rete rilevate > EPSON ET 2720
  5. Aggiungi manualmente l’indirizzo di rete e scegli un’altra voce qualsiasi (altrimenti non si attiva il bottone Avanti )
  6. Riseleziona Stampanti di rete rilevate > EPSON ET 2720 e clicca su Avanti
  7. Attendi l’elenco dei driver per selezionare poi Driver consigliati > EPSON ET 2720 etc
  8. Clicca su Fine

Fammi sapere :slight_smile: anche io avevo smanettato sulla console di Cups ma non era andata

immagina di fare tutto bene fino al punto 6 del tuo elenco solo che quando clicchi su avanti appare l’errore del server cups, sul portatile dove uso endeavours io uso un sistema pulito perchè ho installato il sistema da pochi giorni a parte il tema grafico non ho installato nulla di strano, però con la versione di arch che usavo prima non avevo questo problema, prima usavo salientos e blackarch. Uso Xfce sono fedele alla “topa” ;-). Ho provato a scaricare dalla fonte i driver epson-inkjet-printer-escpr-1.7.10-1lsb3.2.tar.gz per poter recuperare il file ppd che in fase di installazione dovrebbe copiare nel sistema. Ma anche se lo aggiungo io manualmente non vado avanti di molto perché dopo mi dice che manca un filtro della stampante che non è installato. Se non ho capito male il file ppd contiene i dati sui margini e sul tipo di carta e il filtro dovrebbe contenere i livelli di inchiostro e cose simili.

Con questi comandi io cerco di installare la stampante da linea si comando senza usare system-config-printer ovvero il programma che gestisce la stampante. La stampante mi viene sempre rilevata e dopo che quando dovrebbe installarla si blocca e da errore.

ho provato ad aggiungere la stampante rimuovendo tutte quelle vecchie sia provando l’installazione da:

  1. system-config-printer (programma di gestione delle stampanti classico);
  2. lpadmin (comando da usare nel terminale);
  3. localhost:631 (usare il browser);

Oggi ho voluto riprovare da zero, ovvero ho reinstallato il sistema cancellando il vecchio, il risultato per la stampante non cambia, di seguito metto i comandi usati prima della prova.

$ sudo pacman -S cups cups-filters cups-pdf system-config-printer --needed
attenzione: cups-1:2.3.3op2-3 è aggiornato e sarà ignorato
attenzione: cups-filters-1.28.9-1 è aggiornato e sarà ignorato
attenzione: cups-pdf-3.0.1-6 è aggiornato e sarà ignorato
attenzione: system-config-printer-1.5.15-1 è aggiornato e sarà ignorato
non ci sono aggiornamenti disponibili

$ sudo pacman -S ghostscript gsfonts foomatic-db-engine foomatic-db foomatic-db-ppds foomatic-db-nonfree foomatic-db-nonfree-ppds gutenprint foomatic-db-gutenprint-ppds --needed
attenzione: ghostscript-9.54.0-2 è aggiornato e sarà ignorato
attenzione: gsfonts-20200910-2 è aggiornato e sarà ignorato
attenzione: foomatic-db-engine-4:20200206-1 è aggiornato e sarà ignorato
attenzione: foomatic-db-3:20210528-1 è aggiornato e sarà ignorato
attenzione: foomatic-db-ppds-3:20210528-1 è aggiornato e sarà ignorato
attenzione: foomatic-db-nonfree-3:20210528-1 è aggiornato e sarà ignorato
attenzione: foomatic-db-nonfree-ppds-3:20210528-1 è aggiornato e sarà ignorato
attenzione: gutenprint-5.3.4-1 è aggiornato e sarà ignorato
attenzione: foomatic-db-gutenprint-ppds-5.3.4-1 è aggiornato e sarà ignorato
non ci sono aggiornamenti disponibili

$ sudo systemctl enable --now cups.service

$ yay -S epson-inkjet-printer-escpr

Prova a stoppare cups
sudo systemctl stop cups.service

e poi
Dal menu principale delle applicazioni

  1. voce Stampanti
  2. Rimuovi tutte le stampanti configurate
  3. voce Fai clic qui per aggiungere una nuova stampante
  4. Stampanti di rete rilevate > EPSON ET 2720
  5. Aggiungi manualmente l’indirizzo di rete e scegli un’altra voce qualsiasi (altrimenti non si attiva il bottone Avanti )
  6. Riseleziona Stampanti di rete rilevate > EPSON ET 2720 e clicca su Avanti
  7. Attendi l’elenco dei driver per selezionare poi Driver consigliati > EPSON ET 2720 etc
  8. Clicca su Fine

Per curiosità ho voluto provare anche manjaro per capire se dava questo problema ma li la stampante funzionava, manjaro mi dava altri problemi più legati al wifi che qui non ho, comunque ritornando a noi.

Ho provato a fermare il servizio col comando
$ systemctl stop cups.service
ma quando avvio $ system-config-printer per mettere la stampante

(lasciando stare l’errore grammaticale del messaggio di n al posto di un) se clicco su connetti vado qui

non ci sono altri percorsi per il server cups e se clicco su connetti

si ritorna al punto di partenza, senza ne anche aggiungere la stampante.

Che strano… su Manjaro usi sempre XFCE?

si uso sempre xfce, e vedendo a giro mancherebbe da controllare i file .conf del cups ma avevo provato in precedenza e non aveva cambiato nulla. Era da tanto tempo che non avevo problemi così.

Prova così:

sudo systemctl enable --now cups.service
systemctl status avahi-daemon

Se il secondo comando ti dà errore, allora:

sudo pacman -S avahi --needed
sudo systemctl start avahi-daemon
sudo systemctl enable avahi-daemon

e, alla fine, riavvia la macchina.

Mi dispiace per il problema :s hai installato Endeavour aggiungendo anche il supporto alle stampanti?

Si ho fatto l’installazione con l’online per poter scegliere le cose da installare per non farlo dopo e avevo scelto le cose base, xfce e il supporto stampante. Se provo la versione offline non mi parte dopo l’installazione rimane con lo schermo nero.

Comunque mi da sempre l’errore…

C’è qualcosa che mi sfugge e sicuramente sarà una cavolata :persevere:
Se vuoi traduco tutto in inglese e inserisco il post nella directory dedicata :slight_smile:

mi faresti un favorone, poi credo che se si trova la soluzione viste tutti passaggi fatti potrebbe diventare fonte per una bella guida.

Cerco di mettere insieme tutte le informazioni e ti taggo nel topic nuovo dedicato

Ho preparato il post: prima di pubblicarlo, però, volevo giusto farti fare un’ultima prova:

Sostanzialmente dovresti:

yay -S cups cups-pdf hplip libcups system-config-printer epson-inkjet-printer-escpr xsane
sudo groupadd lpadmin sudo usermod -aG lpadmin logan

(sostituisci logan con il tuo username)

sudo leafpad /etc/cups/cups-files.conf

prima

# Administrator user group, used to match @SYSTEM in cupsd.conf policy rules...
# This cannot contain the Group value for security reasons...
SystemGroup sys root wheel

dopo…

# Administrator user group, used to match @SYSTEM in cupsd.conf policy rules...
# This cannot contain the Group value for security reasons...
SystemGroup sys root wheel lpadmin
sudo systemctl enable org.cups.cupsd.service

e ora riavvia il pc per rendere effettive le modifiche

sudo reboot

Se così non funziona, inserisco il post :wink: