…So why doesn't Bluedevil install with KDE Plasma?

Hi there. Long-time Arch user, first-time EndeavourOS caller.

So I noticed during the installation process, the Bluetooth elements required to make it list in KDE Plasma settings isn’t a thing which can be added during installation. Why does the Bluetooth stuff for this distro require extra steps?

I’ve been using other Arch-based derivatives for a little while now, from my limited experience other desktops using KDE come with BlueDevil as part of their setup because it adds into KDE’s settings app the Bluetooth section which most people would use for configuring such remote devices. Were there previous issues with Bluedevil EndeavourOS team couldn’t overcome?

This is a good question. I hadn’t even noticed it was missing, as I had not to this point connected anything to my Desktop using Bluetooth. Sure enough, I checked to see if it was installed, and it was not. I then checked my Laptop which has vanilla arch that I installed using the new “archinstall” script, and it was there.

For me, I just installed it on my desktop, and it works(and bluez).

On a side note, welcome to the forum.

They do state on the release page and the wiki about Bluetooth

Bluetooth is enabled in the Live environment – Now you can check if Bluetooth is working on your hardware if you want to run EndeavourOS, however after install Bluetooth is disabled by default. We have created a new Bluetooth button that directly links you to our wiki on the installed system.

1 Like

It seems, even if EndeavorOS disables Bluetooth for security reasons, in the KDE version this should be installed. You cannot enable bluetooth until this is installed in KDE (in my case). There may be other software interaction that I am overlooking, thus this was the easiest way to disable it.

1 Like

bluetoothctl works just fine. But you have to enable bluetooth.service first. This is the series of steps one must take in order to make it happen. The only extra thing is installing BlueDevil but on other distros I’ve used bluetoooth service is enabled by default. Seeing this absolutely blew my mind. Feel free to reference this post any time someone asks How the devil do I get [B]luetoth working in KDE?:

sudo pacman -Syu bluedevil
sudo systemctl bluetooth enable
sudo $EDITOR /etc/bluetoooth/main.conf

Page down until you see #AutoEnable, don’t forget to remove the comment and set it to true. Save and exit, reboot, Bluetooth in KDE works properly.

If you just want to get it working now minding these are universal directions for any instance with bluez-utils then this:

sudo systemctl enable bluetooth
sudo systemctl start bluetooth
bluetoothctl

[bluetooth]#
Replace AA:BB:CC:DD:EE:FF with your device MAC address.

power on
scan on
pair AA:BB:CC:DD:EE:FF
trust AA:BB:CC:DD:EE:FF
connect AA:BB:CC:DD:EE:FF
exit
3 Likes

I was adding my 2 cents, which is probably only .5 cents anyway.

On my bluetooth, to connect to a Bose Soundlink II device, that did not work even. As soon as I installed Bluedevil it worked. I still on rare occasion have to restart the bluetooth service, if my laptop sleeps, and/or plug my Bose into a charging cable to connect again. It may be something with my device.

Something else must need to be done either outside of bleutoothctl or within it that I had not discovered in my scant use of that tool to use the command line. Either that or you hadn’t used power on in bluetoothctl and Bluedevil just does that on your behalf.

But I will iterate my original point: Bluedevil should be an option for KDE Plasma in Calamares.

1 Like

I didn’t say it outright, but I was trying to agree :slight_smile:

Thank you for reporting this. Bluedevil was installed by default in previous releases, this is clearly a mistake from our side.

1 Like

EnOS’ Calamares installs a minimal KDE Plasma. To me it seems this has been by “design choice”.

Also:

We have created a new Bluetooth button that directly links you to our wiki on the installed system.
https://endeavouros.com/latest-release/
:arrow_down:

However:

DEs like KDE/plasma and GNOME ship their own Bluetooth GUI by default.

from the wiki page linked above doesn’t seem to be entirely correct when it comes to KDE Plasma since
bluedevil is not part of the plasma-desktop package.

At any rates, for future installations, any desired packages not explicitly installable by choices given in the installer, could be added to user_pkglist in the liveuser home directory.

3 Likes

Archinstall installs plasma-meta which comes with a lot of bloat goodies.

As said before, it is something we overlooked. We will release our bugfix release Apollo neo very, very soon.

1 Like

Well, in its defense, bluedevil seems like an obvious one to include(it leaves out bluez, so it doesn’t work out of the box). But I will say whoever decided on what goes into that group, and what doesn’t was off their rocker a bit…why is discover included? But then kcalc and spectacl not?

kcalc and spectacle are part of my installation. Not sure what you’re on about, probably some metapackage that comes with it…

Using the archinstall script? Or EOS? EOS includes it, the arch installation does not unless you add it your self at the end.

Perhaps because:

discover >> plasma group
spectacle, kcalc >> kde-applications group

?

:sweat_smile:

1 Like

Fair enough on spectacle and kcalc being in a different group/meta package, but I feel like Discover should be there too or at the very least not included in plasma-meta since this is arch we are talking about after all.

1 Like

Please don’t integrate something like this by default, otherwise I’ll have to go to the trouble of uninstalling it again after a new installation! Less is more.

I love EOS also for the fact that it does not bring every shit, otherwise I could take Manjaro or Mint …

1 Like

It was always there previously.

1 Like

Right.

A bit of an awkward choice, I think, for the developer of the archinstall:

  1. plasma-meta

  2. plasma (group)

  3. plasma-desktop

They seem to have gone big for making the installed system “user-friendly”, I guess :man_shrugging:t5:

On my Arch-BTW-installs, if I am to go with plasma, I choose plasma-desktop and take it from there.

3 Likes