Slow wired internet in KDE Plasma

Hello Endeavour!

For some reason my desktop running endeavourOS with Plasma seems to have big big hickups in just light internet browsing. It’s using a wired connection to my hub and then to my router. I should have around 200/200mbit, and my other devices runs fast and painless on the internet.

Is there some setting I might have overlooked, or something along those lines? I have Mullvad VPN but for the most part it’s turned off.

I remember a post on the Manjaro forums about a year and a half ago about people having inexplainable slowdowns in the internet on Arch should try disabling IPv6 and only use IPv4. No idea why, but it helped a lot of people there.

Unfortunately their old forum is no longer in use so I can’t link to the post.

inxi -Fxxxz

would help people to help you :upside_down_face:

System:    Kernel: 5.11.13-arch1-1 x86_64 bits: 64 compiler: gcc v: 10.2.1 Desktop: KDE Plasma 5.21.4 tk: Qt 5.15.2 
           info: polybar wm: kwin_x11 dm: SDDM Distro: EndeavourOS base: Arch Linux 
Machine:   Type: Desktop System: Gigabyte product: Z490 AORUS PRO AX v: -CF serial: <filter> 
           Mobo: Gigabyte model: Z490 AORUS PRO AX v: x.x serial: <filter> UEFI: American Megatrends v: F3 date: 03/25/2020 
CPU:       Info: 10-Core model: Intel Core i9-10850K bits: 64 type: MT MCP arch: Comet Lake rev: 5 L2 cache: 20 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 144040 
           Speed: 4901 MHz min/max: 800/5200 MHz Core speeds (MHz): 1: 4901 2: 4902 3: 4861 4: 4433 5: 4900 6: 3251 7: 4870 
           8: 4507 9: 4848 10: 3559 11: 4846 12: 4800 13: 4800 14: 3187 15: 1898 16: 4800 17: 4837 18: 1887 19: 1985 20: 4896 
Graphics:  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] driver: nvidia v: 460.67 bus ID: 01:00.0 chip ID: 10de:1c03 
           class ID: 0300 
           Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: loaded: nvidia resolution: 1: 1920x1080 
           2: 1680x1050~60Hz s-dpi: 87 
           OpenGL: renderer: GeForce GTX 1060 6GB/PCIe/SSE2 v: 4.6.0 NVIDIA 460.67 direct render: Yes 
Audio:     Device-1: Intel Comet Lake PCH cAVS vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:06c8 class ID: 0403 
           Device-2: NVIDIA GP106 High Definition Audio driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:10f1 
           class ID: 0403 
           Device-3: Focusrite-Novation Focusrite Scarlett 2i2 type: USB driver: snd-usb-audio bus ID: 1-11.2:6 
           chip ID: 1235:8016 class ID: fe01 
           Device-4: Kingston HyperX 7.1 Audio type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-13.3:10 
           chip ID: 0951:16a4 class ID: 0300 serial: <filter> 
           Sound Server: ALSA v: k5.11.13-arch1-1 
Network:   Device-1: Intel Comet Lake PCH CNVi WiFi driver: iwlwifi v: kernel bus ID: 00:14.3 chip ID: 8086:06f0 
           class ID: 0280 
           IF: wlan0 state: down mac: <filter> 
           Device-2: Intel Ethernet I225-V vendor: Gigabyte driver: igc v: kernel port: 3000 bus ID: 05:00.0 
           chip ID: 8086:15f3 class ID: 0200 
           IF: enp5s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
           IF-ID-1: virbr0 state: down mac: <filter> 
Bluetooth: Device-1: Intel type: USB driver: btusb v: 0.8 bus ID: 1-14:9 chip ID: 8087:0026 class ID: e001 
           Message: Required tool hciconfig not installed. Check --recommends 
Drives:    Local Storage: total: 6.95 TiB used: 1.19 TiB (17.1%) 
           ID-1: /dev/nvme0n1 vendor: Intel model: SSDPEKNW010T9 size: 953.87 GiB speed: 31.6 Gb/s lanes: 4 rotation: SSD 
           serial: <filter> rev: 001C temp: 33.9 C scheme: GPT 
           ID-2: /dev/sda vendor: Kingston model: SV300S37A120G size: 111.79 GiB speed: 6.0 Gb/s rotation: SSD 
           serial: <filter> rev: BBF0 scheme: GPT 
           ID-3: /dev/sdb vendor: Toshiba model: HDWD240 size: 3.64 TiB speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> 
           rev: 0A scheme: GPT 
           ID-4: /dev/sdc vendor: Samsung model: HD502HI size: 465.76 GiB speed: 3.0 Gb/s serial: <filter> rev: 1118 
           scheme: GPT 
           ID-5: /dev/sdd type: USB vendor: Seagate model: Expansion size: 1.82 TiB serial: <filter> rev: 0707 scheme: MBR 
Partition: ID-1: / size: 937.6 GiB used: 789.63 GiB (84.2%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-2: /boot/efi size: 299.4 MiB used: 284 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 34.0 C mobo: N/A gpu: nvidia temp: 54 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 21% 
Info:      Processes: 401 Uptime: 4h 21m wakeups: 0 Memory: 31.28 GiB used: 5.3 GiB (16.9%) Init: systemd v: 248 Compilers: 
           gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1446 Shell: fish v: 3.2.1 running in: konsole inxi: 3.3.01 

You got it!


It looks like it negotiated to 100 Mbps. Unless you are using a 100 Mbps switch/hub, this is bad.

In network manager, change negotiation to manual and set it to 1000 Mpbs full duplex.


And if the speed has dropped to 100Mb then it is most likely a cable fault. @beerbelly : got another ethernet cable you can try ( a known good one )?

1 Like

There was a firmware update for the ethernet on that board if i have the right one. i225-v 2.5 GbE Firmware version 1.45 Not sure what version it is running. Maybe: sudo dmesg | grep firmware
That may or may not have any bearing on the slow speed. You could also check sudo dmesg | grep igc for some info on its current settings.

It definitely isn’t negotiating a proper link speed. Maybe reset the router and the networkmanager.

Hmmm my firmware is:

[    3.723058] iwlwifi 0000:00:14.3: loaded firmware version 59.601f3a66.0 hr-b0-59.ucode op_mode iwlmvm

Looks very different :smiley:

I tried this, and it does seem to have helped my internet speed. It was oddly specific for general browsing too, torrenting and gaming both went fine.

Anyway, it does seem to be fixed. Thank you a whole bunch!


I swapped cables before trying Daltos recommendation, and it didn’t seem to make a difference - but my cable always worked fine before heh

1 Like

That is your wifi firmware, not your ethernet.

Still always worth checking… :upside_down_face:
Cables are sometimes overlooked, you never know.

I had an incident once, when i wasn’t very hip to whole debug game…
And i throw out Nvidia GPU just to realize later with the new one - it was a cable issue which started for some voodoo reason :sweat_smile:

Have you tried changing the speed using ethtool?

Doesn’t he already have it working by changing the speed in network manager?

I guess i am confused by the answer? :thinking:
Sorry, maybe it is then.