Slow Internet speed at speedtest.net

Short version
I pay for 120 down
my wife on Windows can get pretty close to this, I however seem to be capping at about 35 - 40 down
I therefore assume it’s on my end, not sure how to begin troubleshooting it though

Is the Windows machine connected via Ethernet and the Linux machine via WiFi?

No, both are connected via Ethernet.

1 Like

These potential reasons come first in mind:

  • ethernet cables (try changing the cables)
  • drivers (please show the output of: lspci -vnn | grep -A8 Ethernet)
1 Like

Also keep in mind that many ISPs will prioritise traffic to speed test sites to make you think you are getting your full line speed.

It’s possible that they recognise the Windows browser traffic and give full line rate for that, but don’t recognise the Linux browser and so don’t prioritise that traffic.

And yes - if this is happening to you then this means your ISP is monitoring your Internet traffic. :wink:

4 Likes

And if it doesn’t happen - it still means that your ISP monitoring it :rofl: :alien:

That’s actually good idea, and makes sense…

@Lancaban try something out of your country, for example here i’ve found some russian speedtest clone, i doubt it prioritizes anything outside of Russia, wonder how it will go for you:
https://2ip.ru/speed/

Just press blue Тестировать button

Here’s another one

P.S. Although i’m not in Russia, results are about 15-20 Mbit/s lower than Speedest :upside_down_face:
Not that i care too much, coz i have 500 Mbit/s connection.

2 Likes

I wonder if there are some open-source ISP-agnostic way to measure real down / up speed in terminal or something…?

Something trustworthy :thinking:

2 Likes

Torrenting? Get almost my entire bandwidth every time, no matter which distros ISO I download.

Steam always maxes it out too just fine. Though that’s far from open source. :sweat_smile:

1 Like

For me not even close to full, it’s still limited…

Max-speed i’ve seen on a single torrent is ~38 Mbit/s, so to fill my 500 Mbit/s you’d need a lot of super-speedy torrents :laughing:

I’m relatively close to Russia and with decent amount of peers, I could easily max out mine at 93.6 Mbps out of the 100 Mbits I pay for. Steams highest was 96.8 Mbps.

I have a feeling my ISP might not give a hoot on what I do, since it took them legal threats from the government to finally block certain websites with illegal content.

3 Likes

The first suspect is the cable. try using the wife’s cable if possible.
I had the same problem. Apparently when a cable gets damaged, instead of downright not working, the protocol gracefully degrades from gigabit to 100mbs

1 Like

Wow! Woke up this morning and had a TON of replies I’ll tackle them one at a time

[james@Kalevala ~]$ lspci -vnn | grep -A8 Ethernet
04:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
        Subsystem: ASUSTeK Computer Inc. Device [1043:8677]
        Flags: bus master, fast devsel, latency 0, IRQ 35, IOMMU group 20
        I/O ports at f000 [size=256]
        Memory at fc904000 (64-bit, non-prefetchable) [size=4K]
        Memory at fc900000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: r8169
        Kernel modules: r8169, r8168

As for ISP monitoring, I don’t “think” that’s the problem as I was getting full speed yesterday before my most recent reinstall, I also tried testing again with my VPN which normally gets within a couple MB’s of my full speed and got the same result.
I expect a LITTLE drop-off with the VPN of course, but with or without it I’m getting 1/3rd of my normal speed.

As for speed tests, I use several I’ll link them here in case others are interested.
https://www.cfspeed.com/

https://speedof.me/api/doc/sample1.html (the API of above with more configuration options)
https://testmy.net/

1 Like

The Ethernet driver might be the reason. You could test it:

Install (or reinstall) package r8168 and reboot. If it helps, then great!
Otherwise uninstall r8168 and reboot.

You should see which driver is active on the

Kernel driver in use:

line.

2 Likes

Mines good on the r8169 module with fibre optic cable.

[ricklinux@eos-plasma ~]$ lspci -vnn | grep -A8 Ethernet
27:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 15)
        Subsystem: Micro-Star International Co., Ltd. [MSI] X570-A PRO motherboard [1462:7c37]
        Flags: bus master, fast devsel, latency 0, IRQ 38, IOMMU group 26
        I/O ports at d000 [size=256]
        Memory at fc804000 (64-bit, non-prefetchable) [size=4K]
        Memory at fc800000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: r8169
        Kernel modules: r8169
[ricklinux@eos-plasma ~]$ 

Screenshot_20201005_104418

2 Likes

For speed measurement, I do not recommend speedtest.net, but an FTP connection from a trusted nearby server.

Alright uninstalling r8168 did the trick, thank you!!

5 Likes

Here’s another:

  1. Download (once)
    wget -O speedtest-cli https://raw.githubusercontent.com/sivel/speedtest-cli/master/speedtest.py
  2. Make script executable (once)
    chmod +x speedtest-cli
  3. Test speed in terminal with
    speedtest-cli
  • See options with
    speedtest-cli -h
3 Likes