Shadow of mordor

i ocne more have to ask for aid.
i have some problems with shadow of mordor.
trying to start it with wine staging it opens the game on a blackscreen with sound.
i tried some common windows fixes that didnt work.

than i was able to play a few hours with lutris no problem but upon restarting my pc lutris does not work either, lutris used lutris-6.0-rc1-x86_64, no options changed all the default.

almsot forgot, when i start the game via the terminal i get:

 Mordor GOTY/x64/ShadowOfMordor.exe' 
0594:fixme:heap:RtlSetHeapInformation 0000000000E20000 0 000000000021EC50 4 stub
0594:fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
0594:fixme:wtsapi:WTSRegisterSessionNotification Stub 00000000000A005C 0x00000001
0594:fixme:win:RegisterPowerSettingNotification (00000000000A005C,{a7ad8041-b45a-4cae-87a3-eecbb468a9e1},0): stub
0594:fixme:win:RegisterPowerSettingNotification (00000000000A005C,{5d3e9a59-e9d5-4b00-a6bd-ff34ff516548},0): stub
0594:fixme:win:RegisterPowerSettingNotification (00000000000A005C,{ba3e0f4d-b817-4094-a2d1-d56379e6a0f3},0): stub
05a4:fixme:thread:SetThreadIdealProcessor (FFFFFFFFFFFFFFFE 1): stub
05ac:fixme:thread:SetThreadIdealProcessor (FFFFFFFFFFFFFFFE 3): stub
05a8:fixme:thread:SetThreadIdealProcessor (FFFFFFFFFFFFFFFE 2): stub
05b0:fixme:thread:SetThreadIdealProcessor (FFFFFFFFFFFFFFFE 1): stub
05b4:fixme:thread:SetThreadIdealProcessor (FFFFFFFFFFFFFFFE 2): stub
05b8:fixme:thread:SetThreadIdealProcessor (FFFFFFFFFFFFFFFE 3): stub
0594:fixme:wtsapi:WTSUnRegisterSessionNotification Stub 00000000000A005C
0594:fixme:system:SystemParametersInfoW Unimplemented action: 59 (SPI_SETSTICKYKEYS)
0594:fixme:system:SystemParametersInfoW Unimplemented action: 53 (SPI_SETTOGGLEKEYS)
0594:fixme:system:SystemParametersInfoW Unimplemented action: 51 (SPI_SETFILTERKEYS)

and it ends with " failed to initialize client unable to load game resources"

any help would be appreciated

Try to use GloriousEggroll

The native version crashed constantly. I didn’t make it out of the main menu. 5.0.9 caused weird desktop issues I’ve never seen before (my icon tray fully visible during play) and no online. GE-7-ST makes the game run exactly as it would on Windows, easily running 60fps at Ultra

© https://www.protondb.com/app/241930


That’s some voodoo magic :upside_down_face:

how do i use proton? when i try to launch anything in the terminal with it it says “no compat data path?”

Good question, it depends :slight_smile:

How you’ve installed the game initially with Lutris or Steam?

well, neither i have it isolated on the second internal drive.

Not sure i follow…

Since you’ve launched it with Lutris, it should be installed somewhere in wineprefix which you’ve created before somehow

i did not install the game with steam, i did not install the game with lutris, i have added the game TO lutris with its default, not changing anything.

Yes, but how exactly you’ve added it, from where?

Anyways…If you can launch it with Lutris, what you should do:

  1. Close Lutris

  2. Download GloriousEggroll.tar.gz, extract it

  3. In there find dist folder, rename it to something ike proton-5.21-GE-1-x86_64

  4. Paste this folder to ~/.local/share/lutris/runners/wine/

  5. Launch Lutris

  6. Select game, Right :mouse: Button -> Configure

    Runner options tab:

    Wine version - choose proton-5.21-GE-1-x86_64

  7. Try to play and see how it goes

1 Like

i added it via the plus button? im not sure what else to say, like rpeviously mentioned its on the other drive.

like before when i try to launch the game it says launching for a few seconds and than just stops.

So it’s what, like game installed in some folder with Windows on NTFS disk or something?

+ button implies that you should previously either:

  1. Installed game via Lutrix
  2. Installed game via Steam

Because for game to properly work it must be inside proper wineprefix, i’m kinda amazed you’ve launched it before somehow and it worked…

You can read more here on why and how…

Or just install game by clicking install and opening it with Lutris, just make sure that you have all the stuff mentioned in requirements section

Sorry, not sure how else i can help :slight_smile:

1 Like

i hoenstly dont know what else i can say, so again
i added the game via the lutris plus button, there was no installation done, no steam no nothing
installation implies i did more than just add the games folder via the intended option, which i didnt do

i dont think id want to do step 4 since i dont wanna mess up my hardware accell thing again.

id rather not

i never really had problems, since lutris is for exactly such a purpose? why else would ti have the add a game plus button?

Lutris is just a GUI tool for managing games and Wine versions. You still need to have the game folder in a proper wineprefix with whatever dependencies the game requires.

than why did lutris work before?
why doesnt it say anything about it when its aopparently such a important step?

Lutris scripts do that for you, unless you’re trying to install a Steam game. In this case Shadow of Mordor only has the Steam script available, for the native Linux port (which is garbage and you’d want to run the game with Proton).

If you’re using another solution for the game, you’ll manually have to create a wineprefix and get it running that way.

my main drive is not nearly big enough for it, i have all of my games isolated on another drive.
id very much like to avoid using steam directly if i can, even if it is through lutris.

I’m assuming your other drive is properly formatted to use on Linux. It should be possible to create a wineprefix on there and store the game there. In the thread, you’ll find scrips which can make the prefix for you and install winetricks if needed. @keybreak might have to correct me, but I think you just change the paths to reflect the drive you want to use.

well…im kinda lost at step 2 already…

this thread is kinda WAY above my paygrade…

@Oziach
Yeah technically you can change PREFIX variable in create-prefix.sh to whatever destination you need and then just symlink it to ~/.PlayOnLinux/wineprefix


@AmandaONeill
Sorry, i’d like to help and i kinda know a lot more friendlier way of creating prefix, but i don’t want to rush release of my real script (including simple GUI) right now until i test it really hard.

For now it’s cleanest way in that guide, but you’d have to change some stuff in scripts.
There are plenty of other wine tools available, but they’re really messy.

1 Like

changing stuff in scripts is bay far way more than i coudl do…i wouldnt even knwo where to begin even with thatn guide, but thank you for all of you alls help.

id liek to refer to this agian to see if there would be another solution to that that we havent discussed yet? since it opens, sound palys, just no video/blackscreen