Scroll speed too fast since update

This unnatural speed is across all apps (Thunderbird mail, LibreOffice Writer), browsers (Waterfox, Firefox, and Chromium), all scroll nearly an entire screen with one notch of the scroll wheel, it’s just about impossible to navigate and extremely frustrating.

I can’t find any setting to tweak this either.

It’s a Logitech M705, had it for years, the issue started squarely since rebooting after the latest update.

Operating System: EndeavourOS
KDE Plasma Version: 5.26.5
KDE Frameworks Version: 5.101.0
Qt Version: 5.15.7
Kernel Version: 6.1.2-arch1-1 (64-bit)
Graphics Platform: X11
Processors: 8 × Intel® Core™ i7-6700K CPU @ 4.00GHz
Memory: 31.3 GiB of RAM
Graphics Processor: NVIDIA GeForce RTX 2060 SUPER/PCIe/SSE2

You need to use xinput to change the libinput Scrolling Pixel Distance property.

First, find out the device id of your mouse by running xinput list. You should get something like this

After that, list out all the properties of your device by running xinput list-props <device_id>. Replace <device_id> with the id of your mouse.

Scroll down the list and see if you can find a property called “Scrolling Pixel Distance”. If there is, take note of its current value, and then you set it to a smaller value with:

# 10 is just a dummy value. Pick a number that is smaller than your current setting
xinput --set-prop "libinput Scrolling Pixel Distance" 10

Test out your mouse. If you’re happy with it and want to make the setting permanent, just add the command to a script to be launched at startup.

Hope this helps.

Thanks for the help. I tried adjusting the settings for my Logitech M705 using “libinput Scrolling Pixel Distance”, I tried changing the value up and down, I tried a couple other settings too, even tried settings on other devices that were similarly named, but nothing ever changed the scroll speed.

I recorded a narrated video of myself doing all the above, to show that it’s not working. I hope there’s something else that can be done.

I dual boot Windows 10 and the same mouse works perfectly fine, the scroll speed and all other behaviour has not changed. It’s worth noting that in Windows 10 (and only ever since Windows 10, didn’t have this problem in Windows 7) the scroll wheel scrolls too fast until I turn “Smooth scrolling” ON, then back OFF again, and the scroll speed is normal. Yet I’ve never had an issue in Endeavour OS until this update.

I know the mouse is old now, maybe I’ll just have to bite the bullet and buy a new one. Wish my partner wasn’t wasting my income right now, things are tight.

1 Like

It looks like the latest kernel update may play a role in your issue, check out the discussion here:

If you are able to temporarily run the LTS kernel until it gets resolved that might provide some relief.


That’s good to know, hopefully it’s fixed soon.

I used “akm” and installed and booted into the LTS kernel, and it hung on a message “Failed: TLP startup / shutdown”
I had set TLP_ENABLE=0 in /etc/tlp.conf to solve a sleeping HDD issue so I renabled that, and heck, it still hung at the same point in the boot, just didn’t show that message! I took a photo and manually typed out at what point the boot hung;

Starting systemd-udevd version 252.4-2-arch
/dev/nvme0n1p5: recovering Journal
/dev/nvme0n1p5: clean, 676433/3932160 files, 14569601/15728640 blocks

What’s worse, after I booted back into the current kernel, is the laggy HDD issue came right back! So I’ve set TLP_ENABLE=1 and rebooted again.

So the LTS kernel isn’t an option for me it seems.

linux 6.1.3.arch1-1 is available. Maybe upgrade the kernel and see if the issue is fixed?

1 Like

Damn, yes it is fixed. Between posts I noticed the update notification, so I updated. I’m back after a reboot and it’s fixed. Whew!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.