HDD constantly being spun down

I’ve returned to update on this issue I posted which has been automatically closed, see below;

I can hear the drive spinning down very soon after it’s just been in use, that distinctive “tink” of the HDD head parking, and then whenever I do anything that involves that drive, the system locks up, I hear the drive spin up again, and several seconds later, the system is allowed to continue doing what it was doing.

It’s definitely Endeavour OS spinning my drive down. Here’s how I know why;

  • This behaviour happened very suddenly after a recent system update (see original post)
  • I’ve just replaced that old 1TB drive with a Seagate Ironwolf 4TB drive, and the exact same behaviour is happening.
  • What’s really telling, is this doesn’t happen in Windows whatsoever. (I’m dual booting Windows 10)

I’ve even tried
sudo hdparm -S 0 /dev/sda
to disable sleep entirely, and it doesn’t help.

1 Like

If you haven’t changed anything TLP should be installed. TLP - ArchWiki (archlinux.org)

You could try uninstalling/disabling it.

Thanks man, yes tlp was running, and now I have edited /etc/tlp.conf and set TLP_ENABLE=0, and “tlp-stat -s” shows that it has been disabled now. I’ll see how it goes over the next few days of use. (Hard to tell right away if it’s working)

One thing I did notice, which is really suspicious (and annoying) is in gnome-disk-utility (Disks), that 4TB drive has a “zzz” icon next to it, and the other drives don’t! And it disappears when I do something to access that disk.

Also, selecting the disk and clicking the 3 little dots icon, the “Wake-Up from Standby” option is available! And on the other drives, this option is greyed out, and instead the “Standby Now” option is available.

Annoyingly, going into the “Drive settings” from there, shows “Apply Standby Timeout Settings” is off. I’ve turned it on, and set the slider to “Never”. And yet in my initial tests, the “zzz” icon still comes and goes with the disk activity.

But I haven’t actually seen the computer lock up waiting for the disk just yet. That will take time to notice. Just thought I would add this because it’s even more information that something is being done to this specific drive regarding standby mode!

Actually just disabling TLP could make a reverse effect, in case of disks, but we’ll see… :upside_down_face:
Have you tried my advice before?

Ah, thank you for reminding me. Well now that I’m fiddling with tlp I guess it’s a good idea to try. I’ll give it a few days with the current changes to see what happens, then try that, so I can be sure of what made a difference.

Like, how is THIS even possible???

Since setting TLP_ENABLE=0, I haven’t noticed the delays anymore…

Though I have to mention - the zzz’s still show up as in the screenshot (gnome-disk-utility). Does anyone know what it could mean - why the zzz icon shows up even though I have standby set to “Never”? And if it really does correlate to drive being spun down into standby?