Screenshot program problem with imgur

As i am using screenshoot and share imgur often, in the process of learning endea linux.

Issue1: Imgur not working
I randomly faced "share to > imgur " not working.

When i took the screenshot, share it to imgur works for the first time; if i take the 2nd screenshot to share to imgur again, it will no work.


This is what it happens:
when i
took screenshot > share button > imgur
instead of sharing to imgur, it just open the screenshot with gwenview.

The only thing i can do in gwenview is to save the screenshot as a file in my system.
Even in gwenview, i can only use “copy to or move to” to save my screenshot as a file on local folders. Inside the “share” button on gwenview, there is no “imgur” option in it.

I tried many times with imgur not working, but now, when i try again, imgur works consequencely for 3 times… i can’t explain nor know why… only can say randomly not working; when experienced not working, it will continue be not working with screenshot.

its always possible the services are offline :wink:

can randomly happend it does not work, you can always ‘save as’ to keep it.

pacman -Qs kipi-plugins , check if that is installed. there is more online services i believe these way.

but doesnt mather which screenschooter , the connection to the imgur service can be faulty is sometimes hard or on the server side is full.

this kipi plugin is to give Gwenview more share option ? including imgur ?

kipi-plugins give spectacle more share options dont know exact, but sometimes a network give a issue idk
so it can fail.

When i just installed Endea os, share screenshot to imgur is working good, but lately it never work. Whenever i share to imgur, it just opens out gwenview.

Any idea why ?
I don’t even understand how imgur let me post my pic into their server in the first place, i didn’t even sign in or set up endea for imgur. It just works out of the box! But now it failed to work constantly.

Is there somewhere on endea os lays the setting for imgur acc ?

You probably need an account on imagur?

https://imgur.com/signin?

Your two topics on this subject have been merged together. Please don’t create duplicate topics for the same issue.

3 Likes

Imagur is working fine for me you have to register to use it. I just dragged this photo to imagur waited for it to upload double clicked image on the next screen clicked copy on message boards then pasted on this box

I haven’t been able to replicate that problem through multiple tries of hosting screenshots to imgur with the screenshot application on Xfce. Each time it goes through successfully. Sorry

1 Like

Does it require an account first to use it?

No, it does not support associating uploaded images with an imgur.com account.

Screenshot_2020-10-03_20-07-29

1 Like

Sorry. I forgot i posted it before.

Working for me with spectacle:

I have an imgur acc. When i logged in using firefox, i can upload and whatever in it works.

How ever when i do screenshot using “print screen” it does not work.

OK, to make sure my question is valid , i tried both “print whole screen” and “print rectangular area” 2 types.
The conclusion is : “print whole screen” able to share to imgur - no problem
However “print rectangular area” failed to share to imgur everytime, at least the time I am trying it.
I have being having this problem for quite a few weeks i think… even before i posted the previous post regarding this issue. (i have no time , hence chuck it aside)
Please look into photos for detail.

Print “rectangular area” (failed):


select rectangular area to be print screened.


see i selected share to imgur.


Then it failed to upload to imgur, but it open gwenview (instead of showing me the url)

This is Print whole screen and share to imgur - working fine…


See! with a successful uploading to imgur, it provides the link to the img.

I also tried to search for the location where i can let the os signed imgur (it is common sense to need to sign in to use the service, however in this case there is no sign in?! )


I don’t know where to sign in in this Endea linux… there is an “online accounts” when i use Krunner to search for “account”, however there is “NO accounts added yet” inside it. Since i can share whole screenshot to imgur, surely to register or signin imgur is not nessacery, else both (print whole screen and print rectangular area) should not work altogether already.

According to @ogrefriend you do not need an account to post to imagur. That is why i asked someone who uses it as i don’t. It works for me without an account. Also taking a screen print of a “rectangular area” also works for me and gives me a link for imagur the same as it does taking a screen print of the “whole” screen or “Active” area.

@ricklinux Can i ask you about Timeshift settings ? I don’t really 100% understand how to set, being careful abt it.
Shld i create a new thread or just a chat and get it done with. ?
Just came from youtube, and some webpages… webpages are of no help.
Youtube did help some, but i still not 100% sure… hence need some help explaining . question are of : location, users and filters tab.

I’m just not sure you understand how the program spectacle works to take a screen print and share to imagur?

Press print screen and it opens up spectacle. Change the setting to rectangular region.

Click on take a screenshot. The box opens up asking you to click and drag a rectangular area.
Double click the rectangular area you have just created. Click on export and share to imagur.

It creates the image link and copies it to the clipboard. You can then save it by clicking on save as which will open the spectacle save window which is in the folder you are saving it to and you can change the name of the file if you want.

Otherwise click on the drop down box and click save and it will keep the same name it assigned.Or you can just click save as and in the window at the bottom click save if you aren’t changing the name. Doesn’t matter.

As for using it with an account i don’t see it should be any different.

Edit: Hope you understand this and it should put an end to this problem with imagur. If you want to ask about Timeshift please open a new thread with the topic about Timeshift. I am not that well versed with Timeshift but others are.

1 Like

Yes, this is right. All these is done rightly.


Pls take a look at the photo, it is uploaded to imgur automatically (and provide me the imgur link and copy that link to clipboard) when i clicked “export>share>imgur”
This above is called “working”.
while the above - earlier post shows example that does not work . because it didn’t manage to post to imgur.

I know exactly how spectacle works. There are 2 ways to make it works.:
1 method is just either run “spectacle” itself or press “print screen” to call spectable and select “rectangular area” then the rest are the same as above mentioned.
2nd method is to use “global shortcut” . Please notice, my global shortcut for rectangular area screenshot is “meta+shift+Print screen” . I have being using this shortcut button to do rectangular… and EVERYTIME i use it, it does not post to imgur… instead it just open up the screenshot using gwenview.

**I just found out (when you mentioned open spectacle and select “rectangular area”) open spectable to print screen using “rectangular area” works fine in posting to imgur… only the global shortcut method failed to post.
:neutral_face: At least now i have narrowed it down that Global shortcut method to do rectangular area print screen fails to post to imgur. There is a bug in this method.

Well i don’t know all the ins and outs of spectacle. I use it mainly for screen shots and i don’t post to imagur. Just trying to help you out. I can only say that not always does everything work or work as expected! Just keep that in mind!

1 Like